Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 05-15-2014, 01:39 PM
Member
My Jeep: 2012 WK2
 
Join Date: Mar 2012
Posts: 775
Thanks: 4
Thanked 18 Times in 16 Posts
Rep Power: 1231784
2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute
Re: EVIC - "4WD shift in progress"

Quote:
Originally Posted by sigep0435 View Post
That's what I thought as well, but up until this point, I was never able to tell that I was in 4WD, if that makes sense. Now, when making a slow turn, such as in a parking lot, there is a "binding" feeling, the steering gets tight, and it takes more throttle to get through the turn. It's been completely smooth up until this message started appearing today.
Yep, that makes sense. Definitely shouldn't feel any binding unless you were in 4WD Low.
__________________

__________________
Reply With Quote
  #14  
Old 05-15-2014, 02:39 PM
Premium Member
 
Join Date: Feb 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 312
sigep0435 is on a distinguished road
Re: EVIC - "4WD shift in progress"

Quote:
Originally Posted by 2012 Summit View Post
Yep, that makes sense. Definitely shouldn't feel any binding unless you were in 4WD Low.
10-4, thanks for the replies, I'm going to take it in this afternoon and I'll update when I know more for others that may search this issue.
__________________

__________________
Reply With Quote
  #15  
Old 05-15-2014, 03:32 PM
Member
My Jeep: 2012 WK2
 
Join Date: Mar 2012
Posts: 775
Thanks: 4
Thanked 18 Times in 16 Posts
Rep Power: 1231784
2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute
Re: EVIC - "4WD shift in progress"

Quote:
Originally Posted by sigep0435 View Post
10-4, thanks for the replies, I'm going to take it in this afternoon and I'll update when I know more for others that may search this issue.
Good luck and please do keep us posted.
__________________
Reply With Quote
  #16  
Old 05-15-2014, 10:21 PM
Premium Member
 
Join Date: Feb 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 312
sigep0435 is on a distinguished road
Re: EVIC - "4WD shift in progress"

When leaving to take it to the dealer, it was stuck in 4wd low. It wouldn't not shift out of 4wd low no matter what I did. Soon thereafter, I got the "service 4wd system" , "service air suspension" , and "4wd not available" messages. After power cycling the Jeep several times, the transfer case shifted to neutral and would not let me change that, regardless of what I tried. Had to "push" it out of a parking garage, down to a tow truck, and off to the dealer it went. This all occurs less than a week after I get it back from the dealer after my driver's side headlight went out. That fix took two weeks overall and pretty soon, they will have it longer than me as I just took delivery early April. To be continued...
__________________
Reply With Quote
  #17  
Old 05-16-2014, 04:52 AM
Member
 
Join Date: Sep 2013
Posts: 399
Thanks: 24
Thanked 28 Times in 24 Posts
Rep Power: 1125
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Damn. Sorry to hear of your travails.

Of course, now I really dislike seeing this message flash for a second on my EVIC... it's something that not everyone sees, and at least one vehicle that displays it repeatedly has a cacked transmission.
__________________
Reply With Quote
  #18  
Old 05-22-2014, 02:24 PM
Premium Member
 
Join Date: Feb 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 312
sigep0435 is on a distinguished road
Re: EVIC - "4WD shift in progress"

I got my Jeep back yesterday and my issues stemmed from a bad "transfer case shift position sensor". I can also confirm that the message "4WD Shift in Progress" does not flash up anymore.
__________________
Reply With Quote
  #19  
Old 05-22-2014, 04:57 PM
Premium Member
 
Join Date: Sep 2013
Posts: 575
Thanks: 2
Thanked 68 Times in 51 Posts
Rep Power: 6357
Peter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond repute
Re: EVIC - "4WD shift in progress"

I just started getting the "4WD shift in progress" message for a second when I first start up as well. Not every time...but often enough. No binding that I can feel though.
__________________
Reply With Quote
  #20  
Old 05-23-2014, 12:31 AM
Member
 
Join Date: Sep 2013
Posts: 399
Thanks: 24
Thanked 28 Times in 24 Posts
Rep Power: 1125
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Quote:
Originally Posted by Peter_K View Post
I just started getting the "4WD shift in progress" message for a second when I first start up as well. Not every time...but often enough. No binding that I can feel though.
I know I am probably biasing people by asking, but for those of you seeing this message from time to time, how's your fuel economy been since it's been happening?
__________________
Reply With Quote
  #21  
Old 05-23-2014, 05:30 AM
Member
My Jeep: 2012 WK2
 
Join Date: Mar 2012
Posts: 775
Thanks: 4
Thanked 18 Times in 16 Posts
Rep Power: 1231784
2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute2012 Summit has a reputation beyond repute
Re: EVIC - "4WD shift in progress"

Quote:
Originally Posted by sigep0435 View Post
I got my Jeep back yesterday and my issues stemmed from a bad "transfer case shift position sensor". I can also confirm that the message "4WD Shift in Progress" does not flash up anymore.
Thanks for the update.
__________________
Reply With Quote
  #22  
Old 05-23-2014, 06:49 AM
Premium Member
 
Join Date: Sep 2013
Posts: 575
Thanks: 2
Thanked 68 Times in 51 Posts
Rep Power: 6357
Peter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond repute
Re: EVIC - "4WD shift in progress"

Quote:
Originally Posted by Roadkill View Post
I know I am probably biasing people by asking, but for those of you seeing this message from time to time, how's your fuel economy been since it's been happening?

Well, I have the Hemi so unless it drops by half I'm not going to notice it being anything but awful anyway

Interestingly the message started popping up a week or so after my transfer case was replaced due to a "groaning" noise when reversing. No more groaning noise...but this one will probably explode
__________________
Reply With Quote
  #23  
Old 05-23-2014, 02:09 PM
Premium Member
 
Join Date: Feb 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 312
sigep0435 is on a distinguished road
Re: EVIC - "4WD shift in progress"

Quote:
Originally Posted by Peter_K View Post
Well, I have the Hemi so unless it drops by half I'm not going to notice it being anything but awful anyway

Interestingly the message started popping up a week or so after my transfer case was replaced due to a "groaning" noise when reversing. No more groaning noise...but this one will probably explode
Well...it's funny that you mention the groaning noise when backing up. I noticed this as well on the morning that all of my problems started. It wasn't very pronounced, but I did notice it and wondered "what now!?" Then as the day ensued, everything went down hill. Hasn't done it since the sensor replacement though.
__________________
Reply With Quote
  #24  
Old 05-27-2014, 09:31 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 622
Timick1 is on a distinguished road
Re: EVIC - "4WD shift in progress"

This has been happening to my Jeep lately. I've noticed it 2 times when first starting it. The message only appears for a quick second.


Sent from my iPhone using JeepGarage
__________________

__________________
2014 Jeep Grand Cherokee Overland, 4x4, 6cyl, Billet Silver / Indigo Blue
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EVIC message - 4WD not available transmission overheated grandriver125 2014+ Cherokee-KL 43 09-25-2014 01:21 AM
Service 4WD on EVIC. ALPINEST4RS Troubleshooting/Problems 7 05-04-2014 02:02 PM
Shift procedure 4WD HI WK2007 Technical Tips/DIY/How-To 3 10-05-2012 08:54 PM
Chris's "OG Status" 5.9 Progress Thread.. Redsand Members Rides 25 04-01-2010 07:15 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.