EVIC Issue - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-03-2011, 10:17 AM
Member
My Jeep: 2010 2.4L FC
 
Join Date: Apr 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2584
tbechtel is on a distinguished road
EVIC Issue

I leave the EVIC displaying my speed when driving. When I use the navgation the turn by turn info also displays in the EVIC display. After the turn is made the EVIC display goes back to the menu rather than the speed display that was previously displayed.. At first I thought I accidently hit a button so I made sure my hands wern't anywhere near the buttons. Everytime the navigation clears from the EVIC display the EVIC goes to menu rather than the previously displayed screen. I have to hit the button on the steering wheel each time to re-display the speed function. Just curious if anyone has this issue.

Thanks

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-03-2011, 10:34 AM
Member
 
Join Date: Jun 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2132
zecstone is on a distinguished road
Re: EVIC Issue

Same problem. Doesnt happen always. Did you have it checked yet?
Reply With Quote
  #3  
Old 09-03-2011, 10:55 AM
plynn7's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Nov 2010
Location: Delaware County,PA
Posts: 409
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 2913
plynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond reputeplynn7 has a reputation beyond repute
Re: EVIC Issue

I have the same issue, does not happen all the time, so it's that that big of a deal for me.
__________________
2014 Deep Cherry Red Overland V6 Tech Package
Previous Jeeps:
11 GC Overland V6
08 GC Limited Hemi
04 GC Larado V6
Reply With Quote
  #4  
Old 09-03-2011, 03:48 PM
Member
My Jeep: 2010 2.4L FC
 
Join Date: Apr 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2584
tbechtel is on a distinguished road
Re: EVIC Issue

Mine happens everytime I use the Nav now. Collecting things to be checked so I only have to go to the dealer once for all issues. Added to the list. Obviously a software bug somewhere in the system. Was just curious if others have the same issue or whether mine was unique.
Reply With Quote
  #5  
Old 09-03-2011, 04:40 PM
suprand's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Aug 2010
Location: Chicago
Posts: 240
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2667
suprand is on a distinguished road
Re: EVIC Issue

I think its a very common issue
Reply With Quote
  #6  
Old 09-04-2011, 07:12 AM
Eric67's Avatar
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2011
Location: The Netherlands
Posts: 258
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2339
Eric67 is on a distinguished road
Re: EVIC Issue

Which nav do you guys have ?

I have no issues (730n REW)
Reply With Quote
  #7  
Old 09-04-2011, 07:42 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2010
Location: Ottawa, Ontario
Posts: 962
Thanks: 32
Thanked 16 Times in 12 Posts
Rep Power: 3862
Cherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond reputeCherodude has a reputation beyond repute
Re: EVIC Issue

I have not seen this with 430N Nav. Always returns to the previous EVIC screen (knock on wood).
__________________
2011 GC OL, Natural Green/Frost, QL, ORGII, 430N, Pano, GY WSA
Reply With Quote
  #8  
Old 09-04-2011, 09:55 AM
Member
My Jeep: 2010 2.4L FC
 
Join Date: Apr 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2584
tbechtel is on a distinguished road
Re: EVIC Issue

I have the Garmin
Reply With Quote
  #9  
Old 09-04-2011, 12:06 PM
AAAA's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2011
Location: Upstate NY
Posts: 3,524
Thanks: 224
Thanked 174 Times in 150 Posts
Rep Power: 1545226
AAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond repute
Re: EVIC Issue

Quote:
Originally Posted by Cherodude View Post
I have not seen this with 430N Nav. Always returns to the previous EVIC screen (knock on wood).
Ditto (ditto).
Reply With Quote
  #10  
Old 09-04-2011, 12:52 PM
2011RitterGC's Avatar
Member
My Jeep: 2012 3.6L JK
 
Join Date: Jan 2011
Location: FL
Posts: 539
Thanks: 100
Thanked 33 Times in 22 Posts
Rep Power: 2817
2011RitterGC is on a distinguished road
Re: EVIC Issue

I have not seen this with my 730 RER.
__________________
2016 Granite 75th Anniversary Edition Sahara with Dark Saddle Leather
2011 GC Overland, Hemi
Reply With Quote
  #11  
Old 09-04-2011, 01:53 PM
Senior Member
 
Join Date: Oct 2010
Posts: 1,185
Thanks: 6
Thanked 22 Times in 15 Posts
Rep Power: 3589
jeep2011 has a reputation beyond reputejeep2011 has a reputation beyond reputejeep2011 has a reputation beyond repute
Re: EVIC Issue

It happened with my 430N on the limited a few times. It hasn't happened with my 730 RHR yet.
__________________
Current: 2015 Summit
Reply With Quote
  #12  
Old 09-05-2011, 08:48 AM
dobiegillis's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2011
Location: Atlanta
Posts: 363
Thanks: 20
Thanked 9 Times in 7 Posts
Rep Power: 2587
dobiegillis is on a distinguished road
Re: EVIC Issue

I leave the evic on speedo all the time as well and haven't noticed this problem. However, I rarely use the nav for turn by turn so if an intermittent problem it's possible I haven't experienced it. I have the RHR.
__________________
2016 High Altitude 4x2, V6, Granite
2011 Summit 4x4, Hemi, Brilliant Black/Saddle (sent to live with mom)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Customizing the EVIC foster Audio/Visual/Navigation 4 09-20-2011 11:07 AM
EVIC error kaflyboy Trouble Shooting/Problems/Service 1 08-03-2011 08:50 PM
Pessimistic EVIC? WK2maybe Grand Cherokee - WK2 - 7 07-07-2011 02:39 PM
How to access EVIC Carolyn Trouble Shooting/Problems/Service 3 05-22-2011 12:28 PM
EVIC Digital MPH Off suprand Trouble Shooting/Problems/Service 12 12-19-2010 10:56 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.