Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-09-2013, 04:09 PM
mstordahl's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Alberta, Canada
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 410
mstordahl is on a distinguished road
Hemi code...

Today was the third time in as many weeks that the new jeep turned on the check engine light and the p0307 code (cylinder 7 misfire) upon cold startup. Till now this new jeep has been flawless, haven't seen any other ones doing this, just wondering is this something anyone else has experienced?

Will be taking into the dealer now for this, one time codes do not bother me, I am a HD mechanic, but once they get repetitive it needs to be repaired.

Thanks!
__________________

__________________
'14 Overland white/indigo hemi
Reply With Quote
  #2  
Old 09-10-2013, 08:12 PM
mstordahl's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Alberta, Canada
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 410
mstordahl is on a distinguished road
Re: Hemi code...

Nobody have any similar issues?
__________________

__________________
'14 Overland white/indigo hemi
Reply With Quote
  #3  
Old 01-23-2014, 06:06 PM
mstordahl's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Alberta, Canada
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 410
mstordahl is on a distinguished road
Re: Hemi code...

Im gonna bring this one up again, sorry.

Been to the dealer 3 times now and each time they re flash the computer with new software and say its fixed... check engine light comes back on within a few days again. Now it is always a P0300 code, random missfire.

This is really starting to p!ss me off, has anyone else had this issue with a new hemi?

Thanks.
__________________
'14 Overland white/indigo hemi
Reply With Quote
  #4  
Old 01-23-2014, 06:21 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,394
Thanks: 54
Thanked 131 Times in 113 Posts
Rep Power: 542539
robpp has disabled reputation
Re: Hemi code...

when the 6 cylinders used to get that code it was a bad head.

if you been back for the same issue more than once this time INSIST on a resolution. Its OBVIOUSLY more than software.

older hemis it usually means a dropped valve or seat.
__________________
Reply With Quote
  #5  
Old 01-23-2014, 06:35 PM
tomk's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2012
Location: Amherst, MA
Posts: 328
Thanks: 7
Thanked 9 Times in 8 Posts
Rep Power: 1818
tomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond repute
Re: Hemi code...

You service department needs to open a Starcase.

I have to say I haven't heard this one before. What is your build date (the "MDH" code on your door sticker)
__________________
2007 WK Limited 5.7L
2014 WK2 Overland 5.7L !!
And a few past Durangos
Reply With Quote
  #6  
Old 01-23-2014, 07:08 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Aug 2013
Location: Georgia
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 323
sid_be is on a distinguished road
Re: Hemi code...

my GC summit with 5000 miles on it has done it 3 times.
The first time the engine light came on with code P0300.
Went to the dealership , they reset the code , did not have a solution for it.
Happened twice since , this time the engine light went out after a couple miles of driving.
So far only happens in the morning when i start the motor and put it in reverse.
The motor rpm's drop for a 1/2 second and the engine light comes on.(feels like its robbed of fuel)
I will go to the dealer if the engine light stay's on again.
__________________
Reply With Quote
  #7  
Old 01-23-2014, 09:02 PM
mstordahl's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Alberta, Canada
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 410
mstordahl is on a distinguished road
Re: Hemi code...

Quote:
Originally Posted by sid_be View Post
my GC summit with 5000 miles on it has done it 3 times.
The first time the engine light came on with code P0300.
Went to the dealership , they reset the code , did not have a solution for it.
Happened twice since , this time the engine light went out after a couple miles of driving.
So far only happens in the morning when i start the motor and put it in reverse.
The motor rpm's drop for a 1/2 second and the engine light comes on.(feels like its robbed of fuel)
I will go to the dealer if the engine light stay's on again.
Exactly what mine does, almost. Mine does it on cold startup as well, and the light will go out on its own after a few key cyles but doesnt have to be in gear to do it. It will stumble for a second and then run perfect.

It is very infuriating for me, Im a mechanic for a living so I know they are just not putting any effort into it. Even when the light comes on, it is not running rough at all, and day to day it runs great.

I will get the build date tonight and post it up, its an early one I know that...
__________________
'14 Overland white/indigo hemi
Reply With Quote
  #8  
Old 01-23-2014, 09:35 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,490
Thanks: 0
Thanked 20 Times in 17 Posts
Rep Power: 80040
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: Hemi code...

307 Could just be a bad/clogged injector. If it were mine I'd be tempted to swap injectors with another cyl. and see if it follows. Could also be secondary ignition (plug/coil). If it only happens after a cold start, I'd check for a partly fouled plug. How much of the misfire can you feel ?


300 is more problematic but I'd check the fuel rail pressure first, could be a bad pump/regulator.

Might not be a high tech problem at all.
__________________
Web home. Notary Sojac Y'all
One of these is a diesel:
Reply With Quote
  #9  
Old 01-23-2014, 09:48 PM
Premium Member
 
Join Date: May 2013
Location: Brookfield, Wisconsin
Posts: 59
Thanks: 14
Thanked 6 Times in 5 Posts
Rep Power: 468
agonzo is on a distinguished road
Re: Hemi code...

I have had the random misfire code twice in my 2014 hemi Durango (3000 miles now). After the second occurrence the dealer told me a software update will be available later in Q1 2014, starcase S130800468.

The light will go off automatically after about 15 restarts. I highly doubt it is a clogged injector or any other issue other than the software.

I am not worried about this. The hemi is a reliable engine. There is a thread in the Durango section about the same issue.
__________________
______________________________
____________________________________________
2005 Dodge Magnum RT
2014 Dodge Durango Citadel Hemi
Reply With Quote
  #10  
Old 01-24-2014, 08:28 AM
mstordahl's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Alberta, Canada
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 410
mstordahl is on a distinguished road
Re: Hemi code...

Mine is an 03/13 build date...
__________________

__________________
'14 Overland white/indigo hemi
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
08 GJC Overland 5.7 Hemi Code P0520 Michaelbex Troubleshooting/Problems 2 06-11-2013 05:16 PM
Possible trade for a WK2 Hemi, need advice from hemi owners gc4x4 Grand Cherokee - WK2 - 69 10-08-2012 07:59 PM
OBD code P2667 Input Speed Sensor code Greg.garvin@gmail.com Troubleshooting/Problems Discussion 1 08-19-2012 01:51 AM
OBD code P2667 Input Speed Sensor code Greg.garvin@gmail.com Trouble Shooting/Problems/Service 0 08-18-2012 08:10 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community