Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 05-01-2013, 01:48 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,788
Thanks: 291
Thanked 285 Times in 252 Posts
Rep Power: 1801199
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by visitador View Post
I am not an expert. If a new battery is dead so soon, then it seems to me that there is something electronic that is constantly "on" draining the electricity.
With these cars that is probably the case. But it could also just be a bad battery.

Whatever, I hope they find a solution.
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #14  
Old 05-01-2013, 01:58 PM
Beski's Avatar
Member
 
Join Date: Mar 2013
Location: New Jersey
Posts: 144
Thanks: 0
Thanked 7 Times in 7 Posts
Rep Power: 1890
Beski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by bill_de View Post
With these cars that is probably the case. But it could also just be a bad battery.
Yea, but what are the chances his new Jeep came with a Bad Battery and then they just put in a New Battery over the weekend and that one is also Bad too ?
__________________

__________________
Reply With Quote
  #15  
Old 05-01-2013, 02:28 PM
torifile's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2013
Posts: 633
Thanks: 27
Thanked 13 Times in 9 Posts
Rep Power: 1316887
torifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by Beski View Post
Yea, but what are the chances his new Jeep came with a Bad Battery and then they just put in a New Battery over the weekend and that one is also Bad too ?
I agree. I suspect there's something electrical going on with the car. Not a design flaw but something wrong with his particular car.
__________________
Current: 2014 Overland. V8. 4x4. Black on black.
SOLD! 2010 BMW 335d.
Reply With Quote
  #16  
Old 05-01-2013, 02:46 PM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1442
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by visitador View Post
I am not an expert. If a new battery is dead so soon, then it seems to me that there is something electronic that is constantly "on" draining the electricity.
This is the conclusion and obvious answer, but according to them they tested to see if there was a draw and the machine came back with nothing.
__________________
Reply With Quote
  #17  
Old 05-01-2013, 02:52 PM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1442
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by swing4terps View Post
First off, sorry to hear about all your issues.

You mean to tell me that with all the technology these days actions such as unlock and alarm and whatever else executed via the uConnect app will only work if your car is somewhere that has a 3G signal? Isn't that what satellites are for? This seems like a real buzzkill for people who live in rural areas with spotty cell phone coverage.
I couldn't say for sure for the simple reason that uConnect support never got it to actually work. But, from my understanding the answer is: unless it has a 3G signal it will NOT work, according to uConnect support.
Remember it works on Sprint cell service, not direct satellite service.
__________________
Reply With Quote
  #18  
Old 05-01-2013, 02:57 PM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1442
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by torifile View Post
This is worrisome since I'm going camping next weekend and it would kinda suck to have a dead car in the middle of nowhere...
Well the dealer said that they have not had this issue with any other customer so they basically confirming that it is this truck in particular. Unless it has happened to you already, I wouldn't be too concerned. This started happening 7 days after I took delivery.

Enjoy your camping trip..
__________________
Reply With Quote
  #19  
Old 05-01-2013, 03:09 PM
torifile's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2013
Posts: 633
Thanks: 27
Thanked 13 Times in 9 Posts
Rep Power: 1316887
torifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by Anand View Post
Well the dealer said that they have not had this issue with any other customer so they basically confirming that it is this truck in particular. Unless it has happened to you already, I wouldn't be too concerned. This started happening 7 days after I took delivery.

Enjoy your camping trip..
I only got my truck 5 days ago so I have 2 days left to sweat it out.

I wonder if the lack of 3G coverage is the problem. On a cell phone, the device will continually search for a signal until it dies. Do you think the uconnect system is doing something similar? If the dealer is in an area where there is a signal, he might not see the same behavior or power draw.

If so, that would mean a perfectly fine truck where there is a strong signal wouldn't exhibit any problems but up in the mountains, say while camping with 2 young kids, there might be a problem.
__________________
Current: 2014 Overland. V8. 4x4. Black on black.
SOLD! 2010 BMW 335d.
Reply With Quote
  #20  
Old 05-01-2013, 03:26 PM
Premium Member
 
Join Date: Mar 2013
Location: Woodland Park, CO
Posts: 101
Thanks: 13
Thanked 8 Times in 8 Posts
Rep Power: 578
ColoradoDriver is on a distinguished road
Re: My 2014 Overland review- not good so far!

Make sure to lock your Jeep with the key fob. On our 2012 Passat, unless you lock using the fob, several of the car's computers stay in a stand-by mode drawing current. The Passat also has lots of electronics, including key-less entry and start.
__________________
Reply With Quote
  #21  
Old 05-01-2013, 03:41 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jan 2012
Location: Bergen County, NJ
Posts: 500
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1487
Dabitz has a reputation beyond reputeDabitz has a reputation beyond reputeDabitz has a reputation beyond reputeDabitz has a reputation beyond reputeDabitz has a reputation beyond repute
Garage
Re: My 2014 Overland review- not good so far!

If they can't find what is draining the battery, could it be that the battery is not being "recharged"?
__________________
Reply With Quote
  #22  
Old 05-01-2013, 04:06 PM
Mendo's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Sep 2011
Location: Queensland
Posts: 586
Thanks: 44
Thanked 23 Times in 21 Posts
Rep Power: 6259
Mendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

This was a problem on 2011 and early 2012 models in Australia. There was a TSB that fixed it eventually. Where are you leaving your fob when at home? Make sure it is at least 10-15 metres away from the vehicle.
__________________
3.0L CRD Brilliant Black
Laredo w/ QuadraLift
Reply With Quote
  #23  
Old 05-02-2013, 02:33 AM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1442
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by torifile View Post
I only got my truck 5 days ago so I have 2 days left to sweat it out.

I wonder if the lack of 3G coverage is the problem. On a cell phone, the device will continually search for a signal until it dies. Do you think the uconnect system is doing something similar? If the dealer is in an area where there is a signal, he might not see the same behavior or power draw.
I had the same thought, accept I have good coverage for the 3G ( 3 bars) and also after all of this I uninstalled everything to see what would happen. Service said the antenna would have a draw but it would extremely minimal.
__________________
Reply With Quote
  #24  
Old 05-02-2013, 02:41 AM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1442
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by ColoradoDriver View Post
Make sure to lock your Jeep with the key fob. On our 2012 Passat, unless you lock using the fob, several of the car's computers stay in a stand-by mode drawing current. The Passat also has lots of electronics, including key-less entry and start.
Hmmm, interesting. I never lock with key fob. I always just hit the button on the handle. Will need to have them test this.

Quote:
Originally Posted by Dabitz View Post
If they can't find what is draining the battery, could it be that the battery is not being "recharged"?
I will call and mention that to them tomorrow.

Quote:
Originally Posted by Mendo View Post
This was a problem on 2011 and early 2012 models in Australia. There was a TSB that fixed it eventually. Where are you leaving your fob when at home? Make sure it is at least 10-15 metres away from the vehicle.
Yes I am at least 300 ft from the vehicle.

Thank You ALL so much for these ideas. I will definitely bring up these possible solutions to the service dept and let you guys know. At this point, they have to find a legitimate solution to the problem for me to feel comfortable.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My not so good review on Turtle Wax Headlight Lense Restorer Kit. White WK Swagga Member Product Reviews 13 07-06-2013 07:07 PM
2014 Review HaulinHP Grand Cherokee SRT - WK2 1 04-21-2013 08:00 AM
2014 Overland test drive. Review and pics of Granite exterior. Amazing!!! JTS97Z28 Grand Cherokee - WK2 - 45 03-24-2013 09:08 AM
Good Deal? 2014 JGC Overland Abaksh Grand Cherokee - WK2 - 4 03-10-2013 01:38 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community