Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 05-02-2013, 04:45 AM
scooterha's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2011
Location: WV
Posts: 1,706
Thanks: 0
Thanked 37 Times in 29 Posts
Rep Power: 220041
scooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond reputescooterha has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Hate to hear this and that you are staying semi-positive... have they tried to fix the ground wire? A lot of people are having ground wire problems where its not attached or it's loose.
__________________

__________________
Current Vehicle: 2015 Chrysler 200 S 2.4 Tigershark.
Granite Crystal Metallic. May not have the Jeep, but I'll still drop in and keep up with the news.
Reply With Quote
The Following User Says Thank You to scooterha For This Useful Post:
  #26  
Old 05-02-2013, 04:05 PM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1444
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Update: So they kept the truck overnight and sure enough it was dead this morning. They have narrowed it down to the center driver console and the gear shifter. If you guys notice when you exit your truck and lock it some of the lights in the speedo area and the gear shifter light stays lit for a few seconds before turning off. Apparently, on mine it shuts down and then something causes it to wake up. they are now trying to hunt down what could be causing it to wake up by itself.

They have tried all combinations with key fob and door handle lock.
Also moving the key fob very far away... and it still lit up after a few moments.
So it definitely seems to be some sort of faulty relay or something to that nature.
__________________

__________________
Reply With Quote
  #27  
Old 05-02-2013, 04:10 PM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1444
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by scooterha View Post
Hate to hear this and that you are staying semi-positive... have they tried to fix the ground wire? A lot of people are having ground wire problems where its not attached or it's loose.
Wouldn't a faulty ground cause bigger malfunctions?

It doesn't shut off while driving, and all instrument clusters, radio, climate control work correctly.
__________________
Reply With Quote
  #28  
Old 05-03-2013, 05:17 AM
Member
 
Join Date: Mar 2013
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 510
GoldenBear03 is on a distinguished road
Re: My 2014 Overland review- not good so far!

Stupid addition here from me, but I remember that the night I got mine, I exited the vehicle and noticed the dash stayed backlit. The gauges were not lit, but there was this hint of lighting in the cluster.

I allowed it to sit like this for a few minutes before I realized it wasn't going to go off. As it turns out, the interior lighting switch, which allows you to adjust the dimmer, has one extra position. You have off, dimmer and extra bright at the top. Best I can tell, if you click into the extra bright mode, it stays backlit. I backed mine down to the brightest dimmer level and when I exit the car, the gauges appear fully dead, as they should.

Like I said, I doubt that's it, but that would have caused me a problem on morning 2 had I not noticed it being on still.
__________________
Reply With Quote
  #29  
Old 05-03-2013, 08:41 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Mar 2013
Location: Houston, TX
Posts: 192
Thanks: 16
Thanked 5 Times in 5 Posts
Rep Power: 729
Lanrete has a reputation beyond reputeLanrete has a reputation beyond reputeLanrete has a reputation beyond reputeLanrete has a reputation beyond repute
Quote:
Originally Posted by GoldenBear03 View Post
Stupid addition here from me, but I remember that the night I got mine, I exited the vehicle and noticed the dash stayed backlit. The gauges were not lit, but there was this hint of lighting in the cluster.

I allowed it to sit like this for a few minutes before I realized it wasn't going to go off. As it turns out, the interior lighting switch, which allows you to adjust the dimmer, has one extra position. You have off, dimmer and extra bright at the top. Best I can tell, if you click into the extra bright mode, it stays backlit. I backed mine down to the brightest dimmer level and when I exit the car, the gauges appear fully dead, as they should.

Like I said, I doubt that's it, but that would have caused me a problem on morning 2 had I not noticed it being on still.
My 04 Liberty has an always on position on the dimmer switch, this worked regardless of the car being on or off, but I'm pretty sure it would turn itself off after a set amount of time, like when you leave the headlights on when you get out of the vehicle.
__________________
-Nathan
2014 Grand Cherokee Summit 5.7L 4x4 | 1998 Wrangler Sport 4.0L 4x4
Reply With Quote
  #30  
Old 05-03-2013, 09:12 AM
Member
 
Join Date: Mar 2013
Location: Macomb mich
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 759
Icetech has a reputation beyond reputeIcetech has a reputation beyond reputeIcetech has a reputation beyond reputeIcetech has a reputation beyond reputeIcetech has a reputation beyond reputeIcetech has a reputation beyond repute
Send a message via MSN to Icetech
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by Anand View Post
Wouldn't a faulty ground cause bigger malfunctions?

It doesn't shut off while driving, and all instrument clusters, radio, climate control work correctly.
No.. a bad ground can do any type of weird crap.. from tiny issues to making you think you have gremlins..

I worked on a tempo once, you would turn on the headlights and the wipers would come on... Bad ground.

At least it sounds like they are trying to get the issue resolved
__________________
Reply With Quote
  #31  
Old 05-03-2013, 12:25 PM
weck's Avatar
Member
 
Join Date: Nov 2012
Location: Wisco
Posts: 741
Thanks: 14
Thanked 24 Times in 24 Posts
Rep Power: 3582
weck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond reputeweck has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by Icetech View Post
I worked on a tempo once...
Very sorry to hear that, you have my condolences..

I had a similar issue to this with a VW that occurred right after I attempted to upgrade the factory radio. Apparently despite what the wiring diagram and everything else in the world said, the factory head unit sent an off signal to the factory amp that was not documented anywhere.

The car would die in about a day due to the amp remaining on. Recharge the battery, check the draw (nothing), drive car for a day (with the radio on), then bam, dead a day later. Took me a couple of days to figure out the problem. It killed my stock battery (unrecoverable), grateful the optima I replaced it with was able to take the abuse and came back from single digit voltage.
__________________
Reply With Quote
  #32  
Old 05-03-2013, 01:25 PM
Member
 
Join Date: Jul 2012
Location: NJ
Posts: 62
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 782
emsrescue is on a distinguished road
Re: My 2014 Overland review- not good so far!

Several people have reported that the alternator ground comes off or was loose. This means the car is not charging right or the components are not getting the power they need. However I would think the dealer would have caught that on a voltage test. In your dashboard display go to voltage and watch it. It should show a steady 14 volts. Look for drop during idle.
If you cannot get satisfaction do a buy back with Chrysler but don't waste too much time waiting.
I am having nothing but issues upon issues on mine.
__________________
Reply With Quote
  #33  
Old 05-03-2013, 02:29 PM
Sudbury78's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Scottsdale, AZ
Posts: 132
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 591
Sudbury78 is on a distinguished road
Re: My 2014 Overland review- not good so far!

gosh this is a sad thread and concerning about my future 14. I may have to stick with my perfect 11 overland.
__________________
Reply With Quote
  #34  
Old 05-03-2013, 06:11 PM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,516
Thanks: 3
Thanked 23 Times in 21 Posts
Rep Power: 49491
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by emsrescue View Post
Several people have reported that the alternator ground comes off or was loose. This means the car is not charging right or the components are not getting the power they need. However I would think the dealer would have caught that on a voltage test. In your dashboard display go to voltage and watch it. It should show a steady 14 volts. Look for drop during idle.
If you cannot get satisfaction do a buy back with Chrysler but don't waste too much time waiting.
I am having nothing but issues upon issues on mine.
Voltage reading on mine usually flickers between 14-15 volts on freeway.
__________________
2014 Summit 4X4, V8
Reply With Quote
  #35  
Old 05-03-2013, 06:54 PM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,853
Thanks: 54
Thanked 135 Times in 114 Posts
Rep Power: 389950
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Quote:
Originally Posted by Sudbury78 View Post
gosh this is a sad thread and concerning about my future 14. I may have to stick with my perfect 11 overland.
But remember that for these few problems, how many of us are out enjoying our Jeeps and not posting. There were Alot of jeeps tracked and I haven't heard or seen these people since they got them.
__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #36  
Old 05-03-2013, 09:01 PM
Member
 
Join Date: Jul 2012
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 779
Itsjustme11 is on a distinguished road
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by SnoFire View Post
But remember that for these few problems, how many of us are out enjoying our Jeeps and not posting. There were Alot of jeeps tracked and I haven't heard or seen these people since they got them.
I can tell you that I have been very lucky. My '14 has been flawless. I haven't had any issues at all. The only thing I haven't tried is the SD card. But Ive had no Uconnect issues, no leaks, no rattles, no transmission issues, no misaligned tailgate, no paint issue. Navigation has worked perfectly and even the Wi-Fi, while painfully slow, works.

I really feel for those having issues. I would be so disappointed, frustrated and mad. But I just wanted to put out there that Chrysler IS putting out a great product. So I hope people don't get put off by the issues being posted. Unfortunately, its usually those that are having problems and are unhappy that post.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My not so good review on Turtle Wax Headlight Lense Restorer Kit. White WK Swagga Member Product Reviews 13 07-06-2013 07:07 PM
2014 Review HaulinHP Grand Cherokee SRT - WK2 1 04-21-2013 08:00 AM
2014 Overland test drive. Review and pics of Granite exterior. Amazing!!! JTS97Z28 Grand Cherokee - WK2 - 45 03-24-2013 09:08 AM
Good Deal? 2014 JGC Overland Abaksh Grand Cherokee - WK2 - 4 03-10-2013 01:38 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community