Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-26-2013, 11:39 AM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1543
Anand is on a distinguished road
Garage
My 2014 Overland review- not good so far!

Hi Everyone,

Just to preface this review, I traded my 2011 Overland 5.7 for the new 5.7. The first week it was great! 8 spd tranny is a dream and the ride seems to be smoother and quieter. So I figured let me play around with the uConnect and get that setup (and it went straight downhill from there).

I went through the process of setting up the account and downloading the app to my phone (samsung note2 -verizon). No matter what I tried it wouldn't connect and instructed me to contact uConnect support so I did that. 2 Hours later and it still wasn't fixed and they said they would call me back.

I figured no worries, they will sort it out and it will be working in no time. That is the exact opposite of what happened. I didn't get a call back for at least a week but in the meantime, exactly 6 days after getting the truck I walk up to it trying to get in and...nothing! Battery is COMPLETELY dead! So I get a jump and take it back to the dealer, and of course they found nothing. They charged it and sent me on my way. This was last week Saturday.

Now it just so happens that I get a call back from uConnect support yesterday and I tell them what happens and they mention that a version of the firmware on the radio causes it to stay on and drain the battery. They proceeded to ask what version I was on and although to me (being an IT professional) it seemed like a pretty old version, they assured me that it was not the version that would cause the killing of the battery. They said if it does happen again let us know...hmm..ok ...so can we get uConnect to work then?

So we go through the entire process again of trying to get uConnect to work and to no avail...failed again, they will call me back. This morning I go out and again...truck is dead and coincidentally uConnect support calls back at the very moment and says, I should take it back to the dealer because it must be hardware related.

So 2 things:
1) Why is there no way to completely power off the radio?? This is the dumbest thing I have ever seen in ANY car and I've had lots of them.
2) If it must stay on so that the 3G radio will receive a signal for uConnect App, then why doesn't the computer monitor battery level and shut it off BEFORE it goes to point that it will not start?

I am a HUGE jeep fan but this is an extremely disappointing experience. Not to mention an epic failed attempt at being tech savvy.
__________________

__________________
Reply With Quote
  #2  
Old 04-26-2013, 11:54 AM
visitador's Avatar
Member
 
Join Date: Jan 2013
Location: Northern California
Posts: 274
Thanks: 11
Thanked 8 Times in 6 Posts
Rep Power: 30974
visitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Sorry to read about your problems. Makes me think more and more of getting a battery tender for charging the truck when not in use.

Hope everything is taken care of. Maybe your version of Android in your phone is causing the problem? Just a thought.
__________________

__________________
Current vehicles: 2004 4.0 WJ, 2003 4.0 TJ.
2014 Porsche Cayenne Diesel.
Reply With Quote
  #3  
Old 04-26-2013, 12:07 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,220
Thanks: 1
Thanked 27 Times in 26 Posts
Rep Power: 3185
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

How do you know what version of firmware you have? What is the old and new versions?
__________________
Reply With Quote
  #4  
Old 04-26-2013, 12:23 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,302
Thanks: 329
Thanked 358 Times in 312 Posts
Rep Power: 1801818
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by jp467 View Post
How do you know what version of firmware you have? What is the old and new versions?
You can find your version on the evic ... Settings/info I believe.

With your vin, you can check for updates here;

Uconnect | Support | Jeep


.
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #5  
Old 04-26-2013, 01:35 PM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1543
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

I did think it may have been the version of my Android phone that is stopping the uConnect from working but, when they tried to send a horn/panic signal from their locations it never made it to the truck. So in essence, they replicated the same problem I am having with my phone.

I also made sure that I had 3 bars of 3G service on the truck, so I know I am not parked in an odd spot with no signal.

Version: I can't remember exactly but if you go to uApps- settings- and scroll to the bottom, I think it says software version or something like that.

I was on 10.05.xxx and the lady told me the newest one out was 10.16.xxx or something like that. That's why I feel it was really old.
__________________
Reply With Quote
  #6  
Old 04-26-2013, 02:21 PM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1543
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by bill_de View Post

With your vin, you can check for updates here;

Uconnect | Support | Jeep


.
Thanks for the link. So it says that there are no updates available, which now makes me wonder, are ALL '14 Overlands running same firmware/software? If so has anyone else had these problems?
__________________
Reply With Quote
  #7  
Old 04-26-2013, 11:27 PM
Member
 
Join Date: Feb 2013
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 675
mosttoysrsk has a reputation beyond reputemosttoysrsk has a reputation beyond reputemosttoysrsk has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

Hmm... I haven't had this problem but the longest I have let my Overland sit is for 2 days... I am going on vacation tomorrow for 2 weeks. I'll let you know what happens when I come back and try to start it...
__________________
Reply With Quote
  #8  
Old 05-01-2013, 10:54 AM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1543
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Update: So I pick up the truck on Saturday (day after I dropped it off- 2nd time), and they tell me it's the battery. So they gave me a new battery and said that should fix the problem. uConnect still is not working at this point so the service dept said they would open a ticket with Chrysler.
Nice day on Saturday here in NY so I figured a car wash was in order...both headlights had water in it after coming out of wash..wtf! I called the dealer back and they said they would replace. I am livid at this point, so I said fine and hung up.

Today, 5/1 I go to open the truck and again, it's dead, completely discharged brand new battery AGAIN! It is currently in service but I think I want another truck. Obviously, there is some defect in this particular truck because dealer is telling me "No one else has reported this problem", and more importantly I have not seen anyone else on this forum complain about this problem.

How do I get an exchange, or better yet go back to a 2013 with less computer crap in there cause it is apparent they have no clue how to fix this. Oh and another thing when they have the truck shut off they are saying they do not see a current draw on the battery...go figure.
__________________
Reply With Quote
  #9  
Old 05-01-2013, 10:59 AM
Anand's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2010
Location: Valley Stream, NY
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1543
Anand is on a distinguished road
Garage
Re: My 2014 Overland review- not good so far!

Quote:
Originally Posted by mosttoysrsk View Post
Hmm... I haven't had this problem but the longest I have let my Overland sit is for 2 days... I am going on vacation tomorrow for 2 weeks. I'll let you know what happens when I come back and try to start it...
Except for that first time I have used my truck everyday, it's my DD, and the battery still died.
__________________
Reply With Quote
  #10  
Old 05-01-2013, 11:44 AM
visitador's Avatar
Member
 
Join Date: Jan 2013
Location: Northern California
Posts: 274
Thanks: 11
Thanked 8 Times in 6 Posts
Rep Power: 30974
visitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond reputevisitador has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

I am not an expert. If a new battery is dead so soon, then it seems to me that there is something electronic that is constantly "on" draining the electricity.
__________________
Current vehicles: 2004 4.0 WJ, 2003 4.0 TJ.
2014 Porsche Cayenne Diesel.
Reply With Quote
  #11  
Old 05-01-2013, 01:24 PM
torifile's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2013
Posts: 633
Thanks: 27
Thanked 14 Times in 10 Posts
Rep Power: 1316988
torifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond repute
Re: My 2014 Overland review- not good so far!

This is worrisome since I'm going camping next weekend and it would kinda suck to have a dead car in the middle of nowhere...
__________________
Current: 2014 Overland. V8. 4x4. Black on black.
SOLD! 2010 BMW 335d.
Reply With Quote
  #12  
Old 05-01-2013, 01:32 PM
Premium Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2010
Location: Baltimore, MD
Posts: 434
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 2081
swing4terps is on a distinguished road
Re: My 2014 Overland review- not good so far!

First off, sorry to hear about all your issues.

You mean to tell me that with all the technology these days actions such as unlock and alarm and whatever else executed via the uConnect app will only work if your car is somewhere that has a 3G signal? Isn't that what satellites are for? This seems like a real buzzkill for people who live in rural areas with spotty cell phone coverage.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My not so good review on Turtle Wax Headlight Lense Restorer Kit. White WK Swagga Member Product Reviews 13 07-06-2013 07:07 PM
2014 Review HaulinHP Grand Cherokee SRT - WK2 1 04-21-2013 08:00 AM
2014 Overland test drive. Review and pics of Granite exterior. Amazing!!! JTS97Z28 Grand Cherokee - WK2 - 45 03-24-2013 09:08 AM
Good Deal? 2014 JGC Overland Abaksh Grand Cherokee - WK2 - 4 03-10-2013 01:38 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community