fog light issue 2007 gc laredo - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Tech Tips DIY/How To

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-09-2015, 08:54 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Sep 2014
Location: maryland
Posts: 27
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 828
hefflerisjeepin is on a distinguished road
fog light issue 2007 gc laredo

Need help in finding out why I cannot get fog lights to work..

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-11-2015, 09:57 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,257
Thanks: 17
Thanked 366 Times in 353 Posts
Rep Power: 529369
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: fog light issue 2007 gc laredo

I just see that you also have problems with the horn. I would first check the fuses from both (fuse 15 and 16 under the hood), but both are getting the ground for their respective relays from the front control module. Maybe a problem with the programming of the module.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
The Following User Says Thank You to Frango100 For This Useful Post:
  #3  
Old 03-11-2015, 07:13 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Sep 2014
Location: maryland
Posts: 27
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 828
hefflerisjeepin is on a distinguished road
Quote:
Originally Posted by Frango100 View Post
I just see that you also have problems with the horn. I would first check the fuses from both (fuse 15 and 16 under the hood), but both are getting the ground for their respective relays from the front control module. Maybe a problem with the programming of the module.
Yes the horn is working again there is two horns down their behind the bumper on the right side of vehicle. The horn that was responsible for the plug was snapped and the metal prongs were not properly applied. I took both horns of grabbed the second horn made two exposed wires and threaded them into the socket of the horn and it works for the time being further down the road I'll buy a new one but it's not neccesary.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tail light issue with 2002 Laredo JEANNEZ Troubleshooting/Problems Discussion 3 06-14-2013 12:50 PM
Fog light issue.. DMack89 Visual Modifications 3 04-17-2013 12:26 AM
electrical issue jeep laredo 2007 ...!! Kabbesh Troubleshooting/Problems Discussion 0 04-06-2013 05:59 PM
2012 Jeep Grand Cherokee Laredo X head and fog light mod urbeat Interior/Exterior/Visual 2 03-03-2012 07:57 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.