Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Technical Service Bulletins and Recalls

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 04-26-2014, 08:20 AM
Member
 
Join Date: Feb 2014
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 271
joey49 is on a distinguished road
Re: Pixel on dash

Ok no probs just waiting in dealer to notify me when new dash arrives from US. Will keep you posted !


Sent from my iPhone using JeepGarage
__________________

__________________
Reply With Quote
  #26  
Old 04-28-2014, 07:18 PM
aboyce85's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Oklahoma
Posts: 54
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 381
aboyce85 is on a distinguished road
Re: Pixel on dash

I'm seeing the same dead pixel on my screen, shows up randomly like others have been saying...ImageUploadedByJeepGarage1398730676.640066.jpg


Sent from my iPhone using JeepGarage
__________________

__________________
Reply With Quote
  #27  
Old 05-13-2014, 10:37 PM
cwmccall's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Location: Maryland
Posts: 112
Thanks: 18
Thanked 18 Times in 14 Posts
Rep Power: 466
cwmccall has a reputation beyond reputecwmccall has a reputation beyond reputecwmccall has a reputation beyond reputecwmccall has a reputation beyond reputecwmccall has a reputation beyond repute
Re: Pixel on dash

Quote:
Originally Posted by aboyce85 View Post
I'm seeing the same dead pixel on my screen, shows up randomly like others have been saying...Attachment 38846


Sent from my iPhone using JeepGarage

Same here. I just remembered to take a couple pics. ImageUploadedByJeepGarage1400038579.413861.jpgImageUploadedByJeepGarage1400038607.361578.jpgImageUploadedByJeepGarage1400038630.880627.jpg


Sent from my mini iPad using JeepGarage
__________________
2014 Grand Cherokee Limited | Granite Crystal Metallic
Reply With Quote
  #28  
Old 05-20-2014, 07:07 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 77
Thanks: 1
Thanked 2 Times in 2 Posts
Rep Power: 605
libby2cm is on a distinguished road
Garage
Re: Pixel on dash

Yup.. I noticed it after that flash 6 months or so back for the instrument cluster. If you flip over and back it goes away and only sporadically shows up. Clearly a software bug that wasn't picked up in qa.. :-/
__________________
Reply With Quote
  #29  
Old 07-07-2014, 08:41 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Location: Detroit, MI
Posts: 8
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 466
ktech35 is just really nice
Re: Pixel on dash

Definitely a bug in the software. Looks to be the bottom 2-3 pixels from the "y" in "Parksense Ready" when throwing it into reverse. It doesn't go away when switching between menus with the steering wheel controls but shifting into neutral and toggling Sport Mode resets the pixels to black.

I'm assuming since not everyone has this problem, a reflash of the module controlling the dash screen could fix this. We'll see after my next visit to the dealer.
Attached Files
__________________
Reply With Quote
  #30  
Old 08-02-2014, 07:05 PM
rtadams1's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2014
Location: S. Jersey
Posts: 20
Thanks: 3
Thanked 3 Times in 2 Posts
Rep Power: 78
rtadams1 is on a distinguished road
Re: Pixel on dash

I've noticed this same thing as well. Unfortunately for me, I'm so OCD that I stare at it each time. I just had all of my software updated this past week and it's still there. Has anyone come up with a solution?
__________________
Reply With Quote
  #31  
Old 08-02-2014, 09:00 PM
maxy9's Avatar
Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: Jun 2013
Location: QLD Australia
Posts: 700
Thanks: 54
Thanked 69 Times in 66 Posts
Rep Power: 1537
maxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond repute
Re: Pixel on dash

Quote:
Originally Posted by cwmccall View Post
Same here. I just remembered to take a couple pics. Attachment 39695Attachment 39696Attachment 39697


Sent from my mini iPad using JeepGarage

I have the exact same only noticed it yesterday same bloody spot to ? , my car was flashed last week while I was at work and noticed it yesterday while driving and I skipped through all the menus bloody thing didn't go away , looks like of to the dealer this week .


iPhone @ JeepGarage
__________________
Reply With Quote
  #32  
Old 08-02-2014, 09:11 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Location: Detroit, MI
Posts: 8
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 466
ktech35 is just really nice
Re: Pixel on dash

Forgot to come back and update on my fix. My dealer said they called the STAR line and were instructed to swap it out for a new dash screen. New screen works flawless with no white/defective pixels. Still think it was software related since it wasn't there since day one...
__________________
Reply With Quote
  #33  
Old 08-02-2014, 09:15 PM
maxy9's Avatar
Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: Jun 2013
Location: QLD Australia
Posts: 700
Thanks: 54
Thanked 69 Times in 66 Posts
Rep Power: 1537
maxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond reputemaxy9 has a reputation beyond repute
Pixel on dash

Hmm I'll talk with the service department see how it goes I've had the car 3 months now and it wasn't there, got back from work this week and while I was away had the car updated with about 3 TSB updates and software flashes and noticed this yesterday while cruising these streets..


iPhone @ JeepGarage
__________________
Reply With Quote
  #34  
Old 08-05-2014, 06:18 PM
Premium Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 242
srs148 is on a distinguished road
Re: Pixel on dash

Quote:
Originally Posted by ktech35 View Post
Forgot to come back and update on my fix. My dealer said they called the STAR line and were instructed to swap it out for a new dash screen. New screen works flawless with no white/defective pixels. Still think it was software related since it wasn't there since day one...
It's definitely a software issue as I have the same spot, same location on screen and I, too, thought it was a dead pixel until it went away. it's sporadic for me as well, so its definitely not a dead pixel as that would never go away.

Also, it would be way too much of a coincidence that all of us had the same dead pixel in the same spot OR even the same bad screen or bad wiring harness or connection that caused this 'dead' spot in the same place. I think a future update will resolve it. I wonder if its even been brought to enough attention of the software team to look into it.
__________________
Reply With Quote
  #35  
Old 08-05-2014, 06:43 PM
Member
 
Join Date: Feb 2014
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 271
joey49 is on a distinguished road
Re: Pixel on dash

Hi all just took my jeep in for a service and the dealer said that there is a new electronic flash that he can apply which may fix the pixel problem I will keep you posted


Sent from my iPhone using JeepGarage
__________________
Reply With Quote
  #36  
Old 08-05-2014, 06:47 PM
Premium Member
 
Join Date: Apr 2014
Posts: 87
Thanks: 36
Thanked 8 Times in 8 Posts
Rep Power: 239
JGCDieselPowered is on a distinguished road
Re: Pixel on dash

Quote:
Originally Posted by rtadams1 View Post
I've noticed this same thing as well. Unfortunately for me, I'm so OCD that I stare at it each time. I just had all of my software updated this past week and it's still there. Has anyone come up with a solution?
I have the same issue and am also OCD about it. The only thing that clears it for me is to go to the digital speedometer screen and change it to the "analog old school speedo". Then when I switch back to the digital speedo, it goes away and doesn't come back until the vehicle is turned off. Then it comes back sporadically, and I do the same procedure to clear it again. Must be software related and it drives me crazy.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Center Dash (Radio) Surround and Lower Dash - Below Steering Wheel Removal mickey53usa Trouble Shooting/Problems/Service 7 09-25-2012 01:30 PM
Dash Kit Scotch Interior/Exterior/Visual 6 10-24-2011 05:27 PM
730RER Screen Dead Pixel Line pbm317 Trouble Shooting/Problems/Service 6 06-12-2011 07:57 PM
In dash-dvd...Help! jeepgrand23 Audio, Video, Navigation & Electronic Modifications 11 07-22-2010 07:51 PM
Dash-Mat??? soontobesrt Visual Modifications 6 07-09-2010 09:34 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community