Pixel on dash - Page 6 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Technical Service Bulletins and Recalls

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #61  
Old 04-07-2015, 12:09 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2013
Location: Arvada, CO
Posts: 108
Thanks: 0
Thanked 11 Times in 7 Posts
Rep Power: 1311
Qmulus is on a distinguished road
Re: Pixel on dash

Quote:
Originally Posted by jeepgrandcherokeesal View Post
The STAR tech says he hasn't found any similar cases... I asked the dealer to send me a copy of the response, which is below.

Is anyone willing to share their ticket numbers? Service manager says he won't replace it unless STAR says so
I have started to think of this just like the taillights that don't line up right. It is annoying, but definitely not enough to take the vehicle out of use for a week (what our dealer told us) to get it taken care of. If it bugs me while driving, I go through the menus to the "analog" speedometer display, then back to the "digital" display and that pixel gets cleared. It is kind of amazing to me that a software bug that is so easily replicated made it through testing and that Jeep won't recognize it as an issue. I had a friend with another '14 GC try to replicate it on his and it did the same thing. He normally drives around with the "analog" speedo display so he hadn't seen it before. Now it bugs him too... Hahahahahaaaa.

I imagine that somewhere along the way this bug was fixed for production, but they don't feel it is enough of an issue to do anything about unless someone really complains. Because other GCs do it as well, it is considered to be functioning normally. It is a feature, not a bug! Nice.

Reply With Quote
Sponsored Links
Advertisement
 
  #62  
Old 04-07-2015, 10:59 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1058
jeepgrandcherokeesal is on a distinguished road
Re: Pixel on dash

Quote:
Originally Posted by Qmulus View Post
I have started to think of this just like the taillights that don't line up right. It is annoying, but definitely not enough to take the vehicle out of use for a week (what our dealer told us) to get it taken care of. If it bugs me while driving, I go through the menus to the "analog" speedometer display, then back to the "digital" display and that pixel gets cleared. It is kind of amazing to me that a software bug that is so easily replicated made it through testing and that Jeep won't recognize it as an issue. I had a friend with another '14 GC try to replicate it on his and it did the same thing. He normally drives around with the "analog" speedo display so he hadn't seen it before. Now it bugs him too... Hahahahahaaaa.

I imagine that somewhere along the way this bug was fixed for production, but they don't feel it is enough of an issue to do anything about unless someone really complains. Because other GCs do it as well, it is considered to be functioning normally. It is a feature, not a bug! Nice.

I understand what you're saying. My problem is that I'd rather them say they are unwilling to fix it instead of saying there aren't any documented cases. I think the ticket numbers could help refresh their memory

Did you start a thread about your tail lights? What's up with that?
Reply With Quote
  #63  
Old 04-08-2015, 12:00 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2013
Location: Arvada, CO
Posts: 108
Thanks: 0
Thanked 11 Times in 7 Posts
Rep Power: 1311
Qmulus is on a distinguished road
Re: Pixel on dash

Quote:
Originally Posted by jeepgrandcherokeesal View Post
I understand what you're saying. My problem is that I'd rather them say they are unwilling to fix it instead of saying there aren't any documented cases. I think the ticket numbers could help refresh their memory

Did you start a thread about your tail lights? What's up with that?
Well, from what what I read, the dealer confirmed that your vehicle has the issue you reported, and that they have confirmed that others have it too. DUH!!! The problem appears to be that the dealers do not report it to STAR Technical Assistance (or whoever they need to report it to to get something done). I reported it to my dealer the first time I took it in for an oil change. They confirmed the issue as well, but other than telling me it would require a two week stay to replace did nothing about it.

It does give me some hope that they will fix it as they seemed to say that it may be a simple software update.

Soooo, how do we let someone who can do something about this know what is going on? There are a few threads on this topic, but apparently none of this has made it to anyone that can/will do anything about it. I have seen Jeep Cares post in some forums. I wonder if we referenced your ticket number and reported the same they would do something about it. If it isn't happening in newer dashes, they must be able to find the change quite easily in their software revision control tracking system when and how it was fixed. I would think that a software fix is cheaper than replacing a bunch of instrument clusters that just need to be reprogrammed. Maybe not.

As for the taillights, the left side doesn't quite line up. This seems to be VERY common, but I am not looking right at them when I am driving, so it doesn't really bother me.
Reply With Quote
The Following User Says Thank You to Qmulus For This Useful Post:
  #64  
Old 04-08-2015, 12:25 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1058
jeepgrandcherokeesal is on a distinguished road
Re: Pixel on dash

Quote:
Originally Posted by Qmulus View Post
Well, from what what I read, the dealer confirmed that your vehicle has the issue you reported, and that they have confirmed that others have it too. DUH!!! The problem appears to be that the dealers do not report it to STAR Technical Assistance (or whoever they need to report it to to get something done). I reported it to my dealer the first time I took it in for an oil change. They confirmed the issue as well, but other than telling me it would require a two week stay to replace did nothing about it.

It does give me some hope that they will fix it as they seemed to say that it may be a simple software update.

Soooo, how do we let someone who can do something about this know what is going on? There are a few threads on this topic, but apparently none of this has made it to anyone that can/will do anything about it. I have seen Jeep Cares post in some forums. I wonder if we referenced your ticket number and reported the same they would do something about it. If it isn't happening in newer dashes, they must be able to find the change quite easily in their software revision control tracking system when and how it was fixed. I would think that a software fix is cheaper than replacing a bunch of instrument clusters that just need to be reprogrammed. Maybe not.

As for the taillights, the left side doesn't quite line up. This seems to be VERY common, but I am not looking right at them when I am driving, so it doesn't really bother me.

That's exactly my point! I will call Chrysler as soon as I get at least one ticket, reference, or other information from a similar case. I figured that some people who posted have still subscribed, and are willing to share.

This is a silly issue to be chasing on a $49k vehicle
Reply With Quote
  #65  
Old 09-07-2015, 02:42 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1058
jeepgrandcherokeesal is on a distinguished road
Re: Pixel on dash

Took it to a different dealer, and they replaced the EVIC. DONE
Reply With Quote
  #66  
Old 09-08-2015, 09:36 PM
Member
 
Join Date: Mar 2013
Posts: 430
Thanks: 98
Thanked 31 Times in 22 Posts
Rep Power: 1971
Briant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond reputeBriant73 has a reputation beyond repute
Re: Pixel on dash

Quote:
Originally Posted by jeepgrandcherokeesal View Post
Took it to a different dealer, and they replaced the EVIC. DONE
Glad to hear it. Amazing what a different dealer can accomplish.
Reply With Quote
  #67  
Old 09-08-2015, 09:42 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 91
Thanks: 11
Thanked 6 Times in 5 Posts
Rep Power: 1504
libby2cm is on a distinguished road
Garage
Re: Pixel on dash

《Removed》
Reply With Quote
  #68  
Old 09-08-2015, 09:47 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 91
Thanks: 11
Thanked 6 Times in 5 Posts
Rep Power: 1504
libby2cm is on a distinguished road
Garage
Re: Pixel on dash

Quote:
Originally Posted by jeepgrandcherokeesal View Post
I understand what you're saying. My problem is that I'd rather them say they are unwilling to fix it instead of saying there aren't any documented cases. I think the ticket numbers could help refresh their memory

Did you start a thread about your tail lights? What's up with that?
I had the issue with one of my tailights..it was because one of the studs behind the light wasn't screwed in all the way, so the light didn't sit strait and flush. 3 screws to remove light, screwed stud in, and all is well.
Reply With Quote
  #69  
Old 09-08-2015, 09:49 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 91
Thanks: 11
Thanked 6 Times in 5 Posts
Rep Power: 1504
libby2cm is on a distinguished road
Garage
Re: Pixel on dash

Quote:
Originally Posted by jeepgrandcherokeesal View Post
Took it to a different dealer, and they replaced the EVIC. DONE
Why did you have hardware replaced for a software bug? Mine never did it until that recall for the cluster requiring a firmware update. Sporadically done it ever since.
Reply With Quote
  #70  
Old 09-12-2015, 02:14 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1058
jeepgrandcherokeesal is on a distinguished road
Re: Pixel on dash

Quote:
Originally Posted by libby2cm View Post
Why did you have hardware replaced for a software bug?
I would have done a lot of things differently if it were up to me! haha! That was the solution they proposed, and it worked.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Center Dash (Radio) Surround and Lower Dash - Below Steering Wheel Removal mickey53usa Trouble Shooting/Problems/Service 7 09-25-2012 02:30 PM
Dash Kit Scotch Interior/Exterior/Visual/Lighting 6 10-24-2011 06:27 PM
730RER Screen Dead Pixel Line pbm317 Trouble Shooting/Problems/Service 6 06-12-2011 08:57 PM
In dash-dvd...Help! jeepgrand23 Audio, Video, Navigation & Electronic Modifications 11 07-22-2010 08:51 PM
Dash-Mat??? soontobesrt Visual Modifications 6 07-09-2010 10:34 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.