03 4.0 miss at idle - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-23-2016, 11:49 PM
Member
My Jeep: 2003 4.0L XJ
 
Join Date: Apr 2016
Location: Orang County CA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 276
ECin OC is on a distinguished road
03 4.0 miss at idle

Not able to find a miss at idle when cold backing out of driveway or when in stop and go traffic. Have replaced the CPS and there are no codes. All service is up to date. It is a good miss that anyone that is the car can feel.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 04-24-2016, 08:11 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,320
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529476
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 03 4.0 miss at idle

Welcome to the garage.
Did you check for fault codes? If it misses, it should have stored a P030X (X is cylinder number) code.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 04-24-2016, 10:46 AM
Member
My Jeep: 2003 4.0L XJ
 
Join Date: Apr 2016
Location: Orang County CA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 276
ECin OC is on a distinguished road
Re: 03 4.0 miss at idle

No trouble codes, it is a hard miss At first it would do it once or twice at start up some times but now it is every day and now it is a bit nerve racking in stop and go traffic. It has 105 on the clock and has a clean throttle body, and has had a cam sensor and TPS replaced in the past. The only upgrade I have done was using the 4 port injectors.
Reply With Quote
  #4  
Old 04-24-2016, 09:45 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,320
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529476
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 03 4.0 miss at idle

Without any codes it will be a shot in the dark. Could be a crank position sensor.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 04-24-2016, 09:53 PM
Member
My Jeep: 2003 4.0L XJ
 
Join Date: Apr 2016
Location: Orang County CA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 276
ECin OC is on a distinguished road
Re: 03 4.0 miss at idle

I did replace the CPS this weekend with no change. Also found out the Jeep has obsoleted the battery cable harness. Found a cable vender and ordered a set as my are getting a little worn...
Reply With Quote
  #6  
Old 04-28-2016, 03:06 PM
Member
My Jeep: 2003 4.0L XJ
 
Join Date: Apr 2016
Location: Orang County CA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 276
ECin OC is on a distinguished road
Re: 03 4.0 miss at idle

*** UPDATE **** FIXED ***
Wanted to give an update on the misfire at idle. As there was not check engine lamp on I started to check all of the basics and I started with the sparkplugs that were changed about a year ago by a friends shop before a smog check and what I found were champions (not a fan) and the gaps were at .45. Install NGK's with the gap at .32 and miss is gone!


Thanks for the support and hops this helps someone else,
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bilstein are great, and got a miss. Can anyone help? kycoolcat Grand Cherokee - WK 9 05-09-2010 09:20 PM
I miss this Bitch.... robpp Other Rides 12 06-22-2009 03:07 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.