Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-22-2013, 10:36 PM
New Member
 
Join Date: May 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
stevusprime is on a distinguished road
04 KJ trans issue

I have an 04 liberty limited...it is stuck in "sneaker mode"
I bought the jeep with a rebuilt transmission he said he had it rebuilt because of this issue, when I test drove it everything was fine..
These codes are from when it would sometimes shift passed second
Day #1 codes:
P0700 transmission controller fault
P0734 gear ratio error in fourth
P0846 2-4 pressure switch sense circuit
P1776 solonoid switch valve stuck in LR
P0731 gear ratio error in first
P0733 gear ratio error in third
P1790 fault immediatly after a shift

I cleaned off almost every electrical connection on top and I even pulled the input/output sensor on the side of the trans...
Now that it is stuck in second these are the codes

Codes are now:
P0700
P0731
P1790
P0841 L/R pressure switch sense circuit

Has anyone ever came accross this or know of anything I can do (test connections, etc.)
Thanks
__________________

__________________
Reply With Quote
  #2  
Old 05-23-2013, 09:18 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,185
Thanks: 9
Thanked 120 Times in 113 Posts
Rep Power: 526204
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 KJ trans issue

Not.familiar with the KJ, do you know which transmission it has? The P0700 code only tells that the TCM has set one or more faults, its not a failure code of the TCM itself. P0731 is a code which is set when the ratio between input and output speed is not as.expected, which normally means a slipping clutch pack, but could eventually be caused by a problem with one of the speed sensors.
Depending on which transmission you have, i could maybe tell you a bit more.
But first thing, did you check the fluid level and smell the fluid for burned smell?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 05-23-2013, 01:30 PM
New Member
 
Join Date: May 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
stevusprime is on a distinguished road
Re: 04 KJ trans issue

The fluid is full...it was over full, but I dropped the pan and made sure it was filled right...I have to get in touch with the tranny shop cause I put in ATF+4 and it seemed to help for a day then it acted up again
It has the 42rle I think it is called
The fluid smells funny but it doesn't look brown or cloudy or smell burnt at all
__________________
Reply With Quote
  #4  
Old 05-23-2013, 05:41 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,185
Thanks: 9
Thanked 120 Times in 113 Posts
Rep Power: 526204
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 KJ trans issue

Does the 42rle not only have an output speed sensor? Are you sure its the 42 rle?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 05-23-2013, 11:32 PM
New Member
 
Join Date: May 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
stevusprime is on a distinguished road
Re: 04 KJ trans issue

It has an input and output speed sensor...according to all of my research it ic a 42RLE
Its an 04 liberty limited 4x4 I'm pretty sure it the only tranny they have, I could be wrong though
__________________
Reply With Quote
  #6  
Old 05-24-2013, 07:03 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,185
Thanks: 9
Thanked 120 Times in 113 Posts
Rep Power: 526204
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 KJ trans issue

I know that the Liberty can have the 5-45rfe as well and that one for sure has two speed sensors on the left hand side of the transmission housing. How many gears does it have? The 42 has 4 gears, while the 5-45 has 5. There is also an identification plate on the side of the transmission.
Do you still have guarantee on the rebuild?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 05-24-2013, 08:19 AM
New Member
 
Join Date: May 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
stevusprime is on a distinguished road
Re: 04 KJ trans issue

Yes I have a 1 yr. Warranty on the rebuild...
I no the trans has a stamp on it but I didn't see any plates when I was looking at it last night, its at home right now ill take a look asap
__________________
Reply With Quote
  #8  
Old 05-24-2013, 10:50 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,185
Thanks: 9
Thanked 120 Times in 113 Posts
Rep Power: 526204
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 KJ trans issue

Quote:
Originally Posted by stevusprime View Post
Yes I have a 1 yr. Warranty on the rebuild...
I no the trans has a stamp on it but I didn't see any plates when I was looking at it last night, its at home right now ill take a look asap
On mine its in fact a placard on the same side where the speed sensors are.
But since you are still in warranty, i would let them look for the problem.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 05-31-2013, 04:34 AM
Member
 
Join Date: Feb 2012
Posts: 24
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1531745
THAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond reputeTHAT_XJ_GUY has a reputation beyond repute
Re: 04 KJ trans issue

That has a 42rle. It sounds like the solenoid pack has an issue. P0846 and P0841 are normally caused by a bad solenoid pack.

545rfe only came in 02' and early 03' gas, and all diesel KJ's
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
First Problem (and it's the Trans!) Unsequestered Trouble Shooting/Problems/Service 14 05-05-2013 02:17 PM
Trans issue? kroneck4 Troubleshooting/Problems 0 11-12-2012 09:42 PM
replacing trans erleep Grand Cherokee - ZJ 3 05-27-2011 08:30 PM
Trans questions npenson Grand Cherokee - WK 8 06-06-2010 09:12 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.