04 WJ electrical issue. - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-18-2016, 07:56 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Orange County New York
Posts: 67
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2145
MacDaddy is on a distinguished road
04 WJ electrical issue.

Hello, I have an 04 WJ that had a few broken wires in the drivers door. The ground(of course) and what was appearantly the window controls and overhead courtesy lights. Fixed the issue with the wires and know I have the seat belt light and airbag idiot lights on. Tried the negative terminal disconnect while running with no reset. Horn works and all other controls work fine so it doesn't seem like clock spring. And no chime alarm either, just the idiot lights.
Any ideas, I'm at a loss.
Thanks MacDaddy

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 04-18-2016, 09:53 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,329
Thanks: 17
Thanked 378 Times in 365 Posts
Rep Power: 529492
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 WJ electrical issue.

Why would you try a battery terminal disconnect with running engine?
I would first check the fuses 32 and 33 on the junction block under the dash. Both the ABS light and the seatbelt light come from the ABS control module.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 04-20-2016, 10:41 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Orange County New York
Posts: 67
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2145
MacDaddy is on a distinguished road
Re: 04 WJ electrical issue.

Thanks for your reply, and the reason for the neg battery disconnect with the car running was to see if I had an open circuit/ground fault. Almost every wire in the door cluster had to be repaired, so I wanted to ensure I had made all possible repairs. And the fuses are good also.
Reply With Quote
  #4  
Old 04-20-2016, 12:26 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,329
Thanks: 17
Thanked 378 Times in 365 Posts
Rep Power: 529492
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 WJ electrical issue.

I had always learned to never disconnect a battery terminal when the engine runs. You can easily cause a voltage spike and fry electronics.
I would try the battery terminal disconnect with the engine off and wait at least 5 minutes before reconnecting.
If that doesn´t help, it needs to be scanned to know what is failing.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 04-21-2016, 07:48 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Orange County New York
Posts: 67
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2145
MacDaddy is on a distinguished road
Re: 04 WJ electrical issue.

Yuppers, been there done that with the neg terminal pull off also for about 10 minutes. I'll be getting it scanned next. I'm thinking I probably need to get back into the wire cluster and check every connection as some wires were already nicked from a precious owners door speaker repair. I'll let you know how it turns out. Thanks again
MacDaddy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!! Weird electrical issue jcostri09 Troubleshooting/Problems 7 11-01-2012 10:04 AM
Starting issue, probably electrical larsonra Troubleshooting/Problems Discussion 6 10-03-2011 11:11 PM
Help! Electrical issue. Urgent CPT2010 Troubleshooting/Problems Discussion 11 02-07-2011 07:54 PM
Electrical issue Mistereblack Troubleshooting/Problems 9 05-18-2010 02:15 AM
i have an electrical issue!!!!!!!!!! BUDAKANE Troubleshooting/Problems 5 11-25-2009 08:42 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:39 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.