Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-13-2014, 07:50 PM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2013
Location: Ma
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
jbotelho15 is on a distinguished road
04 WJ noise

Whenever im driving at freeway speeds I hear a noise that I could swear sound like a wheel bearing coming from the front but I just replaced both hubs entirely, replaced my rotors, flushed my differentials, changed my transfer case fluid, etc and the noise is still there. I feel like the noise has improved after replacing the hubs but the noise is still noticeable. Any idea what it is? Front driveshaft maybe?

No vibes or anything just a noise and it sounds like its from something spinning when I accelerate you hear it go wah wah wah wah wah... and when I take my foot off the pedal it almost sounds like a turbine shutting down or something that fading dewwwwwww...... Ive spent alot of money on parts already I dont know where else to look
__________________

__________________
Reply With Quote
  #2  
Old 02-15-2014, 08:26 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,887
Thanks: 9
Thanked 90 Times in 85 Posts
Rep Power: 525835
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 WJ noise

When changing the diff fluid was there any metal glinsters in the old fluid? Any signs of abnormal wear to the ring and/or pinion gear? A diff bearing could getting bad.
Could also be a CV joint from one of the drive shafts or the joint (CV or U-joint) from the propeller shaft.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-15-2014, 10:18 AM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2013
Location: Ma
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
jbotelho15 is on a distinguished road
I removed the front drive shaft and noticed a really bad u joint. Im going to replace this and hope that was my problem. Keeping my fingers crossed its not the bearing
__________________
Reply With Quote
  #4  
Old 02-15-2014, 10:23 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,887
Thanks: 9
Thanked 90 Times in 85 Posts
Rep Power: 525835
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 WJ noise

Quote:
Originally Posted by jbotelho15 View Post
I removed the front drive shaft and noticed a really bad u joint. Im going to replace this and hope that was my problem. Keeping my fingers crossed its not the bearing
Most probably the U-joint is the problem. Let us know how it works out.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 02-15-2014, 10:26 AM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2013
Location: Ma
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
jbotelho15 is on a distinguished road
Will do I took it for a spin with it off and I dont think the noise is there I feel like I here it very slightly but that might just be my head at this point. I know for sure now its related to the driveshaft either going to be the bad u joint or the bearing
__________________
Reply With Quote
  #6  
Old 02-21-2014, 02:57 PM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2013
Location: Ma
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
jbotelho15 is on a distinguished road
Replaced the u joint and now its much better but I do still have a slight noise but this time only when I accelerate.

I also had a ticking that I thought was from the engine but turned out to be a bad camshaft synchronizer. I know alot of peoplehave ticking issues this was mine (if only I could quiet down the evap solenoid now)
__________________
Reply With Quote
  #7  
Old 02-21-2014, 05:17 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,887
Thanks: 9
Thanked 90 Times in 85 Posts
Rep Power: 525835
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 04 WJ noise

Quote:
Originally Posted by jbotelho15 View Post
(if only I could quiet down the evap solenoid now)
You could try to put some rubber between the EVAP purge solenoid and the fender, to isolate as much as possible the noise propagation due to contact. It could eventually be that your EVAP purge solenoid is noisier then normal, then only a new solenoid will solve your problem. (or a better sound system or a more sportier exhaust)
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 02-21-2014, 05:22 PM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2013
Location: Ma
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 594
jbotelho15 is on a distinguished road
Quote:
Originally Posted by Frango100 View Post
You could try to put some rubber between the EVAP purge solenoid and the fender, to isolate as much as possible the noise propagation due to contact. It could eventually be that your EVAP purge solenoid is noisier then normal, then only a new solenoid will solve your problem. (or a better sound system or a more sportier exhaust)
Tried the rubber thing I think its noisier than normal
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Noise!?! robert2012 Technical Service Bulletins and Recalls 11 11-06-2013 01:18 PM
Noise?!?! robert2012 Trouble Shooting/Problems/Service 3 10-14-2013 06:02 PM
Noise robert2012 Tech Tips DIY/How To 0 08-09-2013 01:37 AM
front noise, road noise.. cant pinpoint hamilton5 Troubleshooting/Problems 6 03-30-2013 06:47 PM
little noise mikeeps2 Audio/Visual/Navigation 12 07-17-2012 05:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community