Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-16-2013, 12:36 AM
jeepman465's Avatar
Member
 
Join Date: Aug 2013
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 474
jeepman465 is on a distinguished road
1999 cherokee o2 sensor mess

So I've got issues with my o2 sensors. Po cut the two front o2 sensors and I can't find the plugs. The cat was cut out and no o2 sensor there either. It's running horrible. Spitting and sputtering. If you floor it it just chugs. But if I'm just cruising down the road I'm getting 18 mpg. How's that?
__________________

__________________
Reply With Quote
  #2  
Old 09-16-2013, 11:08 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,050
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526035
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 1999 cherokee o2 sensor mess

4.0 engine? Is this regarding a cherokee or grand cherokee?
Is there still an O2 sensor in place.
When you floor the accelerator, the O2 sensor input is not used (open loop) and the PCM will regulate the injector pulse width according a programmed schedule. Also when there is no O2 sensor input, the PCM will regulate according a programmed schedule. So you probably need to get the O2 sensors back in place.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 09-16-2013, 11:57 AM
jeepman465's Avatar
Member
 
Join Date: Aug 2013
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 474
jeepman465 is on a distinguished road
4.0 grand cherokee. As of right now. One outs of 4 o2 sensors are hooked up.
__________________
Reply With Quote
  #4  
Old 09-16-2013, 12:22 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,050
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526035
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 1999 cherokee o2 sensor mess

So did the PO cut out the small precats close to the manifolds? The O2 sensor wiring is not stowed away to any bundle or other part? There should be some traces left of the wiring at least, when the wires where cut. So you also have the.check engine light on all the time.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 09-16-2013, 12:41 PM
jeepman465's Avatar
Member
 
Join Date: Aug 2013
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 474
jeepman465 is on a distinguished road
Yes it's the pre cats that were cut. I don't see any wiring. Where should I look? Yes check engine light is on.
__________________
Reply With Quote
  #6  
Old 09-17-2013, 04:44 PM
jeepman465's Avatar
Member
 
Join Date: Aug 2013
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 474
jeepman465 is on a distinguished road
Frango I've also noticed if I just sit in park with it running it acts like it goes into limp mode and misses like crazy until I restart the jeep.
__________________
Reply With Quote
  #7  
Old 09-17-2013, 08:50 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,050
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526035
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 1999 cherokee o2 sensor mess

Quote:
Originally Posted by jeepman465 View Post
Frango I've also noticed if I just sit in park with it running it acts like it goes into limp mode and misses like crazy until I restart the jeep.
Goes into limp mode? A transmission goes into limp mode. What do you mean with this?
Depending on the emission package, it could have had only two O2 sensors or four. Are you sure that the precats are cut out? Which fault codes does the PCM show? The missing O2 sensors will be shown as fault. When you don't have a.scanner, use the key dance: ignition switch off/ run three times and leave in run at third time. Odometer will show the fault codes.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 09-17-2013, 08:56 PM
jeepman465's Avatar
Member
 
Join Date: Aug 2013
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 474
jeepman465 is on a distinguished road
The idle gets different if I just sit there and have the jeep idling. It starts missing worse until I shut the jeep off. Mine has four o2 sensor two on the manifold that both wires are cut then another 02 on the down pipe and one after cat.
__________________
Reply With Quote
  #9  
Old 09-17-2013, 11:22 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,050
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526035
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 1999 cherokee o2 sensor mess

So do the key dance and see with which faults it comes up.
The O2 sensors normally have a short wire harness with a connector on it, so probably they just disconnected the connectors. Follow the wire bundles and check if you can find some empty connectors.
Was the jeep running like this from the day you bought it?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #10  
Old 09-18-2013, 12:28 AM
jeepman465's Avatar
Member
 
Join Date: Aug 2013
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 474
jeepman465 is on a distinguished road
No it's gotten worse. I changed to cp sensor awhile back and it's gotten worse since then almost makes me think the crank sensor faulty. Here's my codes p0353,p0138,p1391
__________________
Reply With Quote
  #11  
Old 09-18-2013, 02:00 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,050
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526035
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 1999 cherokee o2 sensor mess

Interresting that there is only one O2 sensor fault stored and then even the downstream sensor(P0138)
The P0353 has to do with ignitor coil #3 control circuit. I would swap this coil with an other position and see if the fault follows. Then you are sure that the coil is faulty. One faulty coil will fore sure cause a rough idle
P1391 has to do with intermittent loss of crank or cam sensor signal. Since you changed the crank sensor, that could be the problem. Did you use a Mopar sensor? Aftermarket sensors for crank and cam do fail more often, better use Mopar.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #12  
Old 09-18-2013, 02:15 AM
jeepman465's Avatar
Member
 
Join Date: Aug 2013
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 474
jeepman465 is on a distinguished road
How do I swap coils? I've never done that before? And it wasn't a mopar crank sensor so I might have to go to the steelership and get one lol.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 Jeep Grand Cherokee ChrisWk Member Garage Discussions 0 05-13-2013 04:21 PM
1999 4.0 cherokee OVERHEATING.. help! flahertysr42 Troubleshooting/Problems Discussion 11 07-12-2012 05:00 PM
1999 Grand Cherokee | I6 4.0 Airintake?! Andrew Grand Cherokee - WK 12 08-17-2009 05:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.