Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-05-2013, 10:39 AM
New Member
 
Join Date: Apr 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Dman0853 is on a distinguished road
2002 Jeep grand Cherokee larado

Had new 6cyl motor installed in Nov 2012 . After getting it back check engine light flashed and power loss..shut off ignition and restart and drives fine...went back to garrage and they replaced plugs said it was a miss fire...picked up jeep and this happened again..took it back and they said code 35 miss fire and they replaced power pack ...picked up and this happened again..took back and they said shows injector 3 .. They did a engine flush and again it happened ..I'm at a loss.. Motor they say has 40'000 miles on it.. Any ideas ?
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Jeep Grand Cherokee Larado dirk8909 Member Garage Discussions 0 02-18-2013 01:46 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.