Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-10-2013, 09:36 AM
josebroo's Avatar
Member
 
Join Date: Jun 2013
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 395
josebroo is on a distinguished road
Garage
2004 Jeep Gr. Chr. Lmtd V8 4.7, Check Engine Light, rough or no shifting to high gear

I have a 2004 JGC Limited with a 4.7 V8 and tow package. I had this same issue two years ago and went away.... it's back. Check engine light comes on, shifts rough or doesn't engage into a high gear at all. I did the key dance which revealed the 0700. I can disconnect the battery which resets the light and of course it shifts just fine... until the light comes on again. I had changed the TPS with MOPAR parts no change.

I had considered attempting the governor pressure sensor and transducer but I was instructed that model does not have this. In reading other forums, they suggest replacing the speed sensors on the transmission. They state that my 4.7 should have an input and output unlike the older models (or V6) that have just an output. I had called the Jeep dealer to check if they have the the speed sensor for the trans, I was told that my model does not show either of these parts but does list a "transducer."

I am trying my damnedest to not go to a shop. I am typically untrustworthy and feel they'll just try to get me to pay for a trans rebuild. Obviously it's got to be a sensor. Any advice on these sensors? Governor sensor? Transducer? OEM part number for a speed sensor? Also can autozone or one of those places pull a more accurate code then what Im getting from the key dance? Can I find my transmission type by entering my VIN on a site? The dealer used my VIN and did not come up with a speed sensor. I'm lost.

Thank you in advance
__________________

__________________
Reply With Quote
  #2  
Old 07-19-2013, 11:18 AM
josebroo's Avatar
Member
 
Join Date: Jun 2013
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 395
josebroo is on a distinguished road
Garage
Follow up.......... Speed sensor(s) on transmission many days of empty walled woes corrected this issue
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re-painted 5.7L HEMI engine cover lettering (2011 Jeep Grand Cherokee Lmtd) foxtrot Interior/Exterior/Visual 11 05-26-2014 09:06 AM
Check Engine Light, Shifting Issues, TPS - no fix josebroo Troubleshooting/Problems Discussion 3 06-29-2013 08:25 AM
Replace light in gear shifter 2004 jeep grand Cherokee Zacedward Grand Cherokee - WJ 25 03-18-2013 09:26 AM
Check Engine, check guages, fan on high MattB5694 Wrangler-JK 3 06-08-2012 01:54 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community