Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-23-2013, 08:36 AM
josebroo's Avatar
Member
 
Join Date: Jun 2013
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
josebroo is on a distinguished road
Garage
2004 Limited Grand Cherokee 4.7 V8, Rough Shifting, Speed Input & Output Sensors

Happy Holidays All,

I have an 04 where I was dealing with a check engine light, rough shifting or no shifting in some cases, P07000 code this past Summer. Of course the trans shops all quoted me thousands to fix except for one who swore it was my speed governor sensor; $500 job. After pouting and further research, a nice gentleman on this site insisted I replace both my input and output sensors ($30). Ill be damned, engine light off, normal shifting..... It was a major relief.

Now, enjoying these below freezing days, had some really bad snow storms, my check engine light popped back on almost a week ago. P07000 code, no symptoms whatsoever until this morning. I was on an incline @45mph, the downshift was a hard shift, a lot like last summer before the sensor change. I pulled into the parking structure, as I was ascending, It felt kinda/sorta like a slipped clutch as I was moving along (RPM increase before response). It did this as well before the sensor change.

So, new sensors (input and output) as of this past July. Is it possible one of those sensors went bad already? I know no direct link between exhaust and the trans but I did just replace my muffler that has more flow/sound. The check engine light came on days after. The sensors appeared to be intact so I partially ruled out that they hit something under there.

Also, over a year ago, my radiator ruptured inside thus causing trans and coolant mixing. I was able to get that all flushed out, didn't change the clutch plate.... it's been fine other than putting it through the ringer for months of trying to figure out the first stated issue.

I didn't sign the paperwork on a 2014 limited for a reason this past Fall. I need to get this one back to health. Thanks in advance
__________________

__________________
Reply With Quote
  #2  
Old 12-25-2013, 02:44 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,926
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525881
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 Limited Grand Cherokee 4.7 V8, Rough Shifting, Speed Input & Output Sensors

Get a scan first to know which fault the TCM has seen.
Also since the exhaust was changed, have a look at the right side of the transmission where the exhaust hanger is. Close to it sits the line pressure sensor, check the wiring that they are not shaving against the exhaust pipe or that insulation is melted..
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 01-25-2014, 04:11 PM
josebroo's Avatar
Member
 
Join Date: Jun 2013
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
josebroo is on a distinguished road
Garage
Thanks Frango.... So I have of course having the identical issues as last time where the input/output sensors corrected the problem. I do not recall what the codes where last spring but my new codes are as follows:

P0700....key dance code
.................................................. ............
P0731 -Gear Ratio Error In First
P0740 -Torque Converter Clutch Out Of Range
P0875 -Underdrive Hydraulic Pressure Test

Symptoms: Check engine light all the time.... when the car is first turned on, It drives normal. After a few miles, it clunks, goes into a lower gear. I could be on the expressway, doing 70mph, it kicks into the error, now I'm doing 70mph at 3500rpms. I can pull off or stop at a light, shut it off, turn it on.... its fine again for a few miles. My trans fluid is right-on mark although I have only checked it while hot. The input/output sensors changed last in June. No issues for 6mos. I do want to note that when I had changed those, the rear sensor of the two was practically in pieces when I removed it. I am hoping to avoid a trans shop where all the local ones mislead me to thinking I need to replace the whole transmission ($1000's). I appreciate your time.
__________________
Reply With Quote
  #4  
Old 01-27-2014, 05:17 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,926
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525881
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 Limited Grand Cherokee 4.7 V8, Rough Shifting, Speed Input & Output Sensors

Do you know the reason why the aft speed sensor was damaged? You could try and swap both speed sensors. If one of them is faulty, you probably get some other problem, like harsh shifting. Also reset the codes first and see if they all come back.
Do you have the idea that its slipping in first gear?
Both faults P0731 and P0740 could be caused by the LR/TCC solenoid in the solenoid block. This solenoid is used to activate the LR clutch (which is for 1st gear), but also for the TCC lockup. The solenoid switch valve inside the valve body decides which one will be selected.
The P0875 could be a side effect due to the LR/TCC solenoid. The pressure switch sits also inside the solenoid block and is tested automatically by the TCM. But when the LR/TCC solenoid doesn't supply pressure, the pressure test will fail.
So i can't garantee it, but there is a good change that the TRS/solenoid block on top of the valve body is the problem. If you would decide to change it, then here is a good address for OEM parts for a good price: Automotive Transmission Electronics Specialists
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 01-27-2014, 05:37 AM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,014
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2392
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
I went through the code p0740. and diagnosed it as a faulty/failing converter/Tcc solenoid pack. I can drive in city conditions and everything works fine, once I go freeway the light comes on, but if I drive with OD off on freeway no check engine light.

Sent from my LG-P999 using Tapatalk 2
__________________
Reply With Quote
  #6  
Old 01-27-2014, 06:09 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,926
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525881
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 Limited Grand Cherokee 4.7 V8, Rough Shifting, Speed Input & Output Sensors

Quote:
Originally Posted by hoffmanestates View Post
I went through the code p0740. and diagnosed it as a faulty/failing converter/Tcc solenoid pack. I can drive in city conditions and everything works fine, once I go freeway the light comes on, but if I drive with OD off on freeway no check engine light.

Sent from my LG-P999 using Tapatalk 2
This is strange, because when you switch OD off, the transmission goes to 3rd gear max, but will still activate the torque converter clutch when in 3rd gear. Since the CEL doesn't come on then, the torque converter seems to be locking ok then. So torque converter clutch and solenoid seem to be working ok then.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 01-28-2014, 08:35 PM
josebroo's Avatar
Member
 
Join Date: Jun 2013
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
josebroo is on a distinguished road
Garage
How hard is it to change the TRS/solenoid block? It needs to be warmer than -5degrees outside before I crawl under there. I do want to note that when I leave work in the parking structure, sharp turn to go around bends, it seems like my trans is slipping. Again, this is sporadic. I would have to shift from drive in 1st otherwise it feels like I'm "riding the clutch" yet in an automatic. Turn the Jeep off, runs like a champ until it goes into it's fault mode.
__________________
Reply With Quote
  #8  
Old 01-28-2014, 08:53 PM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,014
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2392
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Quote:
Originally Posted by Frango100 View Post
This is strange, because when you switch OD off, the transmission goes to 3rd gear max, but will still activate the torque converter clutch when in 3rd gear. Since the CEL doesn't come on then, the torque converter seems to be locking ok then. So torque converter clutch and solenoid seem to be working ok then.
but on highway driving I am running 55mph at 2k

Sent from my LG-P999 using Tapatalk 2
__________________
Reply With Quote
  #9  
Old 01-28-2014, 09:03 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,926
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525881
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 Limited Grand Cherokee 4.7 V8, Rough Shifting, Speed Input & Output Sensors

If the transmission controller sees a fault which could harm the transmission, then it will go into limp mode. In Drive that is 3rd gear, but when selecting the shift lever to 1 or 2 it goes to 2nd gear. Could this be the slipping what you felt?
Changing the TRS solenoid block requires lowering the transmission pan, removing the valve body from the transmission and then changing the solenoid block. No rocket sience and can be done when you have some basic tools like sockets and also some basic mechanics experience. I would not do it as a first job though. Especially laying on the ground under the jeep with a transmission which is still dripping fluid. Removing the valve body is easy, but its a bit lumpy and you have to take Care not to damage it by rough handling. If you would decide to change it, i can guide you through the whole process.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #10  
Old 04-01-2014, 05:31 PM
josebroo's Avatar
Member
 
Join Date: Jun 2013
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
josebroo is on a distinguished road
Garage
Quote:
Originally Posted by Frango100 View Post
If the transmission controller sees a fault which could harm the transmission, then it will go into limp mode. In Drive that is 3rd gear, but when selecting the shift lever to 1 or 2 it goes to 2nd gear. Could this be the slipping what you felt? Changing the TRS solenoid block requires lowering the transmission pan, removing the valve body from the transmission and then changing the solenoid block. No rocket sience and can be done when you have some basic tools like sockets and also some basic mechanics experience. I would not do it as a first job though. Especially laying on the ground under the jeep with a transmission which is still dripping fluid. Removing the valve body is easy, but its a bit lumpy and you have to take Care not to damage it by rough handling. If you would decide to change it, i can guide you through the whole process.
Frango..... Now that it's warmer, im ready to attack this transmission. Should I bother trying to replace the line pressure sensor? Or should I just go for the TRS solenoid? I see there are many Youtube videos on changing this. It definitely slips on occasion in first gear, especially when it was sub-zero outside.

Furthermore, my radiator ruptured for the second time in 15mos thus causing trans fluid and coolant to mix. I caught it right away this time so minimal. Im ordering the radiator tomorrow. I want to order the electronic parts as well to do it all in one shot. Also, do I need to pay the $30 a qt for the Mopar ATF+4 or can I get a much cheaper generic??

Thanks for your time! As always!
__________________
Reply With Quote
  #11  
Old 04-02-2014, 12:09 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,926
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525881
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 Limited Grand Cherokee 4.7 V8, Rough Shifting, Speed Input & Output Sensors

Quote:
Originally Posted by josebroo View Post
Frango..... Now that it's warmer, im ready to attack this transmission. Should I bother trying to replace the line pressure sensor? Or should I just go for the TRS solenoid? I see there are many Youtube videos on changing this. It definitely slips on occasion in first gear, especially when it was sub-zero outside.

Furthermore, my radiator ruptured for the second time in 15mos thus causing trans fluid and coolant to mix. I caught it right away this time so minimal. Im ordering the radiator tomorrow. I want to order the electronic parts as well to do it all in one shot. Also, do I need to pay the $30 a qt for the Mopar ATF+4 or can I get a much cheaper generic??

Thanks for your time! As always!
When the line pressure sensor is faulty (or shorted wiring for example), then it could result in too low line pressure. A shorted wire should give a specific fault code though. It is common practice to change the line pressure sensor during overhaul. If your jeep drove a lot already then a new sensor could be a good idea as well. But your problem seems more related to the TRS solenoid block.
Did the transmission cooler rupture inside the radiator? This is strange if it happens for the second time already.
Regarding the ATF+4, it is the recommended stuff, but others run other compatible fluids as well. I have MOTUL synthetic in there now and it works very well, but i hear others about amsoil with the same results. Just check if the fluid is compatible.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #12  
Old 06-09-2014, 07:05 PM
josebroo's Avatar
Member
 
Join Date: Jun 2013
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
josebroo is on a distinguished road
Garage
Re: 2004 Limited Grand Cherokee 4.7 V8, Rough Shifting, Speed Input & Output Sensors

ImageUploadedByJeepGarage1402358730.425821.jpg

Note the RPMs at 70mph


Sent from my iPad using JeepGarage
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing input/output speed sensors RLM67 Grand Cherokee - WJ 7 09-26-2013 09:41 PM
2004 Jeep Gr. Chr. Lmtd V8 4.7, Check Engine Light, rough or no shifting to high gear josebroo Troubleshooting/Problems Discussion 1 07-19-2013 11:18 AM
1997 grand cherokee limited shifting probs dfoxfish Troubleshooting/Problems Discussion 0 07-03-2011 10:27 PM
Location for Transmission Output/input Sensors t2arrington Troubleshooting/Problems Discussion 4 02-12-2011 05:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community