Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-29-2013, 04:49 PM
gda01's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 495
gda01 is on a distinguished road
2014 JGC 8.4AN screen dead

Hello,

Today after car wash I have realize that Uconnect 8.4" screen is dead... Also not works radio, nav, back camera and all other functionality connected to uconnect... I have check that may be water come to power distribution system - look ok..

May be somebody have similar problems? Any ideas how to solve this?
__________________

__________________
Reply With Quote
  #2  
Old 07-30-2013, 04:51 PM
gda01's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 495
gda01 is on a distinguished road
Hello,


The problem solved.
__________________

__________________
Reply With Quote
  #3  
Old 07-30-2013, 05:17 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 854 Times in 468 Posts
Rep Power: 1927033
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 JGC 8.4AN screen dead

Quote:
Originally Posted by gda01 View Post
Hello,


The problem solved.
Can we find out what your solution was, Sorry I did not see this before.
__________________
Reply With Quote
  #4  
Old 07-31-2013, 12:26 AM
gda01's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 495
gda01 is on a distinguished road
The solution was restart of Uconnect by simultaneous push of "mute" and "tune" buttons for time of 5 seconds.

After this procedure message "uconnect" appear on screen and system started.

Hope this can help to somebody here.
__________________
Reply With Quote
  #5  
Old 07-31-2013, 07:32 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 854 Times in 468 Posts
Rep Power: 1927033
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by gda01 View Post
The solution was restart of Uconnect by simultaneous push of "mute" and "tune" buttons for time of 5 seconds.

After this procedure message "uconnect" appear on screen and system started.

Hope this can help to somebody here.
Hmmm, hopefully a one time problem for you.
__________________
Reply With Quote
  #6  
Old 07-31-2013, 04:43 PM
gda01's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 495
gda01 is on a distinguished road
Hello Willx,


This is not occasional key combination. It was mentioned by some people's as non-documented (dealer, service or similar ....) key combination which was helps with this kind of problems not only to me....
__________________
Reply With Quote
  #7  
Old 07-31-2013, 04:46 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 854 Times in 468 Posts
Rep Power: 1927033
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: 2014 JGC 8.4AN screen dead

Quote:
Originally Posted by gda01 View Post
Hello Willx,


This is not occasional key combination. It was mentioned by some people's as non-documented (dealer, service or similar ....) key combination which was helps with this kind of problems not only to me....
I understand that, I was hoping that the lock up issue only happened once for you. I understand the engineering menus and reset command.
__________________
Reply With Quote
  #8  
Old 08-02-2013, 08:58 PM
sddin's Avatar
Member
 
Join Date: Apr 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 497
sddin is on a distinguished road
I have a 2014 JGC Summit, and mine died this week too. Dealer told me I needed new radio/screen unit, and ordered it from Jeep. I tried the reboot fix described in this thread but didn't solve the problem. Ride not as fun without tunes and access to console controlled amenities.
__________________
Reply With Quote
  #9  
Old 09-15-2013, 04:57 AM
New Member
 
Join Date: Nov 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
tubeli is on a distinguished road
Re: 2014 JGC 8.4AN screen dead

Thanks, was helpfull to me.
__________________
Reply With Quote
  #10  
Old 09-23-2013, 12:32 PM
New Member
 
Join Date: Jul 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
CTPete is on a distinguished road
Re: 2014 JGC 8.4AN screen dead

This happened to me with a 2014 JGC. I tookit to my dealer who told me this is a known problem for which a software update exists. He did the udate for me and the problem was solved.
__________________
Reply With Quote
  #11  
Old 01-18-2014, 06:29 PM
New Member
 
Join Date: Nov 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mjvg is on a distinguished road
Thanks for this info, I've been driving around listening to my iphone while I wait for it to go in for a service this week, Uconnect problem solved
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does the 2014 JGC with 8.4AN play VIDEO? Hazemonster Audio/Visual/Navigation 20 06-15-2014 01:09 PM
2014 Grand Cherokee 7" Screen Dead markus316 Trouble Shooting/Problems/Service 27 08-08-2013 10:38 AM
8.4AN blue screen in reverse Sleestak Grand Cherokee - WK2 - 9 07-14-2013 03:26 PM
8.4AN start-up screen (2014 GC Summit) siegs7 Trouble Shooting/Problems/Service 3 05-06-2013 05:45 PM
Picture of 8.4AN nav screen xnight Grand Cherokee - WK2 - 3 04-05-2013 02:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community