Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-27-2010, 08:29 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12385
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Exclamation 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

Some of you may know what the current problem is, so I'll try to make this brief as possible

Vehicle - 2006 GC V6 3.7L NAG 1 (W5A580) Transmission 4x4 w/ 80K miles

Symptoms

LIMP MODE, only happens when I turn off the car and turn it back on after a couple of minutes.

If I keep the hood open then it does not happen.

Last night I turned off the car left the hood closed and started it after 20 minutes of being shut it went into limp mode.

A couple of hours later tried it with the hood open and started right back up with no problems, so now everywhere I go I have to keep the hood open if I'm going to be a couple of minutes

The codes that I still get are:

P0762 "Shift Solenoid C Stuck On"
P0763 "Shift Solenoid C Electrical" and once a while I get ...
P0710 "Trans fluid temp sensor circuit malfunction"

I have changed the following parts so far ...

Part # 52108308AB - 13 pin connector that is on top of the valve body that contains the circuitry for the temp sensor, speed sensor and all the solenoids $250

Solenoids - Changed out all 3 shift solenoids $160

Starter $100

Battery $150

PCM (TCM is a part of it) $200

Shifter Bezel and whole entire shifter assembly $300

Flashed everything at the dealer ... $95

Almost $1250 just in parts !!!!

So I'm stuck, I don't know what to look for anymore, it is seriously retarded how it only happens when the hood is kept shut and clearly temp related to something that throws the whole phucking car into limp mode !!!

I don't know what to do except the last thing that comes to mind is the wiring harness or the connectors but which one???

Someone care to comment ????
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #2  
Old 07-27-2010, 08:53 AM
Hitchhiking
My Jeep: 2010 6.1L SRT8
 
Join Date: Nov 2009
Location: Who York Busy
Posts: 4,660
Thanks: 1
Thanked 17 Times in 17 Posts
Rep Power: 0
SRTILL8 has a reputation beyond reputeSRTILL8 has a reputation beyond reputeSRTILL8 has a reputation beyond reputeSRTILL8 has a reputation beyond repute
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

yo omar this is weird bro. i doubt its heat related since you say if you leave the hood open and etc.

this is def not it
- but this hood being open to start the car..reminds me how i trick my remote start to start the car while my hood is open.

wish ya the best bro-
__________________

__________________
Reply With Quote
  #3  
Old 07-27-2010, 08:55 AM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16576
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

Did you try taking off neg terminal for a few min? IDK bro I wish I could let you use my warranty bro. I feel for ya!!!
__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #4  
Old 07-27-2010, 09:27 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12385
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

Quote:
Originally Posted by SRTILLA View Post
yo omar this is weird bro. i doubt its heat related since you say if you leave the hood open and etc.

this is def not it- but this hood being open to start the car..reminds me how i trick my remote start to start the car while my hood is open.

wish ya the best bro-
Atilla, I should have been more specific sorry.

If I leave the hood open when the car is off then when I start it back up again with the hood closed it will not go into limp mode.

If I leave the hood closed when the car is off then it will go into limp mode.

IMHO it's about the heat escaping from the bay area and letting something cool suddenly and 10 minutes is not enough time for the engine nor the transmission to cool down enough

Quote:
Originally Posted by White WK Swagga View Post
Did you try taking off neg terminal for a few min? IDK bro I wish I could let you use my warranty bro. I feel for ya!!!
Thanks Nate much appreciated

I think I'm bout to cut my losses and get rid of this thing and get into something else cuz this is getting ridicilous on a student budget
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #5  
Old 07-27-2010, 09:47 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12385
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

55 views come on guys I really need the community help here ...

I have taken the car to the stealer and to a special transmission shop and they are baffled themselves as to what it is ... the stealer keeps on telling me I need to replace my solenoid and when I told them I did they accused me of doing it wrong LOL
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #6  
Old 07-27-2010, 12:03 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,274
Thanks: 869
Thanked 986 Times in 695 Posts
Rep Power: 7717921
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

this trans temp sensor could be the problem. Do you know anything about it? Where its located? etc?
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #7  
Old 07-27-2010, 12:20 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12385
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

It got replaced along side with the circuit board I did that sits on top of the valve body, that does contain the temp sensor ... I checked again for the codes and now the temp sensor code is gone but the solenoid codes remain !!!

It's interesting because I clear the codes and P0762 pops up and I clear that one then P0763 pops up, it's like flipping a coin LOL

one thing I have noticed though that my engine bay gets unregularly HOT, what about any of yours? does it get to the point that you can't even touch the battery or the terminals? I tried to disconnect my battery terminal and was not even able to touch it

I am going to look for simple things such as fan ? or fuses ?
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #8  
Old 07-27-2010, 12:29 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,274
Thanks: 869
Thanked 986 Times in 695 Posts
Rep Power: 7717921
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

maybe the tranny cooler? Does the 3.7's have those?
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #9  
Old 07-27-2010, 12:29 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,274
Thanks: 869
Thanked 986 Times in 695 Posts
Rep Power: 7717921
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

have you checked your coolant? test your coolant and see what it tests out at
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #10  
Old 07-27-2010, 12:44 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12385
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

I will check on the coolant but when I had the scanner plugged in showing real time data the coolant was around 200 normal operating temp and the tranny at 400 LOL

I am planning on doing a coolant flush as part of the regular maintenance schedule this sunday

which can mean a short or low voltage due to resistance somewhere along the line

tranny fluid level is at correct levels and it did not smell burnt at all when the valve body was pulled
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #11  
Old 07-27-2010, 12:46 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,274
Thanks: 869
Thanked 986 Times in 695 Posts
Rep Power: 7717921
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

I would test it with a cheap tester to see if it is normal. The sensor may be reading it incorrectly. Does the 3.7 have a tranny cooler?
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #12  
Old 07-27-2010, 12:54 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12385
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!

I will check into that also it's still mind bobbing with the hood though LOL

I stand corrected yes it does come with one
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranmission Codes P0700 and P0762 - 06 3.7L GC - Someone care to help ??? DJ BoNiOmArIo Troubleshooting/Problems Discussion 19 09-06-2013 12:21 PM
Mygig "Engineering Mode" suzieque Audio, Video, Navigation & Electronic Modifications 24 11-18-2010 09:19 PM
HVAC "Mode" Knob pushed in sam555 Troubleshooting/Problems 0 06-01-2010 10:37 AM
Fuel Saver Mode display on 08 WK??? 08Hemi Grand Cherokee - WK 18 06-16-2009 04:47 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community