Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-31-2011, 03:44 PM
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Sep 2010
Location: Massachusetts
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1511
jsouza111 is on a distinguished road
99 4.0 o2 sensor problems

so the code came up as PO161 O2 Sensor Heater Circuit (Bank 2 Sensor 2). i just dont know which one to replace, but i came upon this pic

http://www.zombiecrisis.org/stuff/engine.jpg

but the only sensors i can see are 2/1 and 1/1
AND wat makes it confusing is that my door says my truck is federal.

HELP GUYS!!!!

which sensor do i replace
__________________

__________________
Reply With Quote
  #2  
Old 10-31-2011, 04:18 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54331
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: 99 4.0 o2 sensor problems

If your jeep is indeed federal only (not california) you will have only 1 main cat instead of that plus 2 mini-cats. On federal there are 2 O2 sensors, 1 each before and after the cat. On California there is 1 before and after each mini cat. So, this code is kind of confusing if your truck is only federal. My guess is it would be the after cat sensor.
__________________

__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #3  
Old 10-31-2011, 04:48 PM
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Sep 2010
Location: Massachusetts
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1511
jsouza111 is on a distinguished road
Re: 99 4.0 o2 sensor problems

yae im confused to. heres this pic that confuses me even more.

http://www.wjjeeps.com/oxygen_40.jpg

the pic that shows federal i dont see either of those o2 sensors. the only sensors i can see are the two i said before ( 2/1 and 1/1 ) which are under the California picture. my guess is thats its the 2/1 but the code said bank 2 sensor 2 which means 2/2.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
O2 Sensor Removal hgb8956 Troubleshooting/Problems 1 04-09-2011 12:12 PM
Which O2 Sensor is Better? SoCalMoparWK Grand Cherokee - WK 5 04-07-2011 04:04 PM
TPS sensor and Cruise Control sensor dhryan44 Troubleshooting/Problems 15 03-03-2011 01:17 AM
Front and rare O2 sensor mixup. Potential problems? magradze Troubleshooting/Problems 2 03-18-2010 09:59 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community