Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-14-2014, 05:02 PM
GC10LTD's Avatar
Member
My Jeep: 2010 3.7L WK
 
Join Date: Nov 2013
Location: Greensboro, NC
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 237
GC10LTD is on a distinguished road
Garage
Acceleration Delay

Maybe Im crazy but ever since I got my jeep, I've noticed that when I push on the gas pedal, it lags sometimes when the RPM's go up. For example, if I make a turn at a stoplight and need to accelerate quickly, I can give it gas, but it takes a second to start accelerating. Anybody know what my issue may be here? I feel like I have to hammer the gas pedal to get her to get going. Any mods that can fix this so I have better throttle response? I have a K&N 77 series and didn't notice much difference.
__________________

__________________
'10 WK Limited - 3.7L V6, 4x4 QTI, K&N 77 Series CAI, ROLA Vortex Rack, Plasti-Dipped Emblems, Plasti-Dipped Wheels, BFG Rugged Terrains
Future Mods:RC 2" Lift, JK MOABS, TOYO M/T's, Bilstein 5100's, 6K HID Lows & Fogs, FASTMAN TB, Thrush Welded Muffler
Reply With Quote
  #2  
Old 01-14-2014, 05:51 PM
tomk's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2012
Location: Amherst, MA
Posts: 307
Thanks: 7
Thanked 9 Times in 8 Posts
Rep Power: 1713
tomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond repute
Re: Acceleration Delay

My '07 does this a lot, the '14 less.

Accelerating after a 'rolling stop' seems to be the worst situation.

...tom
__________________

__________________
2007 WK Limited 5.7L
2014 WK2 Overland 5.7L !!
And a few past Durangos
Reply With Quote
  #3  
Old 01-14-2014, 06:03 PM
GC10LTD's Avatar
Member
My Jeep: 2010 3.7L WK
 
Join Date: Nov 2013
Location: Greensboro, NC
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 237
GC10LTD is on a distinguished road
Garage
Quote:
Originally Posted by tomk View Post
My '07 does this a lot, the '14 less. Accelerating after a 'rolling stop' seems to be the worst situation. ...tom
Is there any way to change this? Or make it more responsive?
__________________
'10 WK Limited - 3.7L V6, 4x4 QTI, K&N 77 Series CAI, ROLA Vortex Rack, Plasti-Dipped Emblems, Plasti-Dipped Wheels, BFG Rugged Terrains
Future Mods:RC 2" Lift, JK MOABS, TOYO M/T's, Bilstein 5100's, 6K HID Lows & Fogs, FASTMAN TB, Thrush Welded Muffler
Reply With Quote
  #4  
Old 01-14-2014, 08:03 PM
jerryjjansen's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Oklahoma City, OK
Posts: 102
Thanks: 0
Thanked 6 Times in 6 Posts
Rep Power: 431
jerryjjansen is on a distinguished road
Garage
My 14 GC Limited V8 did this when I first bought it. Installed a K&N CAI and it went away to never return.
__________________
2014 GC Limited, Hemi V8 5.7L, Max Steel/Black, Sunroof, Tow Group IV, U8.4AN, K&N 77-1563KP CAI, Ionic CXV Running Boards, Billet Technology Signature Series Catch Can, Hemi 5.7 Liter Badge, Escort Max w/Escort Live, Husky Liners, Deluxe Molded Splash Guards
Reply With Quote
  #5  
Old 01-14-2014, 08:52 PM
GC10LTD's Avatar
Member
My Jeep: 2010 3.7L WK
 
Join Date: Nov 2013
Location: Greensboro, NC
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 237
GC10LTD is on a distinguished road
Garage
Re: Acceleration Delay

Quote:
Originally Posted by jerryjjansen View Post
My 14 GC Limited V8 did this when I first bought it. Installed a K&N CAI and it went away to never return.
I installed a K&N intake system (77 series) and it still does it. I don't notice any change over the stock intake.
__________________
'10 WK Limited - 3.7L V6, 4x4 QTI, K&N 77 Series CAI, ROLA Vortex Rack, Plasti-Dipped Emblems, Plasti-Dipped Wheels, BFG Rugged Terrains
Future Mods:RC 2" Lift, JK MOABS, TOYO M/T's, Bilstein 5100's, 6K HID Lows & Fogs, FASTMAN TB, Thrush Welded Muffler
Reply With Quote
  #6  
Old 01-15-2014, 08:02 AM
GC10LTD's Avatar
Member
My Jeep: 2010 3.7L WK
 
Join Date: Nov 2013
Location: Greensboro, NC
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 237
GC10LTD is on a distinguished road
Garage
Quote:
Originally Posted by tomk View Post
My '07 does this a lot, the '14 less. Accelerating after a 'rolling stop' seems to be the worst situation. ...tom
Yes! The rolling stop is by far the worst. It really bugs me. I really want to fix it
__________________
'10 WK Limited - 3.7L V6, 4x4 QTI, K&N 77 Series CAI, ROLA Vortex Rack, Plasti-Dipped Emblems, Plasti-Dipped Wheels, BFG Rugged Terrains
Future Mods:RC 2" Lift, JK MOABS, TOYO M/T's, Bilstein 5100's, 6K HID Lows & Fogs, FASTMAN TB, Thrush Welded Muffler
Reply With Quote
  #7  
Old 01-15-2014, 09:00 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Orlando, FL
Posts: 70
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 424
siegs7 is on a distinguished road
Re: Acceleration Delay

Quote:
Originally Posted by GC10LTD View Post
Yes! The rolling stop is by far the worst. It really bugs me. I really want to fix it
I agree. I have the same problem. I seem to notice it more from a stop to go, or when turning a corner - very annoying. It does seem to be more responsive if I drive in Sport mode though.

A fix/patch/flash etc... would be great!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another delay for the 14' Cherokee KL Scottina06 2014+ Cherokee-KL 26 06-26-2013 07:21 AM
Acceleration/Launch Delay frog_a_lot Diesel Powered 2012+ Export Grand Cherokee 9 02-23-2012 08:38 AM
Manufacturing Delay? boldd Grand Cherokee - WK2 - 41 05-16-2011 09:50 AM
tranny delay jdubgrand Grand Cherokee - WK 11 11-30-2010 12:47 PM
Delay for 2011 WK? Scottina06 Grand Cherokee - WK2 - 6 10-06-2009 01:09 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community