Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-01-2012, 06:16 AM
Ypahihi's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Oct 2011
Location: Nakara, NT, Australia
Posts: 169
Thanks: 15
Thanked 5 Times in 4 Posts
Rep Power: 5670
Ypahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond repute
Brake Booster Repair Gone Bad

Hi All,

Had to replace brake booster as mine was making horn noises.
I thought all had gone well (after I had realigned the booster rod with the master cylinder shaft for the second time) and drove to work.
Someone noticed that my brake lights were on which left me with a flat battery. Had another look at my heavy handed handiwork and have discovered this damage.

Problem Number 1:
Brake pedal toggle switch short about 10mm from contacting brake pedal arm (hence lights on and flat battery).
Is it a pedal thing, toggle thing or have I not aligned the rod and shaft properly?

Problem Number 2:
Speedo and RPM dials not functioning.
I have killed a sensor or wiring arrangement somehow, any ideas?

Problem Number 3:
Broken electrical relay thing which sticks out the side of the master cylinder.
Truthfully I didn't consider it important enough to disconnect when I moved it around to get booster in and out.
I have been able to push it back into the M/cylinder but i am only kidding myself if I think it will work again (whatever it does).

I will be researching the answers to find answers, but thought I would throw it out there for anyone to answer.

Looks like my 4 day fishing trip to Arnhem land is fading fast.

Barney
__________________

__________________
Reply With Quote
  #2  
Old 09-01-2012, 07:15 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,779
Thanks: 9
Thanked 68 Times in 66 Posts
Rep Power: 525703
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Brake Booster Repair Gone Bad

Hi Barney. The brake pedal switch is adjustable and most probably the adjustment was disturbed when removing the booster. You can easily pull it out when you press the brake pedal, and when you release the pedal it should automatically adjust itself (you will hear a ratcheting sound).
The speedo and rpm where working before you started the job? Are all other lamps/ indicators working? All indicators get their information from the PCM via the PCI data bus. You can test the instruments via the instrument self test: with ignition in off, push the odometer reset switch and while keep it pushed, switch the ignition in on. All indicators should go full scale, all lamps will be lit and odometer will count 11111, 2222 etc. As soon as the test is started, you can release the odometer reset switch.
Regarding the electrical connector, on my WJ i only have a connector on the side of the master cylinder reservoir, its for the low level switch which will switch on the red brake warning lamp on the instrument cluster. Is the sensor housing broken?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 09-01-2012, 08:11 AM
Ypahihi's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Oct 2011
Location: Nakara, NT, Australia
Posts: 169
Thanks: 15
Thanked 5 Times in 4 Posts
Rep Power: 5670
Ypahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond repute
Re: Brake Booster Repair Gone Bad

Hey Frango,

Thanks for the info.

Yes, everything was working prior to the jump start at work. Will give the odometer reset a go in the morning. It would appear to be a common issue after jump starting a WJ from all the forum chatter.

I am hoping the ratchet on the brake pedal is the answer as I did have a play with the brake pedal at work but couldn't get it to readjust itself. Have a piece of rubber taking up the slack at the moment.

I'm assuming the reservoir connector is the sensor you are talking about. It had come out of the reservoir altogether and I could see solder where it had snapped off. Will watch to see if red light is on dash.
Maybe I can live without it?

Maybe virgin fishing grounds are still within my grasp?

Thanks again
__________________
Reply With Quote
  #4  
Old 09-01-2012, 09:03 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,779
Thanks: 9
Thanked 68 Times in 66 Posts
Rep Power: 525703
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Brake Booster Repair Gone Bad

Are only the odometer and speedometer not working, or are all instruments not working? No idea why after a jumpstart the instruments wouldn´t work.
The ratchet on the brake pedal switch should do the trick, i had an issue with it on my jeep before as well and it worked out well.
Ofcourse you could live without the brake fluid low level warning, but is a simple repair not possible? Is it the connector itself which is broken? Didn´t you have a "spare" jeep for parts, if so, you could use the connector from that one and splice it in the wiring.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 09-01-2012, 12:27 PM
Ypahihi's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Oct 2011
Location: Nakara, NT, Australia
Posts: 169
Thanks: 15
Thanked 5 Times in 4 Posts
Rep Power: 5670
Ypahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond repute
Re: Brake Booster Repair Gone Bad

Just the speedo and tachometer stopped working. From all accounts when you jump start the needles spin 358 degrees and end up under the normal resting point.

I swapped out the booster from the spare WJ and will swap out the master cylinder as well to fix the broken sensor. The sensor itself had been pulled out because I hadn't disconnected it before repositioning it when changing the booster. Its about an inch long and has a little diode soldered into it.
__________________
Reply With Quote
  #6  
Old 09-01-2012, 11:39 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,779
Thanks: 9
Thanked 68 Times in 66 Posts
Rep Power: 525703
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Brake Booster Repair Gone Bad

So hopefully the tacho and speedo will return to normal position during the instrument self test, but i think that it will only try to move the pointers more against the stop pin and not doing anything else. Maybe disconnecting the battery would help?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 09-07-2012, 05:24 PM
Ypahihi's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Oct 2011
Location: Nakara, NT, Australia
Posts: 169
Thanks: 15
Thanked 5 Times in 4 Posts
Rep Power: 5670
Ypahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond reputeYpahihi has a reputation beyond repute
Re: Brake Booster Repair Gone Bad

Reset worked a charm, also I ended up pulling the master cylinder off and realigned the shaft for third time with a friends help and it fixed the 10mm gap. Still haven't figured out how it made a difference???
I have not changed the reservoir over as it appears to be working (no lights on dash) but will watch it closely and change it if required.

Managed to go fishing but the tales of virgin fishing grounds and baramundi by the hundreds were just tall tales. There were more people there than a new mall/ shopping center sale day'
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will a bad alignment cause uneven brake pad wear? snowchiq16 Wheels/Tires/Brakes 8 08-04-2011 08:46 PM
Booster Seat Warning! JeepeeJ Trouble Shooting/Problems/Service 8 05-04-2011 06:41 PM
Transmission Line Pressure Booster sanitarium16 Grand Cherokee - WK 26 04-03-2011 12:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community