Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-17-2009, 06:55 PM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,113
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94651
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Crap Idle? 4.7 V8

So i"ve asked this question on may other forums and no one seems to have a solution for it and apparently Chrysler denies its a real.

The jeep under no common circumstances will stall out or bog down when stopping. BTW 4.7 V8.
It will happen when the engine is cold, or hot, it will happen after alot of skinny pedal driving or under normal human grandma driving. It will happen in stop and go traffic or in normal traffic.

Basically normally when i come to a stop the rpms drop like the should and stay there. Some times it will drop well below the 500 rpm mark and then bounce back up. Occasionally it will just stall out completely and die.

I talked to a very well seasoned master jeep tech at the dealership. He said that first thing they do is a reflash of the computer. (did that and it did not fix it)

Next he said it could be the torque converter is not working properly and that adding about 1/2 a qt of tranny fluid may fix the issue. ( i will try this next)

Has anyone else sxperienced this and successfully fixed it?

Please help, its really annoying and embarassing.
__________________

__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #2  
Old 06-17-2009, 07:02 PM
dreamer1213's Avatar
Founding Member
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 918
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2923
dreamer1213 has a reputation beyond reputedreamer1213 has a reputation beyond repute
Re: Crap Idle? 4.7 V8

Hmm....my 4.7 H.O in my WJ drops to super low idle mode when coming to a stop sometimes....it drops and idles at 400 rpm's...but has never stalled...

I cleaned out the IAC chamber and motor, and still nothing..same thing...I dunno if its a glitch somewhere in the computer system, or if its the IAC motor thats actually bad...
__________________

__________________
{ Hannes }

02 WJ Overland 4.7L H.O V8

Reply With Quote
  #3  
Old 06-17-2009, 07:29 PM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,113
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94651
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: Crap Idle? 4.7 V8

I was wondering about the IAC myself but everyone i have talked with the issue said they changed it and it did not fix it. Thats why i have not wasted my money on a new IAC yet.
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #4  
Old 06-17-2009, 07:41 PM
dreamer1213's Avatar
Founding Member
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 918
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2923
dreamer1213 has a reputation beyond reputedreamer1213 has a reputation beyond repute
Re: Crap Idle? 4.7 V8

Yeah...I dunno...I was thinking perhaps when I do the superchips flash that it might perk up/smooth out the idle..
__________________
{ Hannes }

02 WJ Overland 4.7L H.O V8

Reply With Quote
  #5  
Old 06-17-2009, 07:44 PM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,113
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94651
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: Crap Idle? 4.7 V8

Thats the other thing that bugs me. To me even when its not acting up, the idle never feels very smooth, it feels like it has a bad idle or bad spark plugs or sumtin, almost a very little shaky, but not in the sound, or seat or anything but i only notice it when i lean my knee on the door while idling.
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #6  
Old 06-17-2009, 09:17 PM
Dylans3960ccs's Avatar
Senior Member
 
Join Date: Jun 2009
Location: Alpharetta ,GA
Posts: 3,808
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5846
Dylans3960ccs has a reputation beyond reputeDylans3960ccs has a reputation beyond reputeDylans3960ccs has a reputation beyond reputeDylans3960ccs has a reputation beyond repute
Re: Crap Idle? 4.7 V8

it is probably the mass air-flow sensor for your case ,Hannes your on your own?.?.
__________________
Reply With Quote
  #7  
Old 06-17-2009, 10:43 PM
baronvonhavok's Avatar
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Jun 2009
Location: Stamford, CT
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2103
baronvonhavok is on a distinguished road
Send a message via AIM to baronvonhavok
Re: Crap Idle? 4.7 V8

i seem to have the exact opposite problem. when in park or neutral, my car idle's at 1500 RPMs. i also have the 4.7, but its non-HO in a 04 WJ. the only mod i have is the K&N intake. i can't really remember when this started happening.

any ideas guys?
__________________
Paul
Silver 04 4.7L WJ


Reply With Quote
  #8  
Old 06-18-2009, 04:55 AM
dreamer1213's Avatar
Founding Member
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 918
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2923
dreamer1213 has a reputation beyond reputedreamer1213 has a reputation beyond repute
Re: Crap Idle? 4.7 V8

1500 rpm idle....something is wayyyyyyyyy wrong!! I'd say the throttle position sensor perhaps your case Paul. That sensor isn't sending the computer the right info...that would be my first guess..
__________________
{ Hannes }

02 WJ Overland 4.7L H.O V8

Reply With Quote
  #9  
Old 06-18-2009, 06:38 AM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,113
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94651
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: Crap Idle? 4.7 V8

Quote:
Originally Posted by Dylans3960ccs View Post
it is probably the mass air-flow sensor for your case ,Hannes your on your own?.?.
There is not mass air flow sensor on jeeps.
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #10  
Old 06-18-2009, 11:17 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,381
Thanks: 875
Thanked 1,045 Times in 720 Posts
Rep Power: 7718297
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Crap Idle? 4.7 V8

oh my god....Dylan tries to post somewhere beside off topic.....and has no idea!!!!LOL
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #11  
Old 06-18-2009, 11:28 AM
baronvonhavok's Avatar
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Jun 2009
Location: Stamford, CT
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2103
baronvonhavok is on a distinguished road
Send a message via AIM to baronvonhavok
Re: Crap Idle? 4.7 V8

the other thing i realized it might be on the way to work today. i have a automatic starter installed. i don't know if this has anything to do with what might be wrong, but it might help you guys think of stuff.

i want to call the stealership, but im afraid they'll give me a lot of shit for the intake and the autostart.

any opinions on my options? haha
__________________
Paul
Silver 04 4.7L WJ


Reply With Quote
  #12  
Old 06-18-2009, 11:50 AM
mjl2610's Avatar
Senior Member
My Jeep: 2006 4.7L WK
 
Join Date: May 2009
Location: Chicago, IL
Posts: 1,526
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 3569
mjl2610 has a reputation beyond reputemjl2610 has a reputation beyond reputemjl2610 has a reputation beyond reputemjl2610 has a reputation beyond repute
Re: Crap Idle? 4.7 V8

Possible vacuum hose issue?? I recall on my friends Jeep his high idle was due to a vacuum hose that was broken.
__________________

__________________
-Mike

Mike, 26, have a 2006 Dark Khaki WK Limited 4.7L; SICK stock 17" 5 Spoke Ronins :/ , Walker QuietFlow muffler, 7500K headlamp and fog Halogens, LED license plate lighting, Interior LED lighting, Champion Platinum Power spark plugs.

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community