Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-27-2009, 11:41 PM
Member
 
Join Date: Jun 2009
Location: canada
Posts: 397
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2288
spiker01 is a name known to all
have you replaced your waterpump???

i was having an issue with a clacking sound from under the hood, so upon further inspection i noticed my water pump was failing. i only have 53000kms on my jeep so i was pretty surprised it was messed up so soon. the older wj's and xj's water pumps wore out prematurely at 130000kms, but 50,000?? damn. anyway i took it to the shop as i am too busy, and the garage is too full to do it myself. $550 dollars later and im all fixed. definately pricey, but what ya gonna do?? so.......has anyone elses replaced their waterpumps so soon??? BTW i think in miles its only like 28000
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #2  
Old 11-28-2009, 01:50 PM
1 GRAND's Avatar
Member
 
Join Date: Jul 2009
Location: Elkhorn City, Kentucky
Posts: 748
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2624
1 GRAND has a reputation beyond repute1 GRAND has a reputation beyond repute
Re: have you replaced your waterpump???

Nope. 43,500 on the Overland and over 300,000 on the old ZJ and no problems.
__________________

__________________


2007 Jeep Grand Cherokee Overland Hemi QD II

2006 Jeep Commander 65th Anniversary 3.7 4x4

1998 Jeep Grand Cherokee 5.9 Limited 4x4

1994 Jeep Grand Cherokee Limited V8 4x4 Lifted
Reply With Quote
  #3  
Old 11-28-2009, 01:57 PM
Member
 
Join Date: Oct 2009
Location: Antioch, IL
Posts: 128
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1895
Hemi WK is just really nice
Re: have you replaced your waterpump???

Wow that sucks. What engine do you have? I'm at 57K miles and no problems. My old 4.7 WJ had close to 190K miles on it when I sold it and the water pump was still original.
__________________
Mike
Reply With Quote
  #4  
Old 11-28-2009, 03:33 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12323
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: have you replaced your waterpump???

one of my friends had to replace the water pump on his wj when it had only 15k miles on it ...

I guess ur water pump was a lemon like his ... chit like that happens hope there is nothing else that is wrong
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #5  
Old 11-28-2009, 04:21 PM
TimmyB's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jun 2009
Location: Boston, MA
Posts: 1,928
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 3911
TimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond repute
Re: have you replaced your waterpump???

I had a 94 GC where the water pump went on it at about 110,000 miles, the shop charged me $330 to replace it, then it went again about 30,000 miles later and I picked one up myself and installed it for about $115.

You never know with engine parts like that, could of been a bad seal or something not machined right from the manufacturer. Things like water pumps are common to replace as its always spinning. The price of over $500 you spent was def very high. The water pumps on a WK are fairly easy to get to and replace yourself, if one has the time and tools to do it.
__________________
I love my Jeep :thumbsup:
Reply With Quote
  #6  
Old 11-28-2009, 04:23 PM
TimmyB's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jun 2009
Location: Boston, MA
Posts: 1,928
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 3911
TimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond repute
Re: have you replaced your waterpump???

But you say you had a "clacking" sound under the hood, and it was in fact the water pump? Usually when a water pump fails the coolant pisses out of it. Was it over heating also, or any leaking coolant?
__________________
I love my Jeep :thumbsup:
Reply With Quote
  #7  
Old 11-28-2009, 07:26 PM
1 GRAND's Avatar
Member
 
Join Date: Jul 2009
Location: Elkhorn City, Kentucky
Posts: 748
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2624
1 GRAND has a reputation beyond repute1 GRAND has a reputation beyond repute
Re: have you replaced your waterpump???

Quote:
Originally Posted by TimmyB View Post
But you say you had a "clacking" sound under the hood, and it was in fact the water pump? Usually when a water pump fails the coolant pisses out of it. Was it over heating also, or any leaking coolant?

You can hear the bearings going out of a waterpump.
__________________


2007 Jeep Grand Cherokee Overland Hemi QD II

2006 Jeep Commander 65th Anniversary 3.7 4x4

1998 Jeep Grand Cherokee 5.9 Limited 4x4

1994 Jeep Grand Cherokee Limited V8 4x4 Lifted
Reply With Quote
  #8  
Old 11-28-2009, 08:36 PM
Member
 
Join Date: Jun 2009
Location: canada
Posts: 397
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2288
spiker01 is a name known to all
Re: have you replaced your waterpump???

yes it was the bearings. you could move the shaft a 1/4", it was leaking but barely. i would have done it my self, but i have been on a tight schedual lately. im just glad its all fixed. oh ya, i have the 3.7l. the jeep has been great really. i have replaced the battery, and waterpump....thats it. it runs and drives great
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #9  
Old 11-28-2009, 09:03 PM
Chaoul1's Avatar
The Original

My Jeep: 2010 6.1L WK
 
Join Date: May 2009
Location: Fairfax, Virginia
Posts: 6,913
Thanks: 2
Thanked 24 Times in 24 Posts
Rep Power: 63346
Chaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond repute
Re: have you replaced your waterpump???

My ZJ's water pump went out 2 months before summer and it had 206,000 miles on it and that was the original water pump.
__________________
-Paul-
2010 Jeep Grand Cherokee SRT8

PaulsProfessional Automotive Detailing

PPAD's Custom Headlights

Contact for both DetailingPPADscustomwork@yahoo.com
Reply With Quote
  #10  
Old 11-28-2009, 11:04 PM
Hamze's Avatar
Member
 
Join Date: Sep 2009
Posts: 288
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2163
Hamze has a reputation beyond reputeHamze has a reputation beyond reputeHamze has a reputation beyond reputeHamze has a reputation beyond reputeHamze has a reputation beyond repute
Re: have you replaced your waterpump???

The Quality of modern vehicles is deteriorating guys.... Not as good as the old ones... have the 3.7L , replaced pump at 50,000 miles, and the 4 O2 sensors ..
__________________


Got a Terminal Illness........ a nasty Mod BUG !
Reply With Quote
  #11  
Old 11-29-2009, 03:08 AM
TimmyB's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jun 2009
Location: Boston, MA
Posts: 1,928
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 3911
TimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond reputeTimmyB has a reputation beyond repute
Re: have you replaced your waterpump???

I have done the water pump in my WK this summer when it had about 60k on it. I also replaced the belt because I got a new one cheap on ebay. My water pump was leaking coolant, and I replaced the big upper coolant hose to the radiator and all the clamps just for fun.
__________________
I love my Jeep :thumbsup:
Reply With Quote
  #12  
Old 10-05-2011, 04:18 PM
New Member
 
Join Date: Oct 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mmason3838 is on a distinguished road
Re: have you replaced your waterpump???

Quote:
Originally Posted by TimmyB View Post
But you say you had a "clacking" sound under the hood, and it was in fact the water pump? Usually when a water pump fails the coolant pisses out of it. Was it over heating also, or any leaking coolant?

I have the same problem currently with my water pump, the clacking is definetly coming from the pump
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community