Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-01-2014, 05:01 PM
New Member
 
Join Date: Mar 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
coonhoundmobile is on a distinguished road
heat kind of works

Hello all my wife's 06 liberty had the recall for the fan done at the dealership
a week after the resistor pack blew. no big deal replaced, all OK. NOW jeep doesn't heat like it used to or as quick as it used to. Also notice a noise coming from the heat system when its in certain positions. Dealership said the system goes through a self test mode and that the system was operating normally. Well if it is in self test mode all the time isn't that wrong? the only time the noise stops is if the jeep is off. They said it is a vacuum system but the temp door is electrically operated. Heat still unacceptable. Haven t check level of coolant YET. t stat working, engine gauge rises and stops in middle. But will eliminate that as well. any other ideas? your help would be appreciated thanks in advance.
__________________

__________________
Reply With Quote
  #2  
Old 03-02-2014, 08:30 AM
sanjuro77's Avatar
Member
My Jeep: 1996 4.0L ZJ
 
Join Date: Dec 2013
Location: NE Ohio
Posts: 207
Thanks: 2
Thanked 17 Times in 15 Posts
Rep Power: 663
sanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond repute
Quote:
Originally Posted by coonhoundmobile View Post
Hello all my wife's 06 liberty had the recall for the fan done at the dealership
a week after the resistor pack blew. no big deal replaced, all OK. NOW jeep doesn't heat like it used to or as quick as it used to. Also notice a noise coming from the heat system when its in certain positions. Dealership said the system goes through a self test mode and that the system was operating normally. Well if it is in self test mode all the time isn't that wrong? the only time the noise stops is if the jeep is off. They said it is a vacuum system but the temp door is electrically operated. Heat still unacceptable. Haven t check level of coolant YET. t stat working, engine gauge rises and stops in middle. But will eliminate that as well. any other ideas? your help would be appreciated thanks in advance.
The gauge should rise to the middle-ish and then drop again when the thermostat pops, not stay in the middle.
Is it a matter of the heat not getting hot or not coming through the correct vents?
Just thinking the blend door could be stuck
__________________

__________________
Reply With Quote
  #3  
Old 03-02-2014, 03:55 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,928
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525884
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: heat kind of works

Just to rule out all posibilities, is the flow from the air exits as before? On the WJ it happened a lot that the wires to the controller where crossed with as a result a counter rotating fan. It was still making noise, but the flow was very low.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Blend Door issue (no heat to footwell area), and very high interior heat temps MandEOntario 2014+ Cherokee-KL 5 02-23-2014 08:50 PM
AC/Heat works on high only... Triplecrown Troubleshooting/Problems 9 09-03-2013 05:54 PM
Heat / AC only works on MAX alexm Grand Cherokee - WK 6 04-07-2011 02:15 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community