Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-07-2011, 12:26 PM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2783
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Exclamation Help! Electrical issue. Urgent

On my dash the battery/voltage light flashes and prevents my jeep from shifting into 4th or 5th gear. Also cruise control won't turn on. Please help me out.

So far what I've done... disconnected my halos amp. Radar detector and phone charger.
I took it too autozone and they said my alternator is good and also my battery, which is an everstart maxx battery.

This morning I took off the terminals and cleaned them with sand paper and same with the connectors.

Started her up, no low voltage light flashed. But after 5 minutes of driving it came on and prevented proper shifting. Also I didn't have anything running. No stereo lights anything plugged in. Please help me out. Thank you
__________________

__________________
2005 WK 5.7 Limited / AFE CAI / Powerstick exhaust / predator tuned / Gloss black viper rims / Tinted tails / 6K lows and fogs / SRT8 front bumper / custom side rails ;) / 5% tint all around / Custom stereo / pioneer 4300dvd / neon accent lighting / Green/white halo's

Coming soon- 180 thermostat./ or a jeep srt8

Reply With Quote
  #2  
Old 02-07-2011, 01:34 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12314
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: Help! Electrical issue. Urgent

interesting did you try flashing it completely? Disconnect for a while and let it sit then re-connect also if your shift is being played with that means the PCM is receiving wrong signal and causing TCM not to over shift beyong 3rd gear.

I always say this and it works 50/50 try cleaning out your contacts, under your hood check out the main harness behind the fuse boxes, clean them hoes out with di-electric cleaner and also the pcm connections alongside with the connections, see if that helps. If not then we can see what else is possible bro
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #3  
Old 02-07-2011, 01:47 PM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2783
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: Help! Electrical issue. Urgent

i just did that... when i was at work. umm anything else you can think of? it all started when i got my amp installed.. i wonder if my battery is bad. even tho they said it was good?
__________________
2005 WK 5.7 Limited / AFE CAI / Powerstick exhaust / predator tuned / Gloss black viper rims / Tinted tails / 6K lows and fogs / SRT8 front bumper / custom side rails ;) / 5% tint all around / Custom stereo / pioneer 4300dvd / neon accent lighting / Green/white halo's

Coming soon- 180 thermostat./ or a jeep srt8

Reply With Quote
  #4  
Old 02-07-2011, 01:56 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,402
Thanks: 55
Thanked 132 Times in 114 Posts
Rep Power: 542559
robpp has disabled reputation
Re: Help! Electrical issue. Urgent

sounds like battery, maybe AMP is causing a discharge somewhere when jeep is off.

ask them o test each cell and do a load test.
__________________
Reply With Quote
  #5  
Old 02-07-2011, 02:12 PM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2783
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: Help! Electrical issue. Urgent

Quote:
Originally Posted by robpp View Post
sounds like battery, maybe AMP is causing a discharge somewhere when jeep is off.

ask them o test each cell and do a load test.
Thank you, they supposedly did that.. but i have a warranty on that battery.. i wanna get it changed.. we did have some really bad temperature changes down here (from 70 degrees to the 10's)

thanks. anything that you can think of i would love to hear it
__________________
Reply With Quote
  #6  
Old 02-07-2011, 02:33 PM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16506
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: Help! Electrical issue. Urgent

Damn sorry to hear Taylor. I was going to say what Omar said. These are tge issues I'm afraid of that's why I got the 2 year itch to get out of this jeep.
__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #7  
Old 02-07-2011, 02:38 PM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2783
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: Help! Electrical issue. Urgent

yea, its probaly bc i was being a jackass having all that sh*t hooked up. i'm gonna get a new battery and get an extra battery hooked up for my amp
__________________
Reply With Quote
  #8  
Old 02-07-2011, 02:42 PM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16506
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: Help! Electrical issue. Urgent

Maybe a bat with higher CCA rating?
__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #9  
Old 02-07-2011, 02:42 PM
B.P.O.D's Avatar
RockNrolla/JG Founder

My Jeep: 2008 3.7L WK
 
Join Date: May 2009
Location: Bergen County, NJ / Bushkill, PA
Posts: 14,644
Thanks: 3
Thanked 9 Times in 8 Posts
Rep Power: 16638
B.P.O.D has disabled reputation
Send a message via AIM to B.P.O.D
Re: Help! Electrical issue. Urgent

hopefully the battery will solve your issue!
__________________
Irfan "Showing off is the fool's idea of glory."
can you beat me in a fight??? http://dreamps.mybrute.com
member of Black, Tri-State, 6 cylinder club 08 Brilliant Black Laredo (JG 3.7L Squad)- k+n 63-1545,magnaflow 10436,mygig(ren), HID's 6k lows, 6k+3k fogs,dual turn leds,led brows,v-led interior leds, cargo led strip, reverse hids, 92 led brake lights, tinted tails,custom powder coated mesh grill, srt sways, 15% tinted windows,illuminated visors,shorty antenna, HH Class III, cargo liner, thule snowboard rack,kayak rack, bike rack

Future mods - color matched side mirrors, black srt reps

My 1-step correction writeup

How To - LED BROW

Reply With Quote
  #10  
Old 02-07-2011, 06:05 PM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2783
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: Help! Electrical issue. Urgent

knock on wood...

i bought the nice everstart battery from walmart in december of 09'
3 year warrenty on it and i know even if the battery has a few bad cells in it, it can still read good, but will throw a code.

so i went to walmart and told the guys my problem b4 and told them i just took it to the dealership to have a full diagnostics done and it was the battery so they wouldnt put it on their machine.

if it reads a good battery at walmart they wont change the battery.

so they switched it out, and i havent had a problem with it when i drove it back to the gym... i hope this was the fix.. hopefully i had all my lights on and halo's, led's and stereo bumping and burnt a cell and thats all it is...

thank you for everyone's help... i was really worried about it being serious.
a fix on a jeep for a 19 year old can be quite detrimental to the mod budget or going out party budget lol
__________________
2005 WK 5.7 Limited / AFE CAI / Powerstick exhaust / predator tuned / Gloss black viper rims / Tinted tails / 6K lows and fogs / SRT8 front bumper / custom side rails ;) / 5% tint all around / Custom stereo / pioneer 4300dvd / neon accent lighting / Green/white halo's

Coming soon- 180 thermostat./ or a jeep srt8

Reply With Quote
  #11  
Old 02-07-2011, 07:37 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12314
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: Help! Electrical issue. Urgent

glad to know you got it fixed, yeah i def recommend installing another a battery for your toys, although the battery on the jeep should be plenty but u never know with these POS's know a days.
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #12  
Old 02-07-2011, 07:54 PM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2783
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: Help! Electrical issue. Urgent

Quote:
Originally Posted by DJ BoNiOmArIo View Post
glad to know you got it fixed, yeah i def recommend installing another a battery for your toys, although the battery on the jeep should be plenty but u never know with these POS's know a days.
i think the reason why we have to have an extra battery unlike i did on my 93 grand cherokee was bc we have all these computers that regulate things...
but i appreciate it.. i'm gonna drive home tonight and that will be about a 15 min drive so we shall see
__________________

__________________
2005 WK 5.7 Limited / AFE CAI / Powerstick exhaust / predator tuned / Gloss black viper rims / Tinted tails / 6K lows and fogs / SRT8 front bumper / custom side rails ;) / 5% tint all around / Custom stereo / pioneer 4300dvd / neon accent lighting / Green/white halo's

Coming soon- 180 thermostat./ or a jeep srt8

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!! Weird electrical issue jcostri09 Troubleshooting/Problems 7 11-01-2012 09:04 AM
urgent help needed JRsmoothee Grand Cherokee - WK 15 09-18-2010 03:55 PM
URGENT - Doing Brembo Conversion soontobesrt Performance Modifications 3 06-27-2010 07:38 PM
Electrical issue Mistereblack Troubleshooting/Problems 9 05-18-2010 01:15 AM
i have an electrical issue!!!!!!!!!! BUDAKANE Troubleshooting/Problems 5 11-25-2009 08:42 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community