Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-28-2013, 02:24 PM
New Member
 
Join Date: Dec 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Gavo is on a distinguished road
Send a message via Skype™ to Gavo
Well I hope I haven't brought a dog....? Today I went to the JGC 2.7 CRD 03 to start it and it wouldn't start. It would turn over but not fire, eventually it took approx 8 - 10 seconds for it start. Once started I left it for a few minutes to warm up. After that I turned it off and it started first time. So I went for a drive, started off and felt ok, after 2 miles I heard a bang, a lot off rattling and then no PAS, suddenly I saw a small ball of fire bouncing around in my rear view mirror. I stopped after a further 1/2 mile looked under the hood and noticed that the pulley for the alternator was missing. So I went back down to where I thought it came of and luckily found it ( I only went back for it because I was worries someone may of hit it). Now... A few question's 1. How this happen? 2. The alternator is still spinning free so do I need to replace it? 3. What is a clutch pulley and can I get one to just replace the one that fell off? 4. Has this ever been heard of and is it common? Sorry for the babel but I am new to forums and really scratching my head and need to know I I have a dog or not... I have other issues but this is the major one at the moment. Thanks for your time Gavo
__________________

__________________
Reply With Quote
  #2  
Old 12-30-2013, 01:49 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,908
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525859
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: I have brought a dog....

The pulley bolt was most probably not correctly torqued down. I have never heard of this before, but it can happen.
If the alternator shaft is not damaged, i don't see a reason why you should not continue using it.
The no start condition can be due to worn glow plugs. You normally discover this when the weather gets colder.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bully dog watch dog gauges ylimits Diesel Powered WK Grand Cherokee 2 12-19-2012 10:18 PM
Brought her home today =] ItsAJeepThing Members Rides 51 07-31-2012 12:50 PM
We brought our new Overland home! EmeraldOne Grand Cherokee - WK2 - 20 10-11-2010 05:07 PM
New WK2 Overland brought home... Technosavant Members Rides 42 09-26-2010 04:04 PM
Look at what fedex brought me today... Bigdiesel74 Visual Modifications 20 10-06-2009 11:36 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community