Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-28-2013, 07:56 PM
TJXJWJ's Avatar
The "pre" SRT 8
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jun 2010
Location: Aurora, OH
Posts: 3,435
Thanks: 195
Thanked 72 Times in 61 Posts
Rep Power: 286733
TJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond repute
Garage
Intermittent Gauge Cluster!!!

Hey everyone! My wife's 09 Liberty has a very intermittent gauge cluster issue. It seems to only happen when it's wet out. Basically anything digital on the cluster goes out. No outside temp, no odometer, no idiot lights. Everything goes dark in the cluster. The Jeep still runs as normal. After it warms up (like if she leaves work, and stops at the store and then goes to leave) everything works as it should. It's garage kept, and never happens when she leaves in the morning. It's only ever happened after being parked outside on wet/rainy days. The cluster was replaced a little over a year ago (before we bought it). That didn't remedy the problem. Anyone have any suggestions or ideas? Intermittent electrical issues suck.
__________________

__________________
Tony-04 Limited HO, DkKhaki w/tan leather int. All LED lighting, 5000k Xtreme HID projs. (deambered)&fogs w/CCFL rings, tinted tails&3rd LED brake lt, fnt glass tinted to match, shawty antenna, 6 Polk speakers, K&N FIPK, FR 70mm TB, TCM#10 snip, Flashpaq'ed on 91 tune, Bilstien HD's, Addcos, polished 20" SRT reps, Hankook Ventus Evos (255-45), Weathertech mats, EBC USR rotors, EBC Greenstuff pads, Magnaflow muffler, RB1 Nav w/iPod kit, de-badged, roof rack delete.
09 Liberty KK Rocky Mountain Edition. Added Mopar Remote Start kit, Weathertech Mats, K&N drop-in.
PAST JEEPS : 99 TJ Sport, 98 XJ Sport, 06 WK Laredo
Reply With Quote
  #2  
Old 01-28-2013, 10:18 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652912
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Intermittent Gauge Cluster!!!

Honestly and this is a TOTAL shot in the dark, it kinda seems like a relay concern, considering it will work after restarting the car, I personally have seen more relays fail this way where it engages and closes the contacts but doesnt have a good connection, the engagement it gets a better contact and works. Next time it does it hop out and pop the hood and bang on the TIPM under the hood where there is at least one run start relay that feeds power to the cluster. I am not certain but this/these relays may be internal to the TIPM and require a new TIPM to repair.

I have seen numerous weird things caused by the TIPM's in these things. Not that I have seen this, I am just saying.
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 01-28-2013, 10:27 PM
TJXJWJ's Avatar
The "pre" SRT 8
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jun 2010
Location: Aurora, OH
Posts: 3,435
Thanks: 195
Thanked 72 Times in 61 Posts
Rep Power: 286733
TJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond repute
Garage
Re: Intermittent Gauge Cluster!!!

I'll try that next time it happens and I'm around...I know she's not getting out and doing it. Whatever the result, I'll report back. Thanks dude!
__________________
Tony-04 Limited HO, DkKhaki w/tan leather int. All LED lighting, 5000k Xtreme HID projs. (deambered)&fogs w/CCFL rings, tinted tails&3rd LED brake lt, fnt glass tinted to match, shawty antenna, 6 Polk speakers, K&N FIPK, FR 70mm TB, TCM#10 snip, Flashpaq'ed on 91 tune, Bilstien HD's, Addcos, polished 20" SRT reps, Hankook Ventus Evos (255-45), Weathertech mats, EBC USR rotors, EBC Greenstuff pads, Magnaflow muffler, RB1 Nav w/iPod kit, de-badged, roof rack delete.
09 Liberty KK Rocky Mountain Edition. Added Mopar Remote Start kit, Weathertech Mats, K&N drop-in.
PAST JEEPS : 99 TJ Sport, 98 XJ Sport, 06 WK Laredo
Reply With Quote
  #4  
Old 01-30-2013, 08:31 AM
TJXJWJ's Avatar
The "pre" SRT 8
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jun 2010
Location: Aurora, OH
Posts: 3,435
Thanks: 195
Thanked 72 Times in 61 Posts
Rep Power: 286733
TJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond repute
Garage
Re: Intermittent Gauge Cluster!!!

Well, I tried it this morning...she rolled into work and none of the digital items in the cluster were working. Turn signal indicators, headlamp/fog lamp indicators not working either. The lights actually work, but the indicator in the cluster didn't illuminate. No exterior temp, no odometer, no idiot lights. I tapped on everything, opened up the lid and tapped on every relay and fuse with the handle of a screwdriver and at no point did we get anything.

This morning she left the house (garaged) and it was working. 2 miles up the road in rainy, warm conditions, it stopped and everything disappeared and remained that way for the rest of her drive in to work. Again, the vehicle drives and acts completely normal...it's just those items that stop working for whatever reason. Any other suggestions?
__________________
Tony-04 Limited HO, DkKhaki w/tan leather int. All LED lighting, 5000k Xtreme HID projs. (deambered)&fogs w/CCFL rings, tinted tails&3rd LED brake lt, fnt glass tinted to match, shawty antenna, 6 Polk speakers, K&N FIPK, FR 70mm TB, TCM#10 snip, Flashpaq'ed on 91 tune, Bilstien HD's, Addcos, polished 20" SRT reps, Hankook Ventus Evos (255-45), Weathertech mats, EBC USR rotors, EBC Greenstuff pads, Magnaflow muffler, RB1 Nav w/iPod kit, de-badged, roof rack delete.
09 Liberty KK Rocky Mountain Edition. Added Mopar Remote Start kit, Weathertech Mats, K&N drop-in.
PAST JEEPS : 99 TJ Sport, 98 XJ Sport, 06 WK Laredo
Reply With Quote
  #5  
Old 01-30-2013, 09:10 AM
Hacksaw's Avatar
Member
 
Join Date: Dec 2012
Posts: 674
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1896
Hacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond repute
Isn't there a similar issue with WK's and the resolution is the multifunction stalk ? I also thought I read something about the ignition switch (not cylinder) causing similar issues.

Think Outside !- No Box Required.
__________________
Reply With Quote
  #6  
Old 01-30-2013, 11:11 AM
TJXJWJ's Avatar
The "pre" SRT 8
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jun 2010
Location: Aurora, OH
Posts: 3,435
Thanks: 195
Thanked 72 Times in 61 Posts
Rep Power: 286733
TJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond repute
Garage
Re: Intermittent Gauge Cluster!!!

I've heard of ignition switches throwing CEL's, but not shutting down the cluster. Everything but the gauges die. It's wierd. I could see if the whole cluster would fail, but it doesn't.
__________________

__________________
Tony-04 Limited HO, DkKhaki w/tan leather int. All LED lighting, 5000k Xtreme HID projs. (deambered)&fogs w/CCFL rings, tinted tails&3rd LED brake lt, fnt glass tinted to match, shawty antenna, 6 Polk speakers, K&N FIPK, FR 70mm TB, TCM#10 snip, Flashpaq'ed on 91 tune, Bilstien HD's, Addcos, polished 20" SRT reps, Hankook Ventus Evos (255-45), Weathertech mats, EBC USR rotors, EBC Greenstuff pads, Magnaflow muffler, RB1 Nav w/iPod kit, de-badged, roof rack delete.
09 Liberty KK Rocky Mountain Edition. Added Mopar Remote Start kit, Weathertech Mats, K&N drop-in.
PAST JEEPS : 99 TJ Sport, 98 XJ Sport, 06 WK Laredo
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gauge Cluster Stopped Working Chas Troubleshooting/Problems 9 12-20-2012 12:28 PM
99 WJ Gauge Cluster idea... bsmith0612 Interior/Exterior/Visual 3 06-19-2012 08:37 PM
Gauge cluster upgrade Gus9890 Interior/Exterior/Visual 61 04-21-2012 11:25 PM
srt8 cluster gauge copley2596 Grand Cherokee - WK 15 08-18-2009 04:51 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community