Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-16-2010, 08:23 AM
Senior Member
 
Join Date: Jul 2009
Location: Scotland, UK
Posts: 1,878
Thanks: 20
Thanked 15 Times in 15 Posts
Rep Power: 79800
Martyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond repute
Is it my callipers or something else??

Hey all,


So I've been having braking issues since I got my rotors and pads changed last year.

I got new new rotors and pads (from EBC, solid rotors all round) as the previous ones were warped so I thought that might be the problem.

Only now its actually worse! Now it seems permanently stuck (only slightly at first then fully when hot) and I need this problem fixed as I don't want to destroy my tranny...

So far; its got new Flexi-pipes to the front, new brake pipe going to the back (as it was corroded) and have had the callipers stripped and cleaned, oh and a brake fluid change.

I spent about 1000 notes on brake parts so far and now my new front rotors are f***'d again due to the seizing issue.

So I'm thinking its the callipers that are the problem and if I buy the new Akebono upgraded callipers, pads and rotors it should be fine.

Only I want some advice from you guys to see if my thinking is right - or if I should try or check something else first.

I just don't want to throw even more money away and still have the problem..

The shop reckons its the callipers but they also got me buying loads of new bits that didn't fix it either which is why I'm sceptical...


Thanks in advance...
__________________

__________________
Marty

"Even though I walk through the valley of the shadow of rice, I will fear no turbo for thou torque art with me. Thy rods and crankshaft, they comfort me."
Reply With Quote
  #2  
Old 05-16-2010, 08:53 AM
StoneCold's Avatar
Premium Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,204
Thanks: 8
Thanked 27 Times in 26 Posts
Rep Power: 153292
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: Is it my callipers or something else??

I've just done my brakes today Marty and it's as easy as heck. Who fitted the pads and rotors? Did they lube the slide pins? Is it just one side or both? You should be experiencing a drop in consumption too.

Check your fluid. Is there any chance moisture has gotten in there? If so that can cause the internal bits to rust and therefore seize. Has it turned brown or black in colour?

I've taken some pics that I'll post later on. You should be able to at least rule out the basics yourself. Honestly mate it's easy when you know how. Trust me if I can, you can.

I saw this done on a Land Cruiser in Iraq (f***ing brakes seized just outside Tikrit!! luckily it was 2am) Try taking the pads off, then move the pistons back into the calipers, if they are seized, press the brake pedal gently to push the pistons out just a touch spray the pistons with brake cleaner give them a quick rub and that might sort it.

But seriously 1000 and nothing solved, they are taking the p***. You'd be aswell doing the full akebono upgrade now.
__________________

__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #3  
Old 05-16-2010, 10:51 AM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,314
Thanks: 43
Thanked 126 Times in 108 Posts
Rep Power: 542374
robpp has disabled reputation
Re: Is it my callipers or something else??

you may consider a rebuild of the calipers and new hardware. or get a USED set of akebono and rebuild those. its rather simple and not many parts. couple seals new pistons, new slide pins some grease viola.....
__________________
Reply With Quote
  #4  
Old 05-16-2010, 11:04 AM
Unholyskorn86's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Sep 2009
Location: Bristol, CT
Posts: 565
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2229
Unholyskorn86 is on a distinguished road
Send a message via AIM to Unholyskorn86
Re: Is it my callipers or something else??

Did you bleed the lines right? Maybe something is wrong with the lines for the brake fluid? Is it only one side? (one caliper?) maybe fluid isnt getting there because of air and its overheating? Long shot, just throwing stuff out there easy test, bleed the lines again.
__________________
WANT TO MAKE MONEY? http://tinyurl.com/lolbusup
Then PM me for more info!
Reply With Quote
  #5  
Old 05-16-2010, 11:30 AM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,314
Thanks: 43
Thanked 126 Times in 108 Posts
Rep Power: 542374
robpp has disabled reputation
Re: Is it my callipers or something else??

^^^^^ or even a brake hose could be bad, the rubber inside casuing the issue????
__________________
Reply With Quote
  #6  
Old 05-16-2010, 12:00 PM
Senior Member
 
Join Date: Jul 2009
Location: Scotland, UK
Posts: 1,878
Thanks: 20
Thanked 15 Times in 15 Posts
Rep Power: 79800
Martyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond repute
Re: Is it my callipers or something else??

Thanks for the info guys...

Aaron; checked the brake fluid and its a brownish color. That sound right? Topped up to max (maybe more actually) and doesn't look like there is any water in there... It's probably 7 months old now, if they did actually change it... If not, who knows...

Rob; yeah, I'll be doing the Akebono upgrade this time. I found a good deal on new ones with Mopar rotors and pads so I'll go for them. Buying used its half the price but the time I get the rotors and pads it'd work out more expensive...

The shop definitely changed the two front brake hoses so I can rule that one out too.

Unholyskorn; It was done at a shop so I'd assume so. I don't want to mess around with brakes myself. It started out as one calliper, although now 3 seem to be affected - both fronts and one rear...


The problem seems to happen when you get some heat in the brakes, I just moved the Jeep forward to wash it and they were all free and worked normally.
__________________
Marty

"Even though I walk through the valley of the shadow of rice, I will fear no turbo for thou torque art with me. Thy rods and crankshaft, they comfort me."
Reply With Quote
  #7  
Old 05-16-2010, 12:21 PM
StoneCold's Avatar
Premium Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,204
Thanks: 8
Thanked 27 Times in 26 Posts
Rep Power: 153292
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: Is it my callipers or something else??

If it's brown, it's could well be rust thats got it's way in, which means it's more than likely the slide pins weren't lubed. If black you're f***ed and everything needs replaced.

Bit of a guess here, but if the fluid is overfilled there may not be enough pressure for the pistons to operate. Syphon a small amount out with a syringe and give it a try.

If it was me and my rotors had gone again, i'd def get the akebono calipers while you're at it
__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #8  
Old 05-16-2010, 01:41 PM
Senior Member
 
Join Date: Jul 2009
Location: Scotland, UK
Posts: 1,878
Thanks: 20
Thanked 15 Times in 15 Posts
Rep Power: 79800
Martyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond repute
Re: Is it my callipers or something else??

Hmm.. Rust in the fluid doesn't sound good.

Hopefully it is just coming from the callipers. I did read somewhere that if the fluid was black its a complete rebuild/overhaul of the system which I think would be trade-in time!

I'll give the shop that has the Akebono callipers for sale a call tomorrow and see if they have any words of wisdom for me before I buy them.

To be honest, I'm not sure if the fluid was changed or just topped-up now... The bill for the fluid was just 4 quid which is pretty cheap?

I'll make sure it does get changed/flushed out this time round!

EDIT: I'll try removing some fluid tonight and see how it goes.
__________________
Marty

"Even though I walk through the valley of the shadow of rice, I will fear no turbo for thou torque art with me. Thy rods and crankshaft, they comfort me."
Reply With Quote
  #9  
Old 05-16-2010, 02:03 PM
Unholyskorn86's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Sep 2009
Location: Bristol, CT
Posts: 565
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2229
Unholyskorn86 is on a distinguished road
Send a message via AIM to Unholyskorn86
Re: Is it my callipers or something else??

Rust doesn't sound good at all. How it went from one tire to 3 or whatever tires. Also, I would just as a fix all completely drain ALL brake fluid before doing the caliper upgrade etc...maybe flush all that rust out? I dunno just doesn't sound right...
__________________
WANT TO MAKE MONEY? http://tinyurl.com/lolbusup
Then PM me for more info!
Reply With Quote
  #10  
Old 05-16-2010, 02:43 PM
Senior Member
 
Join Date: Jul 2009
Location: Scotland, UK
Posts: 1,878
Thanks: 20
Thanked 15 Times in 15 Posts
Rep Power: 79800
Martyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond repute
Re: Is it my callipers or something else??

Yeah, rust in the lines really doesn't sound good - if that is what's causing the browning... Just back from removing some fluid and it smells burnt???

Maybe that's why it is brown? Done a little more Googlin' and it could be the cause of the brown color.

I'm gonna make sure all the fluid gets flushed before the new stuff gets fitted without question.

Thanks for the info so far guys!
__________________
Marty

"Even though I walk through the valley of the shadow of rice, I will fear no turbo for thou torque art with me. Thy rods and crankshaft, they comfort me."
Reply With Quote
  #11  
Old 05-16-2010, 03:40 PM
StoneCold's Avatar
Premium Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,204
Thanks: 8
Thanked 27 Times in 26 Posts
Rep Power: 153292
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: Is it my callipers or something else??

If there's rust in their, there's either moisture in the lines somewhere or the slide pins weren't lubed properly. No lube, rust builds up and feeds itself into the fluid. Black is the worst because that means the seals etc have disintegrated and yes it's a total rebuild.

Strange how you only got charged four quid for fluid though, that must have been a top up. Burnt smelling fluid I'm sure is a sign your seals are on there way out. I'd get another shop to do the upgrade for you, or if you're up my way anytime soon, I'll do it for you.

Sounds weird that they've stripped the calipers and still no joy. I'm just not convinced they've done it right.

You're best upgrading, we're all gonna have to do it at some stage, I just don't have the spare cash at the moment for them, hence I've not bothered. But I will be doing it.
__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #12  
Old 05-17-2010, 12:02 PM
Senior Member
 
Join Date: Jul 2009
Location: Scotland, UK
Posts: 1,878
Thanks: 20
Thanked 15 Times in 15 Posts
Rep Power: 79800
Martyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond repute
Re: Is it my callipers or something else??

Aaron thanks for all the help/info man!

Four quid for fluid as you say doesn't sound right and IIRC it was brownish before it went it - one benefit of having a gleaming engine bay, you can see in the bottles!

So, I called the supplier of the new Akebono callipers and got a price on a new one for the rear to as I reckon that's on its way out too - signs of excess heat on rotor...

Spoke to the tech guy there on the phone and he basically said that he's heard loads of reports of the Teeves (sp?) callipers sticking on the 99-02 WJs and that the Akebono upgrade is a no-brainer for me. I told him about the fluid and the burnt smell and as you said he reckoned the seals are worn and that's what is causing the fluid to look/smell like it is.

He also offered a repair kit for the rear at 40 quid but the time you add labour into it the new calliper isn't all that bad a deal at 79.

So my plan is to try and get booked in to the same place my Dad gets his car serviced (Merc indie) and get him to do the work. I don't trust the other shop anymore...

I'll get him to do a; brake fluid flush with the old callipers > fit the 3 new callipers > re-flush (if req, I don't know) > bleed the brakes and that should be me sorted! I'd guess 2 hours labour should be fine for that and I'll be a happy guy!!


Thanks for the offer BTW, but my brakes would be a molten mess by the time I got up to you - transmission wouldn't like me either. Current MPG is now 9.4!
__________________

__________________
Marty

"Even though I walk through the valley of the shadow of rice, I will fear no turbo for thou torque art with me. Thy rods and crankshaft, they comfort me."
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community