Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-07-2012, 12:46 AM
Member
My Jeep: 2010
 
Join Date: Jan 2012
Location: Philly subs
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1020
Chrissrt10 is on a distinguished road
Jeep revving and giving ' whip lash'

Anyone know why my 98 5.9 is revving and yanking back and fourth when giving it gas? I think it might be the tranny. Also don't know if this has anything to do with the same problem but I gotta wiggle my reverse so the lights reverse lights come on.
__________________

__________________
Reply With Quote
  #2  
Old 01-09-2012, 02:47 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652974
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Jeep revving and giving ' whip lash'

Its hard to tell by the description but sounds like a failure in the trans could be a possibility.
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 01-09-2012, 03:19 PM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113239
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: Jeep revving and giving ' whip lash'

We need a better description of your problems.
Does it drive fine under low/mid/high acceleration?
Rev lights are probably a pin switch or corroded connection.
When was the last time you changed/checked your spark plugs?
How is the trans fluid? Full/low/burnt/brownish/red/perfect?
When was the last full/complete tuneup?

With the yanking back and forth I'd be leaning towards an engine mis....sparkplugs/wires/ect!
A trans "should" just slip unless it's an engagement/fluid issue.
I'd also check on your crank shaft position sensor if it dies and comes back to life causing the jerking problem.
__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #4  
Old 02-02-2012, 12:30 PM
Member
My Jeep: 1997 4.0L ZJ
 
Join Date: Jan 2012
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1072
1ABrian is on a distinguished road
Re: Jeep revving and giving ' whip lash'

Hey Chrissrt10, what was the outcomer with this? You get a chance to check out what Escape mentioned? I would agree with Escape, I would lean toward ignition related
__________________
Brian
Reply With Quote
  #5  
Old 02-03-2012, 12:13 AM
Member
My Jeep: 2010
 
Join Date: Jan 2012
Location: Philly subs
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1020
Chrissrt10 is on a distinguished road
Re: Jeep revving and giving ' whip lash'

A little late but thanks escape for taking the time and info. I havnt had a chance to take my 5niner to the mechanic yet but will tell him what you said to check out. 1ABrian, I plan on taking her to the mechanic some point next week. I am leaning to the tranmissiob though. It has 117,000 miles on it so might be time to buy a new tranny.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated pics of the whip. WSR Showoff 13 09-29-2011 10:47 AM
Safety whip/flag StephenE Troubleshooting/Problems 0 05-24-2011 01:55 PM
Cracked lash adjuster bore curiousguy09 Troubleshooting/Problems 3 04-14-2011 08:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community