Mysterious jeep problem - need help - - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-05-2014, 11:16 AM
Member
 
Join Date: Nov 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
Bmoore23 is on a distinguished road
Mysterious jeep problem - need help -

Ok so let me start out by saying that I am not mechanically inclined; but I can follow directions well. I have on my hands a 2004 4.7 JGC that has been making me slam my head into the wall with the random issues it has.
First: would not start - had starter replaced and was fine for a month.
Second: again would not start, replaced starter relay and all relevant fuses.
Third: it worked for about three days and then would not start again, replaced relay again ( I was in front of autozone when it died) started just fine.
Fourth: brought it home the next day, (yesterday) now it will not stay running unless you give it gas.

Fuel pump was replaced two years ago, I'm checking the fuel filter tonight.

The wiring in the door is intact, I checked that as we'll, I cannot see any breaks. I've cleaned battery and cables, check all grounds I can see.

What else could it be?

Thanks in advance!

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-05-2014, 12:56 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,118
Thanks: 74
Thanked 297 Times in 261 Posts
Rep Power: 46571
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Mysterious jeep problem - need help -

Define will not start:

When you hit the starter, does it turn over at reasonable speed, or just make a click, or nothing.

For this, it could begin at the ignition switch, transmission interlock, bad grounds, crudded up cables, bad alternator, etc. Cheap RatShack voltmeter advised, with a wiring diagram really valuable.

If it turns over, does it fire at all, or no signs of change in motor sound.
If no fire, something wrong with the cps, or fuel.

If it starts, does it stop right away?
There's a cutout for fuel pressure if it does not stay high enough, it presumes theres a leak. From there, you progress to pretty much any number of things involving the ability to create spark, get fuel into cylinders, ignite it at the correct time, proper mix, and occasionally a really badly plugged cat.
Reply With Quote
  #3  
Old 11-05-2014, 01:03 PM
Member
 
Join Date: Nov 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
Bmoore23 is on a distinguished road
Re: Mysterious jeep problem - need help -

It will turn over but if you do not immediately hit the gas it will die.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 11-06-2014, 03:01 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,613
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529932
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Mysterious jeep problem - need help -

Did you check for any fault codes set using the keydance? Ignition switch off/run three times and leave in run at the third time. Odometer will show 'DONE" when no faults, or a fault code(s).
If no fault code present, i would start cleaning the IAC stepper motor plunjer and air canal. If after that it still does not want to idle, then remove the alternator thick wire and isolate it with isolating tape (just to prevent any short) and test again. If it then runs fine, your alternator needs to be replaced.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 11-06-2014, 04:00 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2013
Location: NSW Australia
Posts: 1,473
Thanks: 276
Thanked 290 Times in 222 Posts
Rep Power: 19630
SJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond repute
Re: Mysterious jeep problem - need help -

This will most probably not be your problem but I'll tell you anyway because it had us scratching our heads for quite a while as well.

WK 2005 (Aust compliance 2007 hence my sig) but post July 2005 build.

Damn thing would not start on occasion, usually after sitting in the sun. Would start no issue first thing in the morning but after sitting for a while and in the afternoon wouldn't start. Would attempt to turn over but no go. Give it a nudge for a few minutes and it would start but it just got worse and worse.

Drove us mad and my husband refused to take it to the dealership saying he would figure it out. (It was out of warranty by this stage)

Well, eventually he did after getting the **irks** (insert expletive) one day when he had to drive it somewhere and whilst it attempted to turn over it wouldn't start.

It turned out to be the location of the Mopar Bluetooth module that had been fitted by the dealership in such a way that it restricted the ability turn the key fully. You could turn the key and it would feel fine but it was a tiny bit short of actually kicking in. Most times it would work but when the sun got on to it, for some reason it just exacerbated the issue.

He pulled the cover off (above your knee near the ignition switch) and simply relocated the module to the right hand side of the compartment (that would be your left hand side given that we are opposite downunder) and we have never ever had the issue since. That would be about 4 years ago now.

Such a simple bloody thing and took about 3 minutes to fix.

But, like I said, probably not your issue but thought I'd share a mysterious problem as well when all was ok with starters and wiring etc.
__________________
'07 WK Limited 5.7 Hemi (Sold)
'14 WK2 Overland CRD - ORAII
'15 KL Limited CRD - ADII, Tech Group, Electronics Group and Pano.
Reply With Quote
  #6  
Old 11-06-2014, 07:02 AM
Member
 
Join Date: Nov 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
Bmoore23 is on a distinguished road
Re: Mysterious jeep problem - need help -

I was up until 2am last night. I decided to just give it a basic tuneup, as well as change the fuel filter. & the TSP & IAC. I figured, can't hurt even If it doesn't fix my problem. I'm picking up the tsp and iac this morning since those are plug and play.


Sent from my iPhone using JeepGarage
Reply With Quote
  #7  
Old 11-06-2014, 07:02 AM
Member
 
Join Date: Nov 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
Bmoore23 is on a distinguished road
Re: Mysterious jeep problem - need help -

Oh, and no fault codes period


Sent from my iPhone using JeepGarage
Reply With Quote
  #8  
Old 11-06-2014, 07:49 AM
Member
 
Join Date: Nov 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 970
Bmoore23 is on a distinguished road
Re: Mysterious jeep problem - need help -

*TPS


Sent from my iPhone using JeepGarage
Reply With Quote
  #9  
Old 11-07-2014, 04:43 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,613
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529932
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Mysterious jeep problem - need help -

Donīt forget to clean the IAC air canal in the throttle body as well, a lot of dirt will collect there and can reduce the opening.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #10  
Old 02-27-2015, 04:26 PM
New Member
 
Join Date: Feb 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mrpenu76 is on a distinguished road
Re: Mysterious jeep problem - need help -

Ok so I'm having a issue with my 98 grand Cherokee Laredo... It starts fine then at times it wont.. Like I turn the key and it it turns over but doesn't start.. I had a autostart alarm on it and thought it was the problem so I had it removed.. But the same thing is still happening. Can someone help me please???
Reply With Quote
  #11  
Old 02-27-2015, 05:17 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,613
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529932
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Mysterious jeep problem - need help -

Quote:
Originally Posted by mrpenu76 View Post
Ok so I'm having a issue with my 98 grand Cherokee Laredo... It starts fine then at times it wont.. Like I turn the key and it it turns over but doesn't start.. I had a autostart alarm on it and thought it was the problem so I had it removed.. But the same thing is still happening. Can someone help me please???
No fault codes stored? Could be the crank sensor, but without fault code it is a shot in the dark.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #12  
Old 02-27-2015, 05:20 PM
New Member
 
Join Date: Feb 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mrpenu76 is on a distinguished road
Re: Mysterious jeep problem - need help -

No codes but thanks.. I was just seeing what all it could be wrong with it you guys have told me things I didn't even know were on there thanks again
Reply With Quote
Reply

Tags
jeep

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mysterious Antifreeze Leak mjonesjr Troubleshooting/Problems 7 02-15-2013 08:49 PM
light/dimmer switch problem. need help asap! DavidESchiller Grand Cherokee - ZJ 5 03-25-2012 10:53 PM
Mysterious noise Cordishead Troubleshooting/Problems Discussion 3 12-23-2010 08:01 AM
big problem need help cutt288 Troubleshooting/Problems Discussion 7 11-30-2010 08:01 PM
P0443 Problem, need some help akabigo Troubleshooting/Problems Discussion 10 10-20-2010 08:14 AM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.