Newbie with a problem - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-14-2015, 10:07 AM
New Member
 
Join Date: Dec 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
DaBigWolf is on a distinguished road
Newbie with a problem

Hey guys, newbie here I recently acquired an 07 JKU with about 109K on the odometer. The jeep is a solid soft top with half doors in the X trim. Love it so for… But from a couple of days I notice that when I turn the key to start the engine there’s a delay with the starter to crank (is this normal???) and a couple of nights ago, and this morning, it didn’t crank at all and you could hear the typical CLICK, like when a battery is without power… but the headlights and horn and wipers the radio were working fine.. Any thoughts as what might be causing this?

Thanks for your assistance and advice,

F. R. (DaBigWolf)

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-14-2015, 02:14 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,615
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529935
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Newbie with a problem

Welcome to the garage.
Sounds as a starter solenoid problem, but could eventually be a high resistance in the connections of the power wire or the ground wire. Look if the wire connections are clean (no corrosion) and fastened well. Also the thinner wire on the starter solenoid should be checked, because caused problems to others already.
I presume that the click which you heard was coming from the starter relay under the hood. This relay can go bad as well. You can eventually swap it with an other relay in the relay box.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recent flash problems, oil problem, dpf problem now jp6544 Grand Cherokee - WK2 - 5 06-25-2015 04:46 PM
UK NEWBIE with a problem!! petethejeep Liberty-KJ and KK 1 09-09-2014 08:12 AM
OBD diag problem or car problem?? jeeper_57 Troubleshooting/Problems 0 06-25-2013 11:24 AM
Heater problem!!! (Hello from the Newbie) rensaun Troubleshooting/Problems 8 02-01-2013 07:57 PM
Newbie here Puppetmaster_sr New Members - Welcome! 26 10-16-2012 05:35 AM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:47 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.