No power for radio hvac or vic - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-03-2014, 11:09 AM
New Member
My Jeep: 1997 5.2L ZJ
 
Join Date: Sep 2014
Location: South Florida
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
islandliving is on a distinguished road
1997 Jeep Grand Cherokee limited
I do not have power for my radio, a/c controls, or vic. I changed 3 fuses: radio, rad illum, and radio hvac. Still no power. What is next?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-08-2014, 11:31 PM
champagneinhand's Avatar
Member
My Jeep: 2016 3.2L KL
 
Join Date: Dec 2013
Location: Upstate Western NY State
Posts: 233
Thanks: 29
Thanked 18 Times in 17 Posts
Rep Power: 1376
champagneinhand is on a distinguished road
Garage
Re: No power for radio hvac or vic

Sounds like an entire module might have gone. Pricy. Good luck. Electrical problems are a nightmare. There are good heads on the forum that may have some solutions. Hopefully you won't have to spend hours tearing apart the dash consult with a voltmeter searching for a wire short. GL!
Reply With Quote
  #3  
Old 11-09-2014, 07:56 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529483
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: No power for radio hvac or vic

Most probably a wire break or bad contact somewhere. Check first if there is voltage at the fuse. If there is, then check if there is voltage at the respective components that do not work. You will need a wiring diagram to know where the voltage should be.
If the voltage is ok, then you will need to measure the resistance for the ground wire. A bad ground (due to corrosion or a loose ground stud) could be your problem. A good ground wire should give less then 1 ohm.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 11-09-2014, 06:31 PM
New Member
My Jeep: 1997 5.2L ZJ
 
Join Date: Sep 2014
Location: South Florida
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
islandliving is on a distinguished road
Thanks for all the input. I got a volt meter and narrowed the problem down to the fuse box. I don't know why I did this but I changed the fuse again , still no power, so I tried another fuse, still no power. Now I only have one fuse left so I tried it and tada I got power. These fuses were brand new. Anyone ever hear of new fuses being faulty?
Anyway I am just happy everything is working again
Reply With Quote
  #5  
Old 11-09-2014, 07:18 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529483
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: No power for radio hvac or vic

Besides the fuses, it can also be a bad contact in the fuse holder. Did you measure each fuse for continuity with the multimeter in ohms position?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 11-09-2014, 07:58 PM
New Member
My Jeep: 1997 5.2L ZJ
 
Join Date: Sep 2014
Location: South Florida
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
islandliving is on a distinguished road
Re: No power for radio hvac or vic

No I did not, but I will try that. Thanks. What if you are right? What is the solution?
Reply With Quote
  #7  
Old 11-10-2014, 06:30 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529483
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: No power for radio hvac or vic

Where all the fuses of the same amperage? A too low amperage fuse could melt imediately when the power was switched on. An other possibility is that there is a short somewhere, melting the fuse when inserted. Or you just had bad luck with the fuses you bought.
There could eventually be something wrong with the fuse holder itself; a loose connection inside the junction block or the blades, which should make the electrical contact with the fuse, too wide open.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't control HVAC - Looking for part number for HVAC Circuit Control Board GoldenBear03 Trouble Shooting/Problems/Service 8 05-03-2014 11:51 AM
New Member VIC - new to Jeep, hopefully 2014 CRD dunkit New Members - Welcome! 4 06-27-2013 09:19 AM
new vic roads rules for mods sparky60 Export Grand Cherokee 2011+ 3 12-20-2012 01:28 AM
WK2 Meet BBQ in Vic - late Nov/Early Dec scarps Export Grand Cherokee 2011+ 8 10-03-2012 08:19 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:55 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.