Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-30-2014, 09:23 AM
New Member
 
Join Date: Mar 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
DalyJim is on a distinguished road
No Spark on yls 2 & 4

My daughter has a 2006 Jeep Liberty Sport with 110,000 miles on it.
Last month she overheated the jeep, radiator split open. We got it back home and I replaced the radiator, as well as the water pump and the thermostat. It overheated for a reason, so I was taking out the possible simple problems. But was not running right, brought it to the mechanic and he said cyls 2 & 4 not working and found antifreeze in the cyls, head gasket! Well, instead of the 3500 head job, we opted for the quick fix, Blue Devil gasket repair. That seemed to fix the problem as far as the missing antifreeze, but the codes keep coming back for 2 & 4. I brought it home and did the old school plug test, and no spark. Bought 2 new coils, same thing, put the coil on #1 lead, and it fired the plug. So no trigger to coils 2 & 4 to fire. Any ideas?
__________________

__________________
Reply With Quote
  #2  
Old 03-30-2014, 11:46 AM
sanjuro77's Avatar
Member
My Jeep: 1996 4.0L ZJ
 
Join Date: Dec 2013
Location: NE Ohio
Posts: 221
Thanks: 3
Thanked 18 Times in 16 Posts
Rep Power: 765
sanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond repute
Out of curiosity, did you replace the plug wires or test them?
Overheating can totally kill those cables.
__________________

__________________
Reply With Quote
  #3  
Old 03-30-2014, 11:52 AM
New Member
 
Join Date: Mar 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
DalyJim is on a distinguished road
Re: No Spark on yls 2 & 4

Quote:
Originally Posted by sanjuro77 View Post
Out of curiosity, did you replace the plug wires or test them?
Overheating can totally kill those cables.
No "Plug" wires - individual coils - trying to trace the leads from the coil plugs back through the harness to the other point of contact to check there is nothing wrong with them in the harness, but no idea where they go back to yet.
__________________
Reply With Quote
  #4  
Old 03-31-2014, 08:23 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,291
Thanks: 9
Thanked 127 Times in 120 Posts
Rep Power: 526335
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: No Spark on yls 2 & 4

Quote:
Originally Posted by DalyJim View Post
No "Plug" wires - individual coils - trying to trace the leads from the coil plugs back through the harness to the other point of contact to check there is nothing wrong with them in the harness, but no idea where they go back to yet.
Eventhough im not familiar with the engine in the liberty, normally 12 V positive is coming from the auto shutdown relay and the ground wire goes to the PCM (powertrain control module). The PCM will ground each wire for the coil to produce the spark. So i would get a wiring diagram and start measuring the wires first, maybe there is a wire break in the 12 V + for coils 2 and 4, or a short in the ground wires for 2 and 4,
Did you also check if there is any fault code set? Dont know if the keydance works on a liberty: ignition switch off/run three times and leave in run at the third time. The odometer will show "DONE" when no faults stored, or any fault code(s).
Also did you change the plugs for cylinder 2 and 4?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ukraine gets Overland w paint matched mirrors&handles, &black rearstep & tail surrond jgc4ever Grand Cherokee - WK2 - 32 03-23-2014 11:04 AM
How to change the spark plugs on a 4.7 V8 WK Grand Cherokee or Commander Scottina06 Technical Tips/DIY/How-To 31 03-20-2013 09:41 PM
!$^@&W%&#*#@^!@^@&% jeep !@^$@^ heywaitfourme Trouble Shooting/Problems/Service 96 03-12-2011 07:36 PM
Spark Plugs - What not to buy & do? magradze Engine Performance/Intake/Exhaust 13 04-08-2010 03:35 PM
Has Anyone Ever Used Pulstar Spark Plugs? jeeppro Performance Modifications 16 06-02-2009 08:32 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.