Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-11-2014, 02:25 PM
New Member
 
Join Date: Mar 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Bigbear1 is on a distinguished road
no start

I am working on a 2004 Jeep Grand Cherokee with a 4.7l engine. Customer states that it was running then just quit. Engine turns over fine but it acts like it is flooded. Plugs are dry other then being black like it was running rich. I have injector pulse and compression is roughly 150psi in each cylinder. No codes are present. Fuel Pressure while cranking is 52psi. Replaced cam and crank sensors.
__________________

__________________
Reply With Quote
  #2  
Old 03-11-2014, 04:08 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,776
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525699
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: no start

Welcome to the garage.
Does it give spark? Did you check for the 5v reference voltage signal which is used for the cam, crank, MAP, engine coolant, intake air temperature and TPS? See attached schematic.
Attached Files
File Type: pdf cam-crank sensor.pdf (186.1 KB, 1 views)
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 03-11-2014, 07:59 PM
New Member
 
Join Date: Mar 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Bigbear1 is on a distinguished road
Re: no start

yes they have a 5 volt reference signal and I have spark
__________________
Reply With Quote
  #4  
Old 03-11-2014, 08:00 PM
New Member
 
Join Date: Mar 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Bigbear1 is on a distinguished road
Re: no start

yes I do have a 5 volt reference and I have spark
__________________
Reply With Quote
  #5  
Old 03-11-2014, 09:24 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,776
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525699
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: no start

It is strange that you have injector pulse, but the plugs are dry. Did you check the valve timing already?
Does the tach move a bit when trying to start?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Start of My WK snow99dohc Members Rides 42 04-22-2012 03:48 AM
Remote Start Disabled - Start Vehicle to Reset?? bmrsooner10 Trouble Shooting/Problems/Service 3 01-02-2012 10:11 AM
99 4.7l No start...Please Help... SuperTuner12010 Engine Performance/Intake/Exhaust 3 05-05-2011 01:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community