Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-14-2010, 06:12 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,854
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26250
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
P0051 trouble code on 04 GC **RESOLVED**

Driving to work before my CEL came on. I got to work and I checked it and I got code P0051 showed in the odometer.
I searched the code and got this result.

A P0051 DTC (diagnostic) refers to the O2 sensor (sensor) located on Bank 2 in front of the catalytic converter. There is also an oxygen sensor behind the converter which is Sensor #2.

Do I need to rush to get this looked at? I am due for an oil change in 1100 miles, I figured I would wait until then. I am also going to clear the code out tomorrow and see if it comes back.
__________________

__________________
Reply With Quote
  #2  
Old 05-13-2010, 01:12 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,854
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26250
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: P0051 trouble code on 04 GC

got this taken care of the other day. Just an FYI, aftermarket sensor didn't work. CEL came right back. Replaced with OEM and all is good
__________________

__________________
Reply With Quote
  #3  
Old 05-13-2010, 01:21 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12413
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: P0051 trouble code on 04 GC

glad to know it's all in good condition
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #4  
Old 05-13-2010, 03:03 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,421
Thanks: 877
Thanked 1,054 Times in 728 Posts
Rep Power: 7718345
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: P0051 trouble code on 04 GC

always get the oem's....for some reason the aftermarkets have problems
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #5  
Old 05-13-2010, 03:25 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,854
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26250
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: P0051 trouble code on 04 GC

the more you know LOL. And what's even better is I got the OEM one for less then the aftermarket one cost. Next step is returning the aftermarket one, after the company tried to give me a hard time not understanding why the CEL came back and why the code was the same for their new O2 sensor, vs the one that was removed from my jeep
__________________
Reply With Quote
  #6  
Old 08-01-2010, 05:36 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,854
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26250
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: P0051 trouble code on 04 GC

So I got a cel the other day. P1281. Thermostat. I replaced that a few weeks back, with non OEM, guess that was the issue. I have an OEM one on the way from Kolak. I cleared the CEL out yesterday AM, and within 10 miles it came back on. I checked it this AM it was P0051. O2 sensor Bank 2, sensor 1. I replaced that one like 3 months ago, with an OEM. I know the thermostat is still an issue as the engine temp isn't going high enough. But now I am trying to figure out why the 02 sensor needs to be replaced again. I cleared it this AM again, and when I started up this afternoon, CEL on, code P0051 again.
__________________
Reply With Quote
  #7  
Old 08-12-2010, 01:27 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,854
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26250
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: P0051 trouble code on 04 GC

well had mechanic install OEM Tstat today and that problem is solved. Engine temp is now where it needs to be. On to the 02 sensors. I was mistaken, the code I was throwing was P0031 Bank 1 Sensor 1. That is no longer the case. This AM before I started the jeep I checked the code and its P0051 Bank 2 Sensor 1. Mechanic didn't think the sensor should need to be replaced again. Each time the code was cleared out immediately up start up it came back. Mechanic started testing and came up with no resistance at the resistor. He didn't have enough time today. Said to bring it back he will need atleast half a day to test wires coming out of the ECU. He told me also to just keep driving it and maybe it will straighten itself out on it's own.
Anyone have any insight?
__________________
Reply With Quote
  #8  
Old 08-19-2010, 01:13 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,854
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26250
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: P0051 trouble code on 04 GC

anyone have any ideas about this. Perhaps the right direction for my mechanic to look in?
__________________
Reply With Quote
  #9  
Old 08-24-2010, 05:59 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,854
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26250
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: P0051 trouble code on 04 GC

dropping off at mechanic in the AM. Hopefully it will be an easy resolution. Wish me Luck.
__________________
Reply With Quote
  #10  
Old 08-25-2010, 03:00 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,854
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26250
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: P0051 trouble code on 04 GC

issue resolved
a cluster of wires that runs behind the engine along the firewall was rubbing against a bolt, as I am hearing is a common problem. Mechanic taped up the wires and tied them up away from the bolt. How nice it is to not be driving around with a CEL
__________________
Reply With Quote
  #11  
Old 08-25-2010, 03:50 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12413
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: P0051 trouble code on 04 GC

nice dude glad to know it's all good now
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #12  
Old 11-03-2010, 06:59 AM
New Member
 
Join Date: Nov 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
rableo is on a distinguished road
Re: P0051 trouble code on 04 GC

I am having the same code p0051. i replaced the o2 sensor with an after market one and the code came back. I just drove it like that for a while since I was not getting bad gas mileage or any thing and just thought it was a short. I just recently replaced the O2 sensor with a Mopar one and I am getting the same code. Anyone have any suggestions on how to find the short?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
halo wiring trouble!! 99limited Visual Modifications 6 04-04-2010 09:44 AM
P0420 trouble code Hamze Troubleshooting/Problems Discussion 5 03-29-2010 03:25 PM
Trouble Starting 99 4.7 jimd4x4 Troubleshooting/Problems 4 03-16-2010 02:03 PM
Can't get trouble code to apear on 06 cherokee?? 06CherokeeMan Grand Cherokee - WK 14 02-14-2010 08:04 AM
Diagnostic Trouble Codes Frankie Troubleshooting/Problems Discussion 12 05-30-2009 11:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.