Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-17-2009, 05:12 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,202
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4250
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
P0152

Went to leave after work today and right when I started the Jeep I immediately got the MIL. Did the key dance and got P0152 - O2 Sensor 2/1 Circuit High.

I've got the negative battery cable off it right now for about 10 minutes to try and reset everything. If it comes back, guess I'll buy a new O2 sensor.
__________________

__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #2  
Old 06-17-2009, 05:28 PM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16600
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: P0152

Sorry to hear. Good luck...
__________________

__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #3  
Old 06-17-2009, 05:54 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,202
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4250
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: P0152

Disconnecting the battery fixed it.
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #4  
Old 06-17-2009, 06:48 PM
blackpepper's Avatar
Senior Member
My Jeep: 2009 6.1L WK
 
Join Date: May 2009
Location: SF Bay Area
Posts: 6,435
Thanks: 67
Thanked 39 Times in 28 Posts
Rep Power: 13501
blackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond repute
Re: P0152

I remember you saying that you were running 93 octane on the 91 Superchips tune... if that's true, you should run 91 octane for the tune or else you'll continue to get the code.
__________________
Ryan
2009 SRT8 - loaded, corsa exhaust, afe stage ii intake, diablo intune w/ Johan toona, vreds 275/315, r1 drilled/slotted rotors, stoptech pads, lockpick adapter, billet tech catch can, 180 tstat, eibach springs, bwoody links, stage 6 qa1 shocks, tail light tint, front window tint, stillen hl brows, lloyd mats, powder-coated alcoas, red srt lettering, trim color-matched...

2007 Jeep 5.7 Limited - 120,681 miles, one owner. SOLD
Reply With Quote
  #5  
Old 06-17-2009, 07:05 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,202
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4250
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: P0152

Quote:
Originally Posted by BlackPepper View Post
I remember you saying that you were running 93 octane on the 91 Superchips tune... if that's true, you should run 91 octane for the tune or else you'll continue to get the code.
91 octane is not offered around here. it is 87/89/93.

I had been running 93 on the 91 tune for probably 2 weeks/1000ish miles before this happened - I think it would have popped up earlier if running 93 was a problem?
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #6  
Old 06-17-2009, 07:10 PM
blackpepper's Avatar
Senior Member
My Jeep: 2009 6.1L WK
 
Join Date: May 2009
Location: SF Bay Area
Posts: 6,435
Thanks: 67
Thanked 39 Times in 28 Posts
Rep Power: 13501
blackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond reputeblackpepper has a reputation beyond repute
Re: P0152

You could be running rich.. either that or your sensor took a dump.
__________________
Ryan
2009 SRT8 - loaded, corsa exhaust, afe stage ii intake, diablo intune w/ Johan toona, vreds 275/315, r1 drilled/slotted rotors, stoptech pads, lockpick adapter, billet tech catch can, 180 tstat, eibach springs, bwoody links, stage 6 qa1 shocks, tail light tint, front window tint, stillen hl brows, lloyd mats, powder-coated alcoas, red srt lettering, trim color-matched...

2007 Jeep 5.7 Limited - 120,681 miles, one owner. SOLD
Reply With Quote
  #7  
Old 06-17-2009, 07:53 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,202
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4250
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: P0152

We'll see.. the MIL went away after disconnecting the battery for a little while. The truck has been running fine.
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #8  
Old 06-17-2009, 07:57 PM
Robert Palmer's Avatar
Rock N' Roll's Sophisticate/JG Co-Founder


My Jeep: 2010 6.1L SRT8
 
Join Date: May 2009
Location: Downtown Manhattan
Posts: 10,305
Thanks: 10
Thanked 63 Times in 53 Posts
Rep Power: 112770
Robert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond repute
Re: P0152

You didn't clear the codes via SC?
__________________
-Joe-



Silver
2010 Jeep Grand Cherokee SRT-8
Reply With Quote
  #9  
Old 06-17-2009, 08:16 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,202
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4250
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: P0152

Quote:
Originally Posted by Elvis Presley View Post
You didn't clear the codes via SC?
No, I forgot all about it until I went to reconnect the battery, lol.
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #10  
Old 06-19-2009, 11:23 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,418
Thanks: 55
Thanked 133 Times in 115 Posts
Rep Power: 542669
robpp has disabled reputation
Re: P0152

manual says:
When Monitored:
O2 Sensor Heater Temperature is greater than 496° C (925° F) and battery voltage greater than 10.99 volts.

Set Condition:
The Oxygen Sensor voltage is above 3.9 volts for 30 seconds. Two Trip Fault. Three good trips to turn off the MIL.


Possible Causes

(K43) O2 2/1 SIGNAL CIRCUIT SHORTED TO BATTERY VOLTAGE

(K902) O2 RETURN UPSTREAM CIRCUIT SHORTED TO BATTERY VOLTAGE

(K43) O2 2/1 SIGNAL CIRCUIT OPEN

(K902) O2 RETURN UPSTREAM CIRCUIT OPEN

O2 SENSOR

PCM
_____________

i would make sure you didnt melt a wire down there before going to much further.
__________________
Reply With Quote
  #11  
Old 06-21-2009, 05:24 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,202
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4250
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: P0152

Quote:
Originally Posted by robpp View Post
manual says:
When Monitored:
O2 Sensor Heater Temperature is greater than 496° C (925° F) and battery voltage greater than 10.99 volts.

Set Condition:
The Oxygen Sensor voltage is above 3.9 volts for 30 seconds. Two Trip Fault. Three good trips to turn off the MIL.


Possible Causes

(K43) O2 2/1 SIGNAL CIRCUIT SHORTED TO BATTERY VOLTAGE

(K902) O2 RETURN UPSTREAM CIRCUIT SHORTED TO BATTERY VOLTAGE

(K43) O2 2/1 SIGNAL CIRCUIT OPEN

(K902) O2 RETURN UPSTREAM CIRCUIT OPEN

O2 SENSOR

PCM
_____________

i would make sure you didnt melt a wire down there before going to much further.
The code hasn't been back since I cleared it, and the truck is driving completely normal.
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #12  
Old 06-24-2009, 03:43 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,202
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4250
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: P0152

Well one week later and a trip to NC and back and the code hasn't come back. Guess it was just a one time fluke deal.
__________________

__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.