Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-09-2013, 02:50 PM
nick1146's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: May 2011
Location: Delray Beach, FL
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1567
nick1146 is on a distinguished road
Please help!! Rough idle,stall, piston mosfire

Hi guys. I have a 2007 4.7 v8 grand Cherokee that has been giving me a big issue. I hooked my jeep up to a scan tool and I get the piston misfire code. When cold my engine runs fine but once it gets hot it starts to idle really rough. Sometimes is goes down to 4-500 rpm and eventually stalls. Also I'll be randomly driving and my jeep starts to shutter very violently and I lose power and the engine light will flicker on and off and eventually stay solid.. I just got the engine replaced an I have about 5,000 on the new engine and 94000 on everything else. I know it's not the spark plugs, and I checked for a vaccume leak and it doesn't seem to have one. Also somtimes when I start my car there is a loud metal clinking sound. It's kind of hard to describe but it sounds like there's a piece of metal in the exhaust or somthing. please if anyone could help of have had this problem before please help.
__________________

Reply With Quote
  #2  
Old 04-09-2013, 03:03 PM
nick1146's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: May 2011
Location: Delray Beach, FL
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1567
nick1146 is on a distinguished road
Also the misfire doesn't happen every time I drive but it happens often. Same with the rough idle
__________________

Reply With Quote
  #3  
Old 04-10-2013, 04:19 PM
nick1146's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: May 2011
Location: Delray Beach, FL
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1567
nick1146 is on a distinguished road
Anybody? Somebody help????
Reply With Quote
  #4  
Old 04-17-2015, 02:03 PM
New Member
 
Join Date: Apr 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jon carthay is on a distinguished road
Re: Please help!! Rough idle,stall, piston mosfire

sounds like TIPM may need replacing, but not sure. Could be ignition key and switch, fuel pump, crankshaft position indicator sensor, coils on top of plugs. Very frustrating! I have similar issue on 2007. Cold start is fine. When warm sometimes it doesn't want to start...just shudders. Then finally starts & runs fine.
Reply With Quote
  #5  
Old 04-17-2015, 06:33 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 6,273
Thanks: 14
Thanked 218 Times in 210 Posts
Rep Power: 527791
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Please help!! Rough idle,stall, piston mosfire

When the engine runs fine cold, but starts to idle rough when hot, then it could be a bad O2 sensor. On a cold engine, the O2 sensor readings are not used by the PCM ( open loop mode), but as soon as the sensor is hot enough, the PCM will use the O2 readings( closed loop mode). A bad sensor could cause a too lean mixture and cause misfires due to this. You will need a scanner with live data to see if the O2 sensors (1-1 and 2-1) are fluctuating frequently between 0.2 and 0.8 V. Then you can also check the fuel trim figures, which should give single digit values. (Normalley they are around +- 5% during stable operation. When going over 10%, then there is probablly something wrong).
A blocked exhaust (loose baffle in silencer or a plugged converter) could also cause rough idle and bad acceleration.
As a third item, which many times is related to heat, is a bad crank sensor.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 04-17-2015, 07:00 PM
New Member
 
Join Date: Apr 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
zielketracy is on a distinguished road
Re: Please help!! Rough idle,stall, piston mosfire

Mine problem was in the cold winter coil went out so to cold out I took it to shop and this grease monkey checked the crank position sen first that was ok found coil shot so replace I picked it up got a block away n noticed it missing bad went back to them to make it rite they parked it in a HEATED garage in the morning it started fine they parked outside for 5hrs when I drove it away missing and the more gas the worse it got till it was at normal temp for 5 ta10 min then fine so in the spring I pulled the crnk position sen n scene GREASY FINGER PRINTS all over the scencer replaced it and its been great ever scents
Reply With Quote
  #7  
Old 07-27-2015, 09:54 PM
Member
 
Join Date: Nov 2014
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 296
krzysztof.gorka.7 is on a distinguished road
hey had same exact problem it took me two weeks to find the problem and finally it was upstream oxygen sensors. when cold its in closed loop when hot it starts to take data from oxygen sensors and when one of them is bad it will start rough idle and easybway to check get thensensors out connect multimeter use lighter to heat up the sensors and check the voltage or just go straight to stealership and buy new mopar
Reply With Quote
  #8  
Old 07-28-2015, 08:31 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 6,273
Thanks: 14
Thanked 218 Times in 210 Posts
Rep Power: 527791
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Please help!! Rough idle,stall, piston mosfire

Quote:
Originally Posted by krzysztof.gorka.7 View Post
hey had same exact problem it took me two weeks to find the problem and finally it was upstream oxygen sensors. when cold its in closed loop when hot it starts to take data from oxygen sensors and when one of them is bad it will start rough idle and easybway to check get thensensors out connect multimeter use lighter to heat up the sensors and check the voltage or just go straight to stealership and buy new mopar
You probably ment to say it right, but when engine is cold, the fuel injection is in open loop (no input used from O2 sensors), after it warms up, it goes into closed loop and will use the O2 sensors for fine trimming the fuel injector pulse.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 07-28-2015, 08:41 AM
Member
 
Join Date: Nov 2014
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 296
krzysztof.gorka.7 is on a distinguished road
yep thats what i meant sorry for the mess up lol
__________________

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
v8 - rough idle Truck11 Trouble Shooting/Problems/Service 10 02-01-2013 11:39 AM
rough idle, really bad dunnie0420 Troubleshooting/Problems 2 11-14-2012 04:44 PM
Idle Drops Below 500RPM And Feels Like Its Gonna Stall!! HELP!! dhackwichita Troubleshooting/Problems 5 03-20-2012 09:30 PM
Rough Idle, Vacuum Leak? PeterB16 Engine Performance/Intake/Exhaust 6 12-03-2011 11:22 PM
Rough idle on decline? TheAngryMinnow Grand Cherokee - WK 0 01-22-2011 10:26 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.