Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-18-2013, 07:18 AM
New Member
 
Join Date: Oct 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
tlauber is on a distinguished road
problems starting

I have a 2009 Jeep Liberty, the last two weeks the radio has not been working right. and now yesterday i had to get a jump to start the jeep cause the battery was dead. yesterday i took out the fuse in the fuse box to the radio thinking the radio was draining the battery and today i have the same problem my jeep wont start.
__________________

__________________
Reply With Quote
  #2  
Old 10-20-2013, 04:12 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,053
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526040
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: problems starting

Did you charge the battery completely after the jumpstart?
If yes, i would first let the battery tested.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problems Island Hemi Troubleshooting/Problems 1 05-07-2013 08:57 AM
Starting Problems 4.7 sandkwagers Engine Performance/Intake/Exhaust 60 03-21-2012 07:06 AM
Starting Problems!!!!!! Zetzsche248 Engine Performance/Intake/Exhaust 7 01-23-2012 04:40 PM
Starting problems vwkg Engine Performance/Intake/Exhaust 8 08-10-2011 01:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.