Quadralift runs after getting out - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-27-2014, 11:56 PM
Member
 
Join Date: May 2014
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 957
jeepin95 is on a distinguished road
Quadralift runs after getting out

Reading the manual I thought the Quadra lift on my 14 limited EcoDiesel wasn't supposed to run if the engine isn't on, however lately we have noticed it running and usually lowering the vehicle anywhere from 5 to 20 minutes after everything is off and we have been out of the vehicle having let it idle while lowering to park level. Is this normal or something I should have looked at? We hear it quite often but don't always look in time to see what it is doing but most of the times we have seen it lowering when we do catch it.

Thanks

__________________
Using Tapatalk
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-28-2014, 09:05 AM
bill_de's Avatar
Premium Member
My Jeep: 2017 5.7L WK2
 
Join Date: Sep 2012
Posts: 8,256
Thanks: 678
Thanked 928 Times in 739 Posts
Rep Power: 1804926
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Quadralift runs after getting out

You didn't read the entire manual ... but neither did anyone else.

The Quadra-Lift automatically levels the vehicle "for appearance" after being turned off.

Strange, but totally normal.


---
__________________
If you need a shoulder to cry on ...
... pull over to the side of the road!

Reply With Quote
  #3  
Old 07-28-2014, 11:24 PM
Member
 
Join Date: May 2014
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 957
jeepin95 is on a distinguished road
Re: Quadralift runs after getting out

Quote:
Originally Posted by bill_de View Post
You didn't read the entire manual ... but neither did anyone else.

The Quadra-Lift automatically levels the vehicle "for appearance" after being turned off.

Strange, but totally normal.


---
Now that you mention it that does sound familiar but you are right I didn't read the entire thing ☺ I've had it since March but just recently noticed the "appearance" adjustments.
Thanks
__________________
Using Tapatalk
Reply With Quote
  #4  
Old 08-01-2014, 02:43 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 3,952
Thanks: 72
Thanked 265 Times in 237 Posts
Rep Power: 46207
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Quadralift runs after getting out

Quote:
Originally Posted by jeepin95 View Post
Now that you mention it that does sound familiar but you are right I didn't read the entire thing ☺ I've had it since March but just recently noticed the "appearance" adjustments.
Thanks
And it will scare the bejazus out of you the first time it does it in a garage when you are working on something else near it.
brrrrrtktktk
Reply With Quote
  #5  
Old 08-01-2014, 06:06 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Location: Kerrville, TX
Posts: 619
Thanks: 59
Thanked 88 Times in 71 Posts
Rep Power: 1791
philbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond repute
Garage
Re: Quadralift runs after getting out

First time I heard it, it reminded me of a horse snickering in a barn....reminding you that its there LOL!

DRIVE ME
__________________
Phil C.
2014 GC Overland 4x4, 3.0CRD, ATG, ORAII ("Smiffy")
2015 Lance 1685 Travel Trailer "#4"
2011 Kia Optima EX-L ("MC"
2003 BMW R1150RT "Darth"
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment Yukoncole Troubleshooting/Problems 10 06-03-2014 09:34 PM
2005 wk engine runs after key turned off Benzie002 Troubleshooting/Problems 1 02-14-2014 11:46 AM
Hemituner runs 10.8 pjs1965 At The Track 7 06-07-2010 08:09 PM
** My ATCO runs today (12-12-09) ** QBNKID At The Track 10 12-14-2009 08:19 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.