Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-06-2011, 08:11 PM
theycallmeBR00KLYN's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Jun 2010
Location: New Jersey
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1670
theycallmeBR00KLYN is on a distinguished road
Rear turn signal stopped working.

My left rear turn signal has stopped working for a while now.
If I put my hazards on, they both work but when I turn on the left turn signal itself, only the front works.
I've replaces bulbs many times, checked the pig tale and it looked fine, checked the fuse box and the fuse was good (#27 15 blue).
Any ideas?
__________________

__________________
Reply With Quote
  #2  
Old 07-06-2011, 08:17 PM
DAVY27's Avatar
Premium Member
Photobucket
 
Join Date: Jun 2009
Location: City that Never Sleeps
Posts: 9,176
Thanks: 433
Thanked 162 Times in 150 Posts
Rep Power: 1660087
DAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond repute
Garage
Send a message via AIM to DAVY27
Re: Rear turn signal stopped working.

had this happen to me a while back. Im assuming you did replace the fuse?
__________________

__________________

2009 Jeep Grand Cherokee SRT Design
SRT Exterior,Magnaflow 14590 w/ SRT resonators,V2 CF Medic Hood,Injen Powerflow Intake,Flying Ryan Ported TB,Custom Painted Halo Headlights,HID lows/fogs,SRT Springs,Stillens,Gloss Black SRT Reps,Mopar Spoiler, Custom Painted Moldings with Snakeskin green GC letterings, Mopar Stripe,Tinted LED tails/rear fogs, TLS Harness,Switchbacks, Stage6 5" Tips,Custom Door Handle Leds,5% Tint,Altec Plate,HID Reverse,Mopar Front Emblem/ Rear Logo,Powerwire,Interior Leds,RGB LED cupholders,Mygig,Weathertech Mats,LXHarness Leds,Rear Cargo Light Mod,Lockpic V4,GlossBlack Vinyl Interior Pieces
Reply With Quote
  #3  
Old 07-06-2011, 08:44 PM
theycallmeBR00KLYN's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Jun 2010
Location: New Jersey
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1670
theycallmeBR00KLYN is on a distinguished road
Re: Rear turn signal stopped working.

I had my boy check the fuse for me (he has every tool that's possible) and the fuse was good.
__________________
Reply With Quote
  #4  
Old 07-08-2011, 01:15 PM
theycallmeBR00KLYN's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Jun 2010
Location: New Jersey
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1670
theycallmeBR00KLYN is on a distinguished road
Re: Rear turn signal stopped working.

Anyone??....
__________________
Reply With Quote
  #5  
Old 07-08-2011, 09:53 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,911
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525863
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Rear turn signal stopped working.

Does the WK have a combination flasher? If its the same as on the WJ, your problem is probably this. The combination flasher has separate outputs for each turn signal light and also for the hazards. Its probably mounted on the junction block, with the fuses.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
uConnect/VR Stopped Working - 430N granto3k Audio/Visual/Navigation 19 02-16-2014 11:53 PM
SRT Rear Fog Lights Hooked up and working as Parking, Brake & Turn Signals (Video) Robert Palmer Interior/Exterior/Visual 26 11-13-2011 08:03 PM
Signal lights stopped working..... Jeff_Jeske Troubleshooting/Problems 3 02-14-2011 12:23 AM
remote keyless entry have stopped working ithinkfit914 Troubleshooting/Problems 9 01-09-2011 06:38 AM
Blue Tooth stopped working NHWK05 Audio, Video, Navigation & Electronic Modifications 2 02-05-2010 06:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community