Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 09-13-2009, 01:24 AM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: Goose Creek, SC
Posts: 2,187
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 4148
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: Service 4wd on help!!!!!

Quote:
Originally Posted by jeeppro View Post
I cant get any codes thats why iam bringin it on here lol..
I had to use my superchips to pull the code through the OBD-II port. Doing the key dance shows nothing.

Bring it to an autozone or advance and tell them you got that warning message and want to check for any codes. They should do it for free then you can look up what code they give you and the FSM has troubleshooting guides for all of the codes.
__________________

__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #14  
Old 09-13-2009, 12:46 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,849
Thanks: 833
Thanked 824 Times in 635 Posts
Rep Power: 7717432
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Service 4wd on help!!!!!

Quote:
Originally Posted by jeeppro View Post
I did its says unkknown
so they pulled the OBD port and it came up as "unknown"
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #15  
Old 03-13-2010, 01:02 AM
boss_hemi's Avatar
Premium Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2009
Location: Jackson, Michigan
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1873
boss_hemi is on a distinguished road
Re: Service 4wd on help!!!!!

i read the forums and a common problem is the crankshaft position sensor.. my 05 limited is having the same issue so im sending it to the dealership next week to confirm that's the problem..
__________________
Reply With Quote
  #16  
Old 04-15-2010, 08:58 PM
New Member
 
Join Date: Apr 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Topcat is on a distinguished road
Re: Service 4wd on help!!!!!

I just started getting the service 4wd on my 05, no codes will show. It will only come on when it has sat overnight or sat long enough to cool down. When I start it after it is warmed up it won't come on again until it has cooled down again.
__________________
Reply With Quote
  #17  
Old 04-16-2010, 10:47 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,085
Thanks: 139
Thanked 163 Times in 153 Posts
Rep Power: 1255323
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: Service 4wd on help!!!!!

there is a tsb for this. the dealer performed the tsb on my jeep and i never got the false waning again.
__________________
Reply With Quote
  #18  
Old 04-17-2010, 07:08 PM
Chaoul1's Avatar
The Original

My Jeep: 2010 6.1L WK
 
Join Date: May 2009
Location: Fairfax, Virginia
Posts: 6,913
Thanks: 2
Thanked 24 Times in 24 Posts
Rep Power: 63345
Chaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond repute
Re: Service 4wd on help!!!!!

Mine just came on today too. I'm just going to change the fluid next week along with the differentials and unplug the battery while doing it. And will try and see if it shows back up.
__________________
-Paul-
2010 Jeep Grand Cherokee SRT8

PaulsProfessional Automotive Detailing

PPAD's Custom Headlights

Contact for both DetailingPPADscustomwork@yahoo.com
Reply With Quote
  #19  
Old 04-18-2010, 10:24 AM
apstang50's Avatar
Member
My Jeep: 1998 5.9L ZJ
 
Join Date: Jan 2010
Location: West Yarmouth, MA
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1785
apstang50 is on a distinguished road
Garage
Re: Service 4wd on help!!!!!

You probably need to replace the 4wd switch that is screwed into the TC.
__________________

__________________
98 Platinum 5.9 GC-Flowmaster, clear corners, white face indigo gauges,relocated IAC, Accel coil, Summit 8mm wires, Mopar front tow hooks, Mopar Performance PCM, K&N Gen 2 FIPK

90 LX mustang notchback- Cobra intake, CAI, 1 3/4" long tube headers, off road h-pipe, 2 chamber Flowmasters, Griffin alu. rad, e-fan, 373 gears, sub frame connectors, underdrive pullies, autometer gauges

thespeedfreaks.net
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community