Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-12-2009, 02:27 PM
CatMan879's Avatar
Member
My Jeep: 2008 5.7L WK
 
Join Date: Jun 2009
Location: Jacksonville, FL
Posts: 376
Thanks: 2
Thanked 2 Times in 2 Posts
Rep Power: 8541
CatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond repute
service 4wd system

Has anyone ever had this I'm in NC on my way to FL and it popped up and went away the jeep still feels strong no issue besides that
__________________

__________________
Reply With Quote
  #2  
Old 09-12-2009, 02:33 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,749
Thanks: 825
Thanked 804 Times in 620 Posts
Rep Power: 7717315
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: service 4wd system

theres another thread on here right now with the same thing. Your gonna have to pull the code and post it to give us a chance. This happens alot with the WK's and is usually nothing.
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #3  
Old 09-12-2009, 02:47 PM
Member
 
Join Date: Jun 2009
Location: Edmonton, Alberta
Posts: 326
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2205
5.7Unlimited is just really nice
Re: service 4wd system

One time on ice I turned ESP off and floored it for a couple of seconds from a stand still for the hell of it, service 4wd system popped up in my EVIC and went away after about 20 seconds, it didnt make a code and there was never any issues.
__________________
-Jeremy
2011 Grand Cherokee Limited 5.7 Silver
Reply With Quote
  #4  
Old 09-12-2009, 03:54 PM
CatMan879's Avatar
Member
My Jeep: 2008 5.7L WK
 
Join Date: Jun 2009
Location: Jacksonville, FL
Posts: 376
Thanks: 2
Thanked 2 Times in 2 Posts
Rep Power: 8541
CatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond reputeCatMan879 has a reputation beyond repute
Re: service 4wd system

Well I'm not pulling any codes so it seems ok and I checked the under the chassis and everything seems good
__________________
Reply With Quote
  #5  
Old 09-12-2009, 04:02 PM
06SRT8300C's Avatar
Member
 
Join Date: Jun 2009
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1992
06SRT8300C is on a distinguished road
Re: service 4wd system

Mine came on while driving to my sisters house in DE and was only on for like 2 min than went away. It was raining so dont know if that has anything to do with it.
__________________
Reply With Quote
  #6  
Old 09-12-2009, 04:23 PM
hemi.jon's Avatar
Member
 
Join Date: May 2009
Posts: 802
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2727
hemi.jon has a reputation beyond reputehemi.jon has a reputation beyond reputehemi.jon has a reputation beyond repute
Re: service 4wd system

its just a POS tcase...boooo....lol
__________________
Reply With Quote
  #7  
Old 09-13-2009, 01:17 AM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: Goose Creek, SC
Posts: 2,186
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 4130
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: service 4wd system

It if comes on and goes away it shouldn't be a problem. Mine came on and stays on now... I don't get a code if I do the key dance but using the superchips I pull code C141D I believe it is. I have to replace the solenoid in the rear axle that controls the ELSD. It is like a $25 part but I'm going to wait until I change my rear diff fluid in a month or so to change the solenoid. The truck still drives totally normal, I just assume that the ELSD won't be workin on my rear axle because the solenoid is shot.
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #8  
Old 09-13-2009, 03:20 AM
chefalan23's Avatar
Member
 
Join Date: Aug 2009
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2005
chefalan23 is on a distinguished road
Re: service 4wd system

2wd ftw
__________________
07 JGC 2wd HEMI
4" Round Magnaflow with Reso Delete, Side Exit
93 oct Predetor Tune
MTX terminator
Reply With Quote
  #9  
Old 09-13-2009, 08:53 AM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: Goose Creek, SC
Posts: 2,186
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 4130
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: service 4wd system

Quote:
Originally Posted by chefalan23 View Post
2wd ftw


2WD FTL
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #10  
Old 09-13-2009, 12:15 PM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: service 4wd system

Yeah not gunna lie, 4wd is always >>>>>> 2wd.....
__________________
Reply With Quote
  #11  
Old 09-13-2009, 12:30 PM
chefalan23's Avatar
Member
 
Join Date: Aug 2009
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2005
chefalan23 is on a distinguished road
Re: service 4wd system

i realized how useless 2wd is the other day when i tried to back over a wet curb.
__________________
07 JGC 2wd HEMI
4" Round Magnaflow with Reso Delete, Side Exit
93 oct Predetor Tune
MTX terminator
Reply With Quote
  #12  
Old 05-25-2010, 11:49 AM
Member
My Jeep: 2006 WK
 
Join Date: Apr 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1552
wilbert is on a distinguished road
Re: service 4wd system

The wife has been saying that her 2006 3.0CRD has been making some "strange noises" when turning on half to full lock when driving in / out or reversing out of the drive when the engine is cold. It has the QDII and I assume the ELSD as standard. I have watched her back out of the drive and although I can't really hear the noise from the outside I can see the front right tyre which is on the outside of the bend "scrabbling" for grip as if the diff is locked up and its turning at a diferent speed to the other wheels. Once warm this problem seems to go away however the "service 4X4 sytem" light came on the other day whilst driving. i can feel this hapening when I drive the car from cold but I only drive it once a month or less. I asked local garrage to change the diff oil the other day so i could start to eliminate things 1 by 1 and much to my dissapointment they didn't as in their veiw the oil was in good condition. Would it worth taking it to the main stealers and paying mega 's. What else should I be having a look at? ie any sofware updates, solenoids, wiring or electrical connections.

Thanks in advance.

Dave
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My system downgrade - Finished w87will Audio, Video, Navigation & Electronic Modifications 80 10-27-2010 10:49 PM
Service 4wd on help!!!!! jeeppro Troubleshooting/Problems Discussion 18 04-18-2010 10:24 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community