Transmission fault codes (?) - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-21-2015, 10:11 AM
Member
 
Join Date: Jul 2012
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1827
RLM67 is on a distinguished road
Transmission fault codes (?)

Check engine light comes on, I pull the P0700 code, then get it scanned at Advance Auto-- they pull 0733 & 0734 (incorrect 3rd & 4th gear ratio incorrect, respectively). They also pull 1784, which I can't find a reference for. I have 2000 Jeep GC Ltd. 4.7L with 285k miles. Symptoms are similar to "limp mode" with higher rpms at freeway speeds--2500-2700rpms at 55-65 mph. Fluid level is normal. I replaced the solenoid pack about a year ago.


Sent from my iPhone using JeepGarage

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-21-2015, 06:13 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,615
Thanks: 23
Thanked 424 Times in 409 Posts
Rep Power: 529937
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission fault codes (?)

The P1784 code means LR pressure switch circuit. The other two codes mean that the transmission is slipping in 3rd and 4th gear.
After ignition off, does it shift normally? Most of the time, when it goes into limp mode, it will reset after ignition off. If the fault is still there, it will go into limp mode again.
Fluid level is normal, but how it the color and smell? No burnt smell to the fluid?
I would start by checking the large connector on the solenoid pack. Check for moisture or corrosion on the pins.
If that looks ok, than you most probably will need to pull the pan and check for any debris, but first check the following:
It can be that the line pressure is too low, causing the slipping in 3rd and 4th gear and the failure of the LR pressure switch. You could try to remove the line pressure sensor connector on the RH side of the transmission housing and test again. The TCM will set the pressure regulator solenoid in a fixed position in that case. If it than works ok, i would change the line pressure sensor.
If still not ok, than you will have to remove the valve body and check the clutches with air pressure and listen for a large air leak inside the transmission. If no large leak is present, you will hear a thumb from the clutch piston when it actuates. If no leaks present internally, than you can have a problem with the solenoid block (again), or the gasket between the solenoid block and the valve body. This gasket is quite fragil and can normally only be used once.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
The Following User Says Thank You to Frango100 For This Useful Post:
  #3  
Old 12-22-2015, 08:46 PM
Member
 
Join Date: Jul 2012
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1827
RLM67 is on a distinguished road
Re: Transmission fault codes (?)

The fluid has a reddish-brownish color, good, smooth viscosity--the odor is not burnt as much as "used" in the same way used oil smells when one changes the oil regularly. The MIL went off after about 45 miles or so and runs fine unless I accelerate hard, then it does race and slip a bit. To test the line pressure sensor, do I disconnect/remove it, and turn key on accessory/or start it to test it? Would I/O sensors affect performance in this way?


Sent from my iPhone using JeepGarage
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 12-22-2015, 10:33 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,615
Thanks: 23
Thanked 424 Times in 409 Posts
Rep Power: 529937
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission fault codes (?)

Just remove the connector from the line pressure sensor and testdrive. The line pressure will go to a fixed value. You could eventually try a line pressure booster from Sonax. It is a resistor, which will change the line pressure feedback signal, so that a higher line pressure will be obtained (approx 15 psi i believe). If the slipping is caused by a worn clutch pack, than the higher line pressure can give you a bit more time before an overhaul will be needed.
Slipping in 3rd and 4th gear is most probably due to the overdrive clutch.
I would not expect a speed sensor problem, since you confirmed it to be slipping. (abnormal engine flare during acceleration)
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep CRD, No Power or fault codes, Oh dear! startech01 Diesel Powered WK Grand Cherokee 5 01-28-2013 12:41 PM
More Fault Codes... Amelie Troubleshooting/Problems 15 04-01-2012 10:44 AM
Jeep CRD, No Power or fault codes, Oh dear! startech01 Troubleshooting/Problems 0 01-31-2012 11:22 AM
Grand cherokee wj fault codes SRNAUTOS Troubleshooting/Problems 3 12-14-2010 02:21 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:48 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.