Uconnect 8.4 losing Settings and Freezing - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-22-2016, 07:44 AM
mjt57's Avatar
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Oct 2015
Location: Gippsland, VIC, Australia
Posts: 187
Thanks: 13
Thanked 14 Times in 13 Posts
Rep Power: 759
mjt57 has much to be proud of
Uconnect 8.4 losing Settings and Freezing

I have a 2015 Jeep Grand Cherokee Limited. The radio in Uconnect is losing its programmed resets. Further, I can't change from AM to FM or vice versa, depending on what it's set to when I start the car. It stays stuck on that radio station.

I can tap either AM or FM or DAB and the selected option is highlighted but the radio does nothing.

I can select media or climate or Nav and that works.

It'll fix itself when I leave the car and return to it. But not always.

Car is going in for its 20,000 km (12,000 miles) service soon. Hopefully they have a fix for it.

Just wondering who else has experienced this.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-22-2016, 08:53 PM
Barboots's Avatar
Senior Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 2,471
Thanks: 138
Thanked 356 Times in 302 Posts
Rep Power: 42527
Barboots has disabled reputation
Re: Uconnect 8.4 losing Settings and Freezing

Have you hard rebooted Uconnect? Tried reinstalling the firmware???
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #3  
Old 12-22-2016, 10:08 PM
bill_de's Avatar
Premium Member
My Jeep: 2017 5.7L WK2
 
Join Date: Sep 2012
Posts: 8,597
Thanks: 732
Thanked 1,064 Times in 825 Posts
Rep Power: 1805962
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Uconnect 8.4 losing Settings and Freezing

Quote:
Originally Posted by Barboots View Post
Have you hard rebooted Uconnect? Tried reinstalling the firmware???
And if that doesn't work try disconnecting your battery for 10-15 minutes.

--
__________________
If you need a shoulder to cry on ...
... pull over to the side of the road!

Reply With Quote
  #4  
Old 12-23-2016, 05:07 AM
mjt57's Avatar
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Oct 2015
Location: Gippsland, VIC, Australia
Posts: 187
Thanks: 13
Thanked 14 Times in 13 Posts
Rep Power: 759
mjt57 has much to be proud of
Re: Uconnect 8.4 losing Settings and Freezing

No. I've not tried any of those things. Nor am I about to. It's under warranty, I'll let Jeep fix it.

Besides, I don't know how to reinstall the firmware.
Reply With Quote
  #5  
Old 12-23-2016, 06:09 AM
Barboots's Avatar
Senior Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 2,471
Thanks: 138
Thanked 356 Times in 302 Posts
Rep Power: 42527
Barboots has disabled reputation
Re: Uconnect 8.4 losing Settings and Freezing

All three are dead easy, but if you want to visit the dealer that's an option for you. However it's definitely the last one I'd choose... their coffee is rubbish, and the other three options would save a trip.

To answer your question as written... yes I've had Uconnect lock up.

Ciao,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #6  
Old 12-23-2016, 07:37 AM
bill_de's Avatar
Premium Member
My Jeep: 2017 5.7L WK2
 
Join Date: Sep 2012
Posts: 8,597
Thanks: 732
Thanked 1,064 Times in 825 Posts
Rep Power: 1805962
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Uconnect 8.4 losing Settings and Freezing

Quote:
Originally Posted by Barboots View Post
All three are dead easy, but if you want to visit the dealer that's an option for you. However it's definitely the last one I'd choose... their coffee is rubbish, and the other three options would save a trip.

To answer your question as written... yes I've had Uconnect lock up.

Ciao,
Steve
That was my thought also, but he said he plans a trip to the dealer anyway. He can always refer back here if the dealer says they can't duplicate the problem.

---
__________________
If you need a shoulder to cry on ...
... pull over to the side of the road!

Reply With Quote
  #7  
Old 12-23-2016, 05:53 PM
mjt57's Avatar
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Oct 2015
Location: Gippsland, VIC, Australia
Posts: 187
Thanks: 13
Thanked 14 Times in 13 Posts
Rep Power: 759
mjt57 has much to be proud of
Re: Uconnect 8.4 losing Settings and Freezing

Quote:
Originally Posted by bill_de View Post
That was my thought also, but he said he plans a trip to the dealer anyway. He can always refer back here if the dealer says they can't duplicate the problem.

---
The car is going in for its 20,000km service, so they can look at it then. When I spoke to the service manager about it I was told that an update for it was coming in January. Hopefully before I get the car serviced. But I've videoed it with the phone camera to show them what I'm seeing.
Reply With Quote
  #8  
Old 12-23-2016, 07:27 PM
Barboots's Avatar
Senior Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 2,471
Thanks: 138
Thanked 356 Times in 302 Posts
Rep Power: 42527
Barboots has disabled reputation
Re: Uconnect 8.4 losing Settings and Freezing

If you've tried a reboot, firmware reinstallation and perhaps battery disconnection, you're several steps ahead in what the dealer will do. I'd find it annoying to wait, have them just reboot it, then have the problem reoccur shortly after picking it up... so would try all the easy stuff myself and allow the time between now and then to prove it out.
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #9  
Old 12-23-2016, 08:07 PM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2013
Location: NSW Australia
Posts: 1,466
Thanks: 268
Thanked 287 Times in 219 Posts
Rep Power: 19560
SJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond repute
Re: Uconnect 8.4 losing Settings and Freezing

What version of Uconnect are you currently running?
__________________
'07 WK Limited 5.7 Hemi (Sold)
'14 WK2 Overland CRD - ORAII
'15 KL Limited CRD - ADII, Tech Group, Electronics Group and Pano.
Reply With Quote
  #10  
Old 12-23-2016, 09:02 PM
mjt57's Avatar
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Oct 2015
Location: Gippsland, VIC, Australia
Posts: 187
Thanks: 13
Thanked 14 Times in 13 Posts
Rep Power: 759
mjt57 has much to be proud of
Re: Uconnect 8.4 losing Settings and Freezing

Quote:
Originally Posted by SJandL View Post
What version of Uconnect are you currently running?
Dunno. Whatever was current when I bought it in Oct 2015.
Reply With Quote
  #11  
Old 12-23-2016, 10:03 PM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2013
Location: NSW Australia
Posts: 1,466
Thanks: 268
Thanked 287 Times in 219 Posts
Rep Power: 19560
SJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond reputeSJandL has a reputation beyond repute
Re: Uconnect 8.4 losing Settings and Freezing

You're a bit behind then. V16.13.13 came out in the middle of the year.

You can do the update yourself if you wish. It's easy. Takes about 15 minutes to download and then approx. 20 minutes to install on the vehicle.

Enter your VIN in here: Uconnect® Software Update - Update your Uconnect® System which will show you the latest update and follow the instructions for direct download if you want to do it yourself.
__________________
'07 WK Limited 5.7 Hemi (Sold)
'14 WK2 Overland CRD - ORAII
'15 KL Limited CRD - ADII, Tech Group, Electronics Group and Pano.
Reply With Quote
  #12  
Old 12-24-2016, 09:51 PM
mjt57's Avatar
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Oct 2015
Location: Gippsland, VIC, Australia
Posts: 187
Thanks: 13
Thanked 14 Times in 13 Posts
Rep Power: 759
mjt57 has much to be proud of
Re: Uconnect 8.4 losing Settings and Freezing

Thanks. I'll have a look. However, I won't do it until after Christmas. If I stuff it up I'll then have to wait til the dealer is open...
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UConnect 8.4 Losing Settings. mjt57 Audio/Visual/Navigation 6 08-30-2016 01:08 AM
UConnect losing device names RandomActs13x Audio/Visual/Navigation 0 10-09-2015 07:35 AM
Radio keeps losing settings Anand Trouble Shooting/Problems/Service 2 07-17-2013 04:53 PM
UConnect / Bluetooth losing connection dPtQu3 Trouble Shooting/Problems/Service 4 06-16-2013 12:40 PM
Uconnect 730N keeps losing the pairing to iPhone 5 SLGF Grand Cherokee - WK2 - 0 04-06-2013 12:47 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.