Go Back   Jeep Garage - Jeep Forum > Jeep Technical Discussion > Troubleshooting/Problems Discussion

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-29-2013, 02:06 PM
ACguyYYZ's Avatar
Member
My Jeep: 2014 3.6L
 
Join Date: Apr 2013
Location: Mississauga, Ontario
Posts: 38
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 496
ACguyYYZ is on a distinguished road
Garage
Wtf

So, has anyone else had this happen to them?
I bought a 2014 Limited back in March of this year, and this is the 2nd time this has happened to me. I started it up this afternoon and was going to take it for a wash, when all a sudden my entire dash lights up like a Christmas tree. I get messages saying to service the electronic brake, the abs system, park sense is inop, no traction and worst of all, the speedometer is inop as well.


image-2640558020.jpg

I just dropped it off unannounced to my dealer, and told them I didn't want it back until it's been fixed. Now the waiting game.
__________________

__________________
Reply With Quote
  #2  
Old 10-29-2013, 02:45 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,003
Thanks: 16
Thanked 53 Times in 48 Posts
Rep Power: 43387
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Wtf

Quote:
Originally Posted by ACguyYYZ View Post
So, has anyone else had this happen to them?
I bought a 2014 Limited back in March of this year, and this is the 2nd time this has happened to me. I started it up this afternoon and was going to take it for a wash, when all a sudden my entire dash lights up like a Christmas tree. I get messages saying to service the electronic brake, the abs system, park sense is inop, no traction and worst of all, the speedometer is inop as well.

I just dropped it off unannounced to my dealer, and told them I didn't want it back until it's been fixed. Now the waiting game.
Yes [search for Xmas tree], and there are a few causes, plus a TSB.

Often turning it off, open/close driver door, turn it back on can clear it....
__________________

__________________
Reply With Quote
  #3  
Old 10-29-2013, 02:46 PM
ACguyYYZ's Avatar
Member
My Jeep: 2014 3.6L
 
Join Date: Apr 2013
Location: Mississauga, Ontario
Posts: 38
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 496
ACguyYYZ is on a distinguished road
Garage
Tried that. No dice. It's the dealers issue now lol
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
:o wtf????? CherokeeOnToyos Grand Cherokee - WJ 13 05-11-2010 07:20 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community