Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - ZJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-18-2012, 11:30 AM
New Member
 
Join Date: Apr 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mfre111 is on a distinguished road
Angry 94 4.0 Starts and dies (every time)

This is a tough one. It has a new computer and crank position sensor. I will give a run down on it. I am trying to help a friend with this. He put the battery in backwards and fried the computer. He installed a new computer and it started and ran for about 2 months. It just died. He had a guy come over to diagnose it and they put in a new Crank Position sensor and a computer. Here is what is happening. It will stay running when starting fluid is sprayed in the throttle body. It runs for about 2 or 3 seconds when we don't spray starting fluid in the throttle body. I checked the fuel pressure and it is at 35 psi. I unplugged the injectors and put a noid light on each wire and cranked the engine. The noid light flashes correctly on all cylinders. When I plug back in all the injectors except one and check with the noid light, It will start and die and the noid light will flash 1 or 2 times and then stop flashing. I checked the ohms on the injectors and they are all 14.2 which from what I have read is within specs. I pulled the injector rail and turned the engine over and all 6 of the injectors are spraying fuel in blasts, one at a time as it seems they should. I put it all back together and it still starts and dies. I checked the continuity on the wires between the computer harnes plug and the plug in at both the crank positions sensor and the cam position sensor (distributor) and they are all reading great. Now I put in another new crank position sensor and a new distributor. It still does the same thing. Starts and then dies. Anyone with suggestions would be greatly appriciated. This vehicle has no codes and does not have an alarm system.
__________________

__________________
Reply With Quote
  #2  
Old 04-18-2012, 11:32 AM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,423
Thanks: 55
Thanked 133 Times in 115 Posts
Rep Power: 542735
robpp has disabled reputation
Re: 94 4.0 Starts and dies (every time)

what about the Throttle Position Sensor/ usually you change the CPS and the TPS at the same time.
__________________

__________________
Reply With Quote
  #3  
Old 04-20-2012, 02:43 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1653067
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: 94 4.0 Starts and dies (every time)

Did the crankshaft position sensor have a round mount hole or an oval hole (allowing in and out movement? There is a spec for the air gap on the sensor if it has an oval mount hole, there is actually a "green dot" that is basically a cardboard sticker that you stick to the end of the sensor that sets the proper gap on sensor installation. Also did you use an aftermarket ckp sensor or an OEM sensor? HIGHLY suggest the OEM. Not that this is for sure your problem but you would not be the first to have a bad brand new CKP sensor.

With you loosing the injector pulse after a couple seconds this sounds to me like an ASD relay being commanded off. ASD relay feeds the injectors and will be shut off for things like no crank signal at the pcm, it will come on for the initial startup but if it doesnt see a crank signal in so many seconds it shuts off. Honestly I am not sure if it will try to fire anything on just the camshaft position sensor.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starts in off road i after flash fix? WABCLawyers Suspension/Driveline/Brakes/Wheels/Tires 1 11-08-2011 01:13 AM
SRT Tour starts Friday!!!! The schedule has been posted VerbalKint Grand Cherokee SRT - WK2 15 08-11-2011 08:20 AM
Anyone know when 2012 production starts? Jpjr Grand Cherokee - WK2 - 26 01-09-2011 08:04 PM
violent jerk on cold starts 06HemiLtd Troubleshooting/Problems Discussion 0 11-30-2010 08:37 AM
Grand Cherokee starts rough rhodesian Grand Cherokee - ZJ 1 11-05-2010 03:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.