Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - ZJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-18-2013, 04:01 PM
New Member
 
Join Date: Mar 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mr Matt is on a distinguished road
A bad new CPS

Hi,

I hope someone here can help with this, no mechanic has yet done so. Story is, a while ago, my 6 cylinder, 1996 grand jeep cherokee( Laredo) started bucking slightly, perodically. It eventually got worse to the point it stalled. The crankshaft position sensor was determined to be bad, it threw the code out for this.

Mechanic replaced it using an aftermarket item. Car ran ok, and soon a very slight noticeable shudder would occur as the engine was about warmed up. This tremor is now a strong shudder that usually comes on right before the engine is completely warmed up, lasts about 15 seconds, then all is fine.

You can pretty much drive it around the rest of the day ,even leaving the car off for a few hours but will not do it again, unless completely cooled down.

The only codes it throws now are cylinders misfiring- which is a secondary issue - something is giving the engine wrong information.

I am thinking the new aftermarket sensor, about 3 months old is partly bad or something, but is not giving off codes...


Have taken the jeep to 3 mechanics, one of them the jeep dealer, thinking they have seen everything, but so far this has them stumped.

Not sure if anyone else had this issue, again... hope you can help!

Thanks!

Matt
__________________

__________________
Reply With Quote
  #2  
Old 03-18-2013, 06:06 PM
Member
 
Join Date: Jan 2013
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 725
Jeeper79 is on a distinguished road
Re: A bad new CPS

Only possibility I can think of is an ignition coil. Have seen quite a few coils start to make the engine buck after it is warmed up. Usually runs great until the engine heats up and the coil actually heats up and opens internally.
Just an option
__________________

__________________
Reply With Quote
  #3  
Old 03-19-2013, 04:41 PM
New Member
 
Join Date: Mar 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mr Matt is on a distinguished road
Re: A bad new CPS

Thanks for taking the time to respond, I greatly appreciate it.

At one point I did think it was the coil, I removed it and measure the resistance of the windings... they were within spec.s so I thought that was not it... but maybe it sitll could be? Do you think it is possible?. By the way, at the time I bought a new coil just in case from NAPA, and the windings of the new coil were out of spec to what was in my jeep manual.....

I also replaced the TPS and that did not help....

Thanks!

Matt
__________________
Reply With Quote
  #4  
Old 03-19-2013, 10:23 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,302
Thanks: 9
Thanked 130 Times in 123 Posts
Rep Power: 526350
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: A bad new CPS

Aftermarket crank and cam sensors can give sometimes strange behaviour. Best is to stay with original sensors, to prevent surprises lateron. These sensors not always give a code when they donīt work properly.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 03-20-2013, 06:39 PM
New Member
 
Join Date: Mar 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mr Matt is on a distinguished road
Re: A bad new CPS

Thanks, that is beginning to be my conclusion..........
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad,Bad Week for Ole Silver cheapjeep Grand Cherokee - WJ 12 01-05-2013 09:13 PM
You know it's bad when: Wxchaser Detailing 13 10-29-2012 07:52 PM
Not bad for a 4.7.... i0r15 Grand Cherokee - WK 2 07-30-2012 09:23 AM
Bad battery or What ? ChrisWk Troubleshooting/Problems 9 01-18-2012 05:51 PM
How bad is This?? Blueflame1979 Grand Cherokee - WK 4 07-02-2011 05:14 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.