Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - ZJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-17-2011, 01:34 PM
Member
My Jeep: 1998 4.0L ZJ
 
Join Date: May 2011
Location: Thetford, UK
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1302
Ozz1967 is on a distinguished road
Coolant Temp Sensor Fault

Hey guys,

1998 Grand Cherokee Limited here. My computer thing in the center console in front of the shifter is calling out a "Coolant temp sensor" fault. It blinks in the engine bay area when going off.

I've already replaced the only sensor that i know to be a coolant temp sensor...the one in thermostat housing on the water neck. Is there another sensor some where I should check? She runs fine, the temp gauge reads correctly and doesn't over heat, but the constant beeping is driving me nuts. On the alternative, was there a reset button or something I should have pushed when I changed out the sensor to clear the original fault? I'm not the original owner and I don't have an owners manual to reference. Any help would be appreciated.
__________________

__________________
1998 Grand Cherokee Limited
Pontiac Owners Club (UK)[/URL]
http://www.cardomain.com/ride/2589724"]My 84 Trans Am[/URL]
http://www.cardomain.com/ride/2592401"]My 67 Camaro[/URL]
"Life is tough. It's tougher when your stupid!" (John Wayne)

"Life is tough. It's tougher when your stupid!" (John Wayne)
[I]Freedom Is Never Free!
Reply With Quote
  #2  
Old 10-17-2011, 02:19 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,418
Thanks: 55
Thanked 133 Times in 115 Posts
Rep Power: 542665
robpp has disabled reputation
Re: Coolant Temp Sensor Fault

have you tried disconnecting the neg terminal for a while see if the puter resets.......
__________________

__________________
Reply With Quote
  #3  
Old 10-17-2011, 03:04 PM
Member
My Jeep: 1998 4.0L ZJ
 
Join Date: May 2011
Location: Thetford, UK
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1302
Ozz1967 is on a distinguished road
Re: Coolant Temp Sensor Fault

No, I haven't, but I figured if it's anything like the Alero I had, there would be a reset button somewhere but I can't find one.
__________________
1998 Grand Cherokee Limited
Pontiac Owners Club (UK)[/URL]
http://www.cardomain.com/ride/2589724"]My 84 Trans Am[/URL]
http://www.cardomain.com/ride/2592401"]My 67 Camaro[/URL]
"Life is tough. It's tougher when your stupid!" (John Wayne)

"Life is tough. It's tougher when your stupid!" (John Wayne)
[I]Freedom Is Never Free!
Reply With Quote
  #4  
Old 10-20-2011, 10:02 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,048
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526031
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Coolant Temp Sensor Fault

As i mentioned in the other thread, have a look at the solders of the VIC circuit board. They can come loose after a long time and cause bad contact. Just resolder again.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 10-21-2011, 09:42 AM
LexSRT's Avatar
Member
My Jeep: 2008 SRT8
 
Join Date: Apr 2011
Location: In a van by the river
Posts: 51
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1332
LexSRT is on a distinguished road
Re: Coolant Temp Sensor Fault

I've heard of that and other problems of the V>I>C
__________________
Reply With Quote
  #6  
Old 11-20-2011, 09:36 PM
Member
My Jeep: 1996 4.0L ZJ
 
Join Date: Nov 2010
Location: Belmont, NH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1462
OffCenter is on a distinguished road
Re: Coolant Temp Sensor Fault

Its the V I C. board, its no big deal unless you want to re sale your jeep, Its a small crack. that take 10 sec to soder. but you have to take dash off i guess to get to it, mine does it too. has for last 3k mile. ask someone about with a jeep and they told me.
__________________
Reply With Quote
  #7  
Old 02-02-2012, 04:55 PM
Member
My Jeep: 1997 4.0L ZJ
 
Join Date: Jan 2012
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1100
1ABrian is on a distinguished road
Re: Coolant Temp Sensor Fault

Ditto in the VIC. If you decide to fix it, post pic of the Vic and how you fixed it
__________________
Brian
Reply With Quote
  #8  
Old 02-02-2012, 07:31 PM
Member
My Jeep: 1998 4.0L ZJ
 
Join Date: May 2011
Location: Thetford, UK
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1302
Ozz1967 is on a distinguished road
Re: Coolant Temp Sensor Fault

Quote:
Originally Posted by OffCenter View Post
Its the V I C. board, its no big deal unless you want to re sale your jeep, Its a small crack. that take 10 sec to soder. but you have to take dash off i guess to get to it, mine does it too. has for last 3k mile. ask someone about with a jeep and they told me.
Strangely enough, once the weather turned cold, the warning stopped popping up.

I wouldn't even know where to look for this "board" any way. Is it behind the screen where the warning is posted or somewhere else? This is my first Jeep so I'm really unfamiliar with them.
__________________
1998 Grand Cherokee Limited
Pontiac Owners Club (UK)[/URL]
http://www.cardomain.com/ride/2589724"]My 84 Trans Am[/URL]
http://www.cardomain.com/ride/2592401"]My 67 Camaro[/URL]
"Life is tough. It's tougher when your stupid!" (John Wayne)

"Life is tough. It's tougher when your stupid!" (John Wayne)
[I]Freedom Is Never Free!
Reply With Quote
  #9  
Old 02-03-2012, 11:24 AM
Member
My Jeep: 1997 4.0L ZJ
 
Join Date: Jan 2012
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1100
1ABrian is on a distinguished road
Re: Coolant Temp Sensor Fault

Try this. Hopefully the pics are viewable. I think page 5-6
http://www.jeepforum.com/forum/f13/c...-fixed-175207/
but read it all. Pretty helpful
__________________
Brian
Reply With Quote
  #10  
Old 02-07-2012, 04:20 PM
Member
My Jeep: 1997 4.0L ZJ
 
Join Date: Jan 2012
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1100
1ABrian is on a distinguished road
Re: Coolant Temp Sensor Fault

Just as a heads up, I did the VIC repair last night. Took my time and was a little over an hour start to finish. Drove around last night after and to work today in a BEEP FREE atmosphere. Worked like a charm.
__________________
Brian
Reply With Quote
  #11  
Old 03-01-2012, 05:41 AM
Member
My Jeep: 1998 4.0L ZJ
 
Join Date: May 2011
Location: Thetford, UK
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1302
Ozz1967 is on a distinguished road
Re: Coolant Temp Sensor Fault

My overflow bottle is empty now, and my radiator looks like it's got red sludge all in it, but still cools ok. Going to fill the overflow back up but...as of right now, no beepings or warnings.
__________________
1998 Grand Cherokee Limited
Pontiac Owners Club (UK)[/URL]
http://www.cardomain.com/ride/2589724"]My 84 Trans Am[/URL]
http://www.cardomain.com/ride/2592401"]My 67 Camaro[/URL]
"Life is tough. It's tougher when your stupid!" (John Wayne)

"Life is tough. It's tougher when your stupid!" (John Wayne)
[I]Freedom Is Never Free!
Reply With Quote
  #12  
Old 03-01-2012, 08:34 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,048
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526031
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Coolant Temp Sensor Fault

Red sludge could be from corrosion, you better flush the whole system and put fresh liquid into it.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
engine coolant sensor bad Gomer Troubleshooting/Problems Discussion 5 10-21-2011 10:34 AM
Intake Air Temp Sensor Location tommc4 Troubleshooting/Problems 6 09-09-2011 05:43 AM
Location of Eng Coolant sensor thud Troubleshooting/Problems 6 05-17-2011 02:18 PM
coolant leak - rad cap - temp gauge rvtifer Troubleshooting/Problems Discussion 9 12-22-2010 03:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community