Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - ZJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-05-2014, 11:00 AM
Bonesbrown's Avatar
Premium Member
My Jeep: 1998 4.0L ZJ
 
Join Date: Jan 2014
Location: Croydon, Pa
Posts: 17
Thanks: 1
Thanked 3 Times in 2 Posts
Rep Power: 259
Bonesbrown is on a distinguished road
Cool Sometimes a Problem is a simple fix

Last night my power windows quit working. Fortunately they were all closed. ( We are having nasty weather here lately) My hope was a blown fuse, but the power mirrors and other components tied to the same fuse still were working. I pulled the 50 amp fuse anyway to check it. Located under the hood in the power control center. The fuse was in fact still good. I did however notice that the blades of the fuse were a little dirty so I gave them a quick rub with a pencil eraser and a little wipe with some rubbing alcohol. This in fact fixed the problem. Power windows back up and running.
So because at first glance the fuse was not blown and the other features attached to this fuse still were functioning I could have made a costly mistake and taken it in to have a mechanic look into it.
__________________

__________________
Bones
Reply With Quote
The Following 2 Users Say Thank You to Bonesbrown For This Useful Post:
  #2  
Old 02-08-2014, 08:55 PM
sanjuro77's Avatar
Member
My Jeep: 1996 4.0L ZJ
 
Join Date: Dec 2013
Location: NE Ohio
Posts: 205
Thanks: 2
Thanked 17 Times in 15 Posts
Rep Power: 655
sanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond reputesanjuro77 has a reputation beyond repute
Nice catch!
After cleaning them you can put a little dilectric grease on the blades as a preventative measure against further corrosion, too.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Simple Upgrade? JWIN Audio/Visual/Navigation 34 03-24-2013 09:58 AM
2014 Changed Select Track (Fix for Sand problem?) lysol Interior/Exterior/Visual 2 01-17-2013 08:54 PM
Hummmm in front end... Known problem no fix kaflyboy Trouble Shooting/Problems/Service 2 05-05-2012 06:38 AM
Seemed like a simple thing tk7108 Audio/Visual/Navigation 3 01-27-2012 02:56 PM
Did Shudder TSB fix a problem? 2011 Shudder problems thread JoeSchmoe007 Trouble Shooting/Problems/Service 159 02-14-2011 09:11 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community